Previous Thread
Next Thread
New Reply
Print Thread
AEM GEN 1 CAI CEL's #97829 Feb 5, 11:26am Feb 5, 11:26am
Joined: May 2003
Posts: 5,346
LA
spaztikid OP
dikitzaps
1974 Toyota Celica
spaztikid OP

dikitzaps
1974 Toyota Celica

Joined: May 2003
Posts: 5,346
LA
AEM GEN 1 CAI CEL's
wtf is up with this thing... starting about a month ago every time i really push the car i get a CEL... i've read all the posts about it on NC and there is no solution.

My Intake has been on for about 1 year (8000 miles) now, i recently cleaned the filter and MAFS.

anyone else have this problem ?? how long has your CAI been on?

I know its installed properly...

Re: AEM GEN 1 CAI CEL's [Re: spaztikid] #97830 Feb 5, 11:50am Feb 5, 11:50am
Joined: Aug 2003
Posts: 566
Tilburg, The Netherlands
Immo
Senior Member
2000 Toyota Celica GT
Immo

Senior Member
2000 Toyota Celica GT

Joined: Aug 2003
Posts: 566
Tilburg, The Netherlands
hmm

have it on about 5 months, no problem(s) up to now


Re: AEM GEN 1 CAI CEL's [Re: spaztikid] #97831 Feb 5, 12:59pm Feb 5, 12:59pm
Joined: Jul 2003
Posts: 1,143
Austin, TX
2000 Black Toyota Celica GT booyaolian
Specialist
2000 Toyota Celica GT
booyaolian
2000 Black Toyota Celica GT
Specialist
2000 Toyota Celica GT

Joined: Jul 2003
Posts: 1,143
Austin, TX
Originally Posted by spaztikid
wtf is up with this thing... starting about a month ago every time i really push the car i get a CEL... i've read all the posts about it on NC and there is no solution.

My Intake has been on for about 1 year (8000 miles) now, i recently cleaned the filter and MAFS.

anyone else have this problem ?? how long has your CAI been on?

I know its installed properly...


maybe you should sell it and get an Injen CAI

Re: AEM GEN 1 CAI CEL's [Re: booyaolian] #97832 Feb 5, 1:01pm Feb 5, 1:01pm
Joined: May 2003
Posts: 5,346
LA
spaztikid OP
dikitzaps
1974 Toyota Celica
spaztikid OP

dikitzaps
1974 Toyota Celica

Joined: May 2003
Posts: 5,346
LA
Originally Posted by booyaolian
Originally Posted by spaztikid
wtf is up with this thing... starting about a month ago every time i really push the car i get a CEL... i've read all the posts about it on NC and there is no solution.

My Intake has been on for about 1 year (8000 miles) now, i recently cleaned the filter and MAFS.

anyone else have this problem ?? how long has your CAI been on?

I know its installed properly...


maybe you should sell it and get an Injen CAI


i've heard the same problems with Injen...

i think i'm gonna go to AEM and bitch at them untill they give me a 2gen for free... its not like its an ebay rip off, i payed like 220 for this thing when it came out over a year ago.

Re: AEM GEN 1 CAI CEL's [Re: spaztikid] #97833 Feb 5, 1:12pm Feb 5, 1:12pm
Joined: Jul 2003
Posts: 1,143
Austin, TX
2000 Black Toyota Celica GT booyaolian
Specialist
2000 Toyota Celica GT
booyaolian
2000 Black Toyota Celica GT
Specialist
2000 Toyota Celica GT

Joined: Jul 2003
Posts: 1,143
Austin, TX
Originally Posted by spaztikid
Originally Posted by booyaolian
Originally Posted by spaztikid
wtf is up with this thing... starting about a month ago every time i really push the car i get a CEL... i've read all the posts about it on NC and there is no solution.

My Intake has been on for about 1 year (8000 miles) now, i recently cleaned the filter and MAFS.

anyone else have this problem ?? how long has your CAI been on?

I know its installed properly...


maybe you should sell it and get an Injen CAI


i've heard the same problems with Injen...

i think i'm gonna go to AEM and bitch at them untill they give me a 2gen for free... its not like its an ebay rip off, i payed like 220 for this thing when it came out over a year ago.


good luck!!!

will an Injen Short Ram have the same problem?

Re: AEM GEN 1 CAI CEL's [Re: booyaolian] #97834 Feb 5, 1:13pm Feb 5, 1:13pm
Joined: May 2003
Posts: 5,346
LA
spaztikid OP
dikitzaps
1974 Toyota Celica
spaztikid OP

dikitzaps
1974 Toyota Celica

Joined: May 2003
Posts: 5,346
LA
i dont know personally.

Re: AEM GEN 1 CAI CEL's [Re: spaztikid] #97835 Feb 5, 2:38pm Feb 5, 2:38pm
Joined: Sep 2003
Posts: 22
SoCal
2000 Red Toyota Celica GT SimpleGuy215
Member
2000 Toyota Celica GT
SimpleGuy215
2000 Red Toyota Celica GT
Member
2000 Toyota Celica GT

Joined: Sep 2003
Posts: 22
SoCal
Originally Posted by spaztikid
wtf is up with this thing... starting about a month ago every time i really push the car i get a CEL... i've read all the posts about it on NC and there is no solution.

My Intake has been on for about 1 year (8000 miles) now, i recently cleaned the filter and MAFS.

anyone else have this problem ?? how long has your CAI been on?

I know its installed properly...


you might want to check the steronoid (not sure if that's how you spell it) it's a small cylinder device that was attached to the air box. i had a problem with mine and the CEL light came on too eveytime i pushed the car but i don't have a CAI. dunno hope it helps wave

Re: AEM GEN 1 CAI CEL's [Re: SimpleGuy215] #97836 Feb 5, 2:40pm Feb 5, 2:40pm
Joined: May 2003
Posts: 5,346
LA
spaztikid OP
dikitzaps
1974 Toyota Celica
spaztikid OP

dikitzaps
1974 Toyota Celica

Joined: May 2003
Posts: 5,346
LA
Originally Posted by SimpleGuy215
Originally Posted by spaztikid
wtf is up with this thing... starting about a month ago every time i really push the car i get a CEL... i've read all the posts about it on NC and there is no solution.

My Intake has been on for about 1 year (8000 miles) now, i recently cleaned the filter and MAFS.

anyone else have this problem ?? how long has your CAI been on?

I know its installed properly...


you might want to check the steronoid (not sure if that's how you spell it) it's a small cylinder device that was attached to the air box. i had a problem with mine and the CEL light came on too eveytime i pushed the car but i don't have a CAI. dunno hope it helps wave


you meen solenoid right? ... i will check it, but i dont think thats the problem.

Re: AEM GEN 1 CAI CEL's [Re: spaztikid] #97837 Feb 5, 3:05pm Feb 5, 3:05pm
Joined: Jul 2002
Posts: 10,123
Milford, NJ
VSGTS14
05 WRB
2005 Subaru WRX STi
VSGTS14

05 WRB
2005 Subaru WRX STi

Joined: Jul 2002
Posts: 10,123
Milford, NJ
Injen... thumbsup thumbsup thumbsup


SUBARU TECNICA INTERNATIONAL
Re: AEM GEN 1 CAI CEL's [Re: VSGTS14] #97838 Feb 5, 3:33pm Feb 5, 3:33pm
Joined: May 2003
Posts: 5,346
LA
spaztikid OP
dikitzaps
1974 Toyota Celica
spaztikid OP

dikitzaps
1974 Toyota Celica

Joined: May 2003
Posts: 5,346
LA
Originally Posted by VSGTS14
Injen... thumbsup thumbsup thumbsup


how many mile do you have on your Injen... have you drive HARD with the Intake for more than 5 mins? I'm thinking about buying an Injen RD.

Re: AEM GEN 1 CAI CEL's [Re: spaztikid] #97839 Feb 5, 4:21pm Feb 5, 4:21pm
Joined: Jul 2003
Posts: 421
Florence SC
Elkal900
Senior Member
2000 Toyota Celica
Elkal900

Senior Member
2000 Toyota Celica

Joined: Jul 2003
Posts: 421
Florence SC
Ive had my CAI on since I think OCT last year and I drive hard a good bit, with no"problems confused

Re: AEM GEN 1 CAI CEL's [Re: Elkal900] #97840 Feb 5, 4:22pm Feb 5, 4:22pm
Joined: May 2003
Posts: 5,346
LA
spaztikid OP
dikitzaps
1974 Toyota Celica
spaztikid OP

dikitzaps
1974 Toyota Celica

Joined: May 2003
Posts: 5,346
LA
gen1 or 2?

Re: AEM GEN 1 CAI CEL's [Re: spaztikid] #97841 Feb 5, 4:23pm Feb 5, 4:23pm
Joined: Jul 2002
Posts: 10,123
Milford, NJ
VSGTS14
05 WRB
2005 Subaru WRX STi
VSGTS14

05 WRB
2005 Subaru WRX STi

Joined: Jul 2002
Posts: 10,123
Milford, NJ
Originally Posted by spaztikid
Originally Posted by VSGTS14
Injen... thumbsup thumbsup thumbsup


how many mile do you have on your injen... have you drive HARD with the intake for more than 5 mins? I'm thinking about buying an injen RD.


idk how many are on it...but i have shortram and yes we have hit lift a couple of times with it on...sounds good thumbsup


SUBARU TECNICA INTERNATIONAL
Re: AEM GEN 1 CAI CEL's [Re: spaztikid] #97842 Feb 5, 4:30pm Feb 5, 4:30pm
Joined: Jul 2003
Posts: 421
Florence SC
Elkal900
Senior Member
2000 Toyota Celica
Elkal900

Senior Member
2000 Toyota Celica

Joined: Jul 2003
Posts: 421
Florence SC
Originally Posted by spaztikid
gen1 or 2?


its a gen1

Re: AEM GEN 1 CAI CEL's [Re: spaztikid] #97843 Feb 5, 5:44pm Feb 5, 5:44pm
Joined: Oct 2003
Posts: 1,227
New Jersey
hephaestus
Specialist
hephaestus

Specialist

Joined: Oct 2003
Posts: 1,227
New Jersey
Originally Posted by spaztikid
Originally Posted by VSGTS14
Injen... thumbsup thumbsup thumbsup


how many mile do you have on your injen... have you drive HARD with the intake for more than 5 mins? I'm thinking about buying an injen RD.

I had my Injen CAI for about a year and a half. Let's say 17,000 miles? Loved it from the first day I had it installed and hit lift. I drive hard sometimes close to a half hour at a time. I also had a problem with a CEL one year after install. Nothing before until I was driving hard one day and there it was. It stayed there for a couple of months this is after trying the battery trick several times. I then read how people from this site tried cleaning the MAFS and I tried it with the battery trick again. Haven't had the CEL since. If that didn't work I was prepared for the only thing I could do. Take it to Toyota and play the runaround, checking codes, we don't know, take the Intake off, it's fixed, oh! the CELs back, we don't know, checking codes again game.

Join the conversation - Register Now or Log In to add your comment


Moderated by  isaac 

Member Spotlight
Sancho
Sancho
2004 Toyota Celica GT
San Diego, CA

Posts: 1,003
Joined: June 2004
Thanks: Blue BatMobile for sponsorship, Isaac for installing strut bar, Easy_C for being a great friend, Sakara for entertainment, DaBigTickett for the laughs. Everyone at Ecelica! You guys rock!
Random: How many emo kids does it take to screw in a lightbulb?
None, they just sit in the dark and cry.
Show All Member Profiles 
Recent Topics
Apexi N1 Exhaust
by michael2111. 09/24/2017 8:58 PM
Gen 7, remove tailgate help.
by Seanseansean. 09/24/2017 12:53 AM
Need help with my Fuel system, exhaust, or ??
by JRob1010. 09/22/2017 4:05 PM
First Toyota, Celica gt-s
by MiataMan. 09/22/2017 6:58 AM
FS: 18 in rims Rays Wolf 77
by WAYNESKI777. 09/20/2017 10:02 AM
Need help wiring a splice in tail light converter.
by seefeldt321. 09/19/2017 3:26 PM
System 10 Speakers not working
by willlcurry. 09/18/2017 3:35 PM
how do u bleed clutch line
by scorpionafw. 09/12/2017 3:20 PM
Customize Your Toyota Celica Privacy Policy · About · Contact
Privacy Policy · About · Contact
CelicaHobby.com is an independent Toyota Celica enthusiast website. CelicaHobby.com is not sponsored by or affiliated with Toyota Motor Sales, USA, Inc. in any way. The Toyota and Celica names and logos are trademarks owned by Toyota Motor Sales, USA, Inc.
© CelicaHobby.com, 2001-2017
Powered by UBB.threads™ PHP Forum Software 7.6.1
(Snapshot build 20170920)