Previous Thread
Next Thread
New Reply
Print Thread
Joined: Jun 2003
Posts: 509
FPcelica
Senior Member
FPcelica
2001 Spectra Blue Mica Toyota Celica GT
Senior Member
2001 Toyota Celica GT

Joined: Jun 2003
Posts: 509
Houston, TX
Jan 20, 8:20pm - #87196 
engine noise...

ever since my car took a dive in the water... i have noticed that the motor i think its the alternator has been making this like spooling up sound like a "turbo" i was wandering if this was normal. my dad was saying it was the belting squeaking but i dont think its that


[Linked Image]
Joined: Apr 2003
Posts: 2,451
DiabloGTS
Wheezy Joe
DiabloGTS

Wheezy Joe
2002 Kawasaki Ninja 250

Joined: Apr 2003
Posts: 2,451
Lafayette, LA
Jan 20, 8:24pm - #87197 
is the stereo on?

could be feedback from a bad ground.

If not, could be alternator


To have played and laughed with enthusiasm
and sung with exultation
To know even one life has breathed easier
This is to have succeeded.
Joined: Jun 2003
Posts: 509
FPcelica
Senior Member
FPcelica
2001 Spectra Blue Mica Toyota Celica GT
Senior Member
2001 Toyota Celica GT

Joined: Jun 2003
Posts: 509
Houston, TX
Jan 20, 8:31pm - #87198 
Originally Posted by DiabloGTS
is the stereo on?

could be feedback from a bad ground.

If not, could be alternator


no its off, i just installed a ground wire kit, but i didnt know where to put them so i just put them on somewhat random places wich i figured wouldnt matter but could that b the problem


[Linked Image]
Joined: Apr 2003
Posts: 2,451
DiabloGTS
Wheezy Joe
DiabloGTS

Wheezy Joe
2002 Kawasaki Ninja 250

Joined: Apr 2003
Posts: 2,451
Lafayette, LA
Jan 20, 9:20pm - #87199 
Originally Posted by FPcelica
Originally Posted by DiabloGTS
is the stereo on?

could be feedback from a bad ground.

If not, could be alternator


no its off, i just installed a ground wire kit, but i didnt know where to put them so i just put them on somewhat random places wich i figured wouldnt matter but could that b the problem


Possibly could cause a problem.


To have played and laughed with enthusiasm
and sung with exultation
To know even one life has breathed easier
This is to have succeeded.
Joined: Jun 2003
Posts: 509
FPcelica
Senior Member
FPcelica
2001 Spectra Blue Mica Toyota Celica GT
Senior Member
2001 Toyota Celica GT

Joined: Jun 2003
Posts: 509
Houston, TX
Jan 20, 9:22pm - #87200 
Originally Posted by DiabloGTS
Originally Posted by FPcelica
Originally Posted by DiabloGTS
is the stereo on?

could be feedback from a bad ground.

If not, could be alternator


no its off, i just installed a ground wire kit, but i didnt know where to put them so i just put them on somewhat random places wich i figured wouldnt matter but could that b the problem


Possibly could cause a problem.


well the ground wires r gone but it still makin the sound, i guess im gonna wait to the belts dry
or maybe take it in to b looked at


[Linked Image]
Joined: Apr 2003
Posts: 2,451
DiabloGTS
Wheezy Joe
DiabloGTS

Wheezy Joe
2002 Kawasaki Ninja 250

Joined: Apr 2003
Posts: 2,451
Lafayette, LA
Jan 20, 9:37pm - #87201 
Originally Posted by FPcelica
Originally Posted by DiabloGTS
Originally Posted by FPcelica
Originally Posted by DiabloGTS
is the stereo on?

could be feedback from a bad ground.

If not, could be alternator


no its off, i just installed a ground wire kit, but i didnt know where to put them so i just put them on somewhat random places wich i figured wouldnt matter but could that b the problem


Possibly could cause a problem.


well the ground wires r gone but it still makin the sound, i guess im gonna wait to the belts dry
or maybe take it in to b looked at


what kind of sound it is?

constant whir, pulse?


To have played and laughed with enthusiasm
and sung with exultation
To know even one life has breathed easier
This is to have succeeded.
Joined: Jun 2003
Posts: 509
FPcelica
Senior Member
FPcelica
2001 Spectra Blue Mica Toyota Celica GT
Senior Member
2001 Toyota Celica GT

Joined: Jun 2003
Posts: 509
Houston, TX
Jan 20, 10:08pm - #87202 
Originally Posted by DiabloGTS
Originally Posted by FPcelica
Originally Posted by DiabloGTS
Originally Posted by FPcelica
[quote=DiabloGTS]is the stereo on?

could be feedback from a bad ground.

If not, could be alternator


no its off, i just installed a ground wire kit, but i didnt know where to put them so i just put them on somewhat random places wich i figured wouldnt matter but could that b the problem


Possibly could cause a problem.


well the ground wires r gone but it still makin the sound, i guess im gonna wait to the belts dry
or maybe take it in to b looked at


what kind of sound it is?

constant whir, pulse? [/quote]

yea it goes with the revs, it sounds like a turbo, a lil bit, spooling up


[Linked Image]
Joined: Apr 2003
Posts: 896
element_celica
Senior Member
element_celica

Senior Member

Joined: Apr 2003
Posts: 896
Michigan
Jan 20, 11:00pm - #87203 
same thing's happening to my friends grand am.
sounds like it's the alternator.
he sprayed his alternator pulley/bearing w/ oil and it stopped for awhile.


rip celi...
95 240sx
Joined: Apr 2003
Posts: 2,451
DiabloGTS
Wheezy Joe
DiabloGTS

Wheezy Joe
2002 Kawasaki Ninja 250

Joined: Apr 2003
Posts: 2,451
Lafayette, LA
Jan 20, 11:02pm - #87204 
then it's most likely the alternator.

the other belts would whir or pulse, the alternator whirs when it revvs up! thumbsup


To have played and laughed with enthusiasm
and sung with exultation
To know even one life has breathed easier
This is to have succeeded.
Joined: Jun 2003
Posts: 509
FPcelica
Senior Member
FPcelica
2001 Spectra Blue Mica Toyota Celica GT
Senior Member
2001 Toyota Celica GT

Joined: Jun 2003
Posts: 509
Houston, TX
Jan 21, 9:51pm - #87205 
Originally Posted by DiabloGTS
then it's most likely the alternator.

the other belts would whir or pulse, the alternator whirs when it revvs up! thumbsup


how do i fix this


[Linked Image]
Joined: Apr 2003
Posts: 2,451
DiabloGTS
Wheezy Joe
DiabloGTS

Wheezy Joe
2002 Kawasaki Ninja 250

Joined: Apr 2003
Posts: 2,451
Lafayette, LA
Jan 22, 12:41am - #87206 
Originally Posted by FPcelica
Originally Posted by DiabloGTS
then it's most likely the alternator.

the other belts would whir or pulse, the alternator whirs when it revvs up! thumbsup


how do i fix this


It might need to be replaced. If you can afford it, have someone look at it.


To have played and laughed with enthusiasm
and sung with exultation
To know even one life has breathed easier
This is to have succeeded.
Join the conversation - Register Now or Log In to add your comment


Moderated by  isaac 

Member Spotlight
Elkal900
Elkal900
2000 Toyota Celica
Florence SC

Posts: 421
Joined: July 2003
Thanks: EverythingCelica.com ROCKS!!!!
Show All Member Profiles 
Recent Topics
Audio wiring issue
by redmarien. 06/24/2017 3:49 PM
Electrical Issue
by zenbone. 06/17/2017 12:40 PM
Manifold intake hose
by Celicafannn23. 06/10/2017 12:29 PM
Wheel size
by enjoi94. 06/08/2017 6:33 PM
Replaced Lock Actuator Issues
by geekbits. 06/08/2017 12:06 PM
Engine swap
by Darkgazer666. 06/06/2017 3:50 PM
What brand of wheels are these guys?
by jennmarkov. 06/05/2017 7:24 AM
WTB: Tsunami Rear Bumper
by valkyrie_gt. 06/04/2017 11:31 AM
Customize Your Toyota Celica Privacy Policy · About · Contact
Privacy Policy · About · Contact
CelicaHobby.com is an independent Toyota Celica enthusiast website. CelicaHobby.com is not sponsored by or affiliated with Toyota Motor Sales, USA, Inc. in any way. The Toyota and Celica names and logos are trademarks owned by Toyota Motor Sales, USA, Inc.
© CelicaHobby.com, 2001-2017
Powered by UBB.threads™ PHP Forum Software 7.6.1
(Snapshot build 20170611)