Previous Thread
Next Thread
New Reply
Print Thread
Joined: Jun 2003
Posts: 509
FPcelica
Senior Member
FPcelica Jan 21, 3:20am - #87196 
2001 Spectra Blue Mica Toyota Celica GT
Senior Member
2001 Toyota Celica GT

Joined: Jun 2003
Posts: 509
Houston, TX
engine noise...

ever since my car took a dive in the water... i have noticed that the motor i think its the alternator has been making this like spooling up sound like a "turbo" i was wandering if this was normal. my dad was saying it was the belting squeaking but i dont think its that

[Linked Image]
Joined: Apr 2003
Posts: 2,451
DiabloGTS
Wheezy Joe
DiabloGTS Jan 21, 3:24am - #87197 

Wheezy Joe
2002 Kawasaki Ninja 250

Joined: Apr 2003
Posts: 2,451
Lafayette, LA
is the stereo on?

could be feedback from a bad ground.

If not, could be alternator

To have played and laughed with enthusiasm
and sung with exultation
To know even one life has breathed easier
This is to have succeeded.
Joined: Jun 2003
Posts: 509
FPcelica
Senior Member
FPcelica Jan 21, 3:31am - #87198 
2001 Spectra Blue Mica Toyota Celica GT
Senior Member
2001 Toyota Celica GT

Joined: Jun 2003
Posts: 509
Houston, TX
Originally Posted by DiabloGTS
is the stereo on?

could be feedback from a bad ground.

If not, could be alternator


no its off, i just installed a ground wire kit, but i didnt know where to put them so i just put them on somewhat random places wich i figured wouldnt matter but could that b the problem

[Linked Image]
Joined: Apr 2003
Posts: 2,451
DiabloGTS
Wheezy Joe
DiabloGTS Jan 21, 4:20am - #87199 

Wheezy Joe
2002 Kawasaki Ninja 250

Joined: Apr 2003
Posts: 2,451
Lafayette, LA
Originally Posted by FPcelica
Originally Posted by DiabloGTS
is the stereo on?

could be feedback from a bad ground.

If not, could be alternator


no its off, i just installed a ground wire kit, but i didnt know where to put them so i just put them on somewhat random places wich i figured wouldnt matter but could that b the problem


Possibly could cause a problem.

To have played and laughed with enthusiasm
and sung with exultation
To know even one life has breathed easier
This is to have succeeded.
Joined: Jun 2003
Posts: 509
FPcelica
Senior Member
FPcelica Jan 21, 4:22am - #87200 
2001 Spectra Blue Mica Toyota Celica GT
Senior Member
2001 Toyota Celica GT

Joined: Jun 2003
Posts: 509
Houston, TX
Originally Posted by DiabloGTS
Originally Posted by FPcelica
Originally Posted by DiabloGTS
is the stereo on?

could be feedback from a bad ground.

If not, could be alternator


no its off, i just installed a ground wire kit, but i didnt know where to put them so i just put them on somewhat random places wich i figured wouldnt matter but could that b the problem


Possibly could cause a problem.


well the ground wires r gone but it still makin the sound, i guess im gonna wait to the belts dry
or maybe take it in to b looked at

[Linked Image]
Joined: Apr 2003
Posts: 2,451
DiabloGTS
Wheezy Joe
DiabloGTS Jan 21, 4:37am - #87201 

Wheezy Joe
2002 Kawasaki Ninja 250

Joined: Apr 2003
Posts: 2,451
Lafayette, LA
Originally Posted by FPcelica
Originally Posted by DiabloGTS
Originally Posted by FPcelica
Originally Posted by DiabloGTS
is the stereo on?

could be feedback from a bad ground.

If not, could be alternator


no its off, i just installed a ground wire kit, but i didnt know where to put them so i just put them on somewhat random places wich i figured wouldnt matter but could that b the problem


Possibly could cause a problem.


well the ground wires r gone but it still makin the sound, i guess im gonna wait to the belts dry
or maybe take it in to b looked at


what kind of sound it is?

constant whir, pulse?

To have played and laughed with enthusiasm
and sung with exultation
To know even one life has breathed easier
This is to have succeeded.
Joined: Jun 2003
Posts: 509
FPcelica
Senior Member
FPcelica Jan 21, 5:08am - #87202 
2001 Spectra Blue Mica Toyota Celica GT
Senior Member
2001 Toyota Celica GT

Joined: Jun 2003
Posts: 509
Houston, TX
Originally Posted by DiabloGTS
Originally Posted by FPcelica
Originally Posted by DiabloGTS
Originally Posted by FPcelica
[quote=DiabloGTS]is the stereo on?

could be feedback from a bad ground.

If not, could be alternator


no its off, i just installed a ground wire kit, but i didnt know where to put them so i just put them on somewhat random places wich i figured wouldnt matter but could that b the problem


Possibly could cause a problem.


well the ground wires r gone but it still makin the sound, i guess im gonna wait to the belts dry
or maybe take it in to b looked at


what kind of sound it is?

constant whir, pulse? [/quote]

yea it goes with the revs, it sounds like a turbo, a lil bit, spooling up

[Linked Image]
Joined: Apr 2003
Posts: 896
element_celica
Senior Member
element_celica Jan 21, 6:00am - #87203 

Senior Member

Joined: Apr 2003
Posts: 896
Michigan
same thing's happening to my friends grand am.
sounds like it's the alternator.
he sprayed his alternator pulley/bearing w/ oil and it stopped for awhile.

rip celi...
95 240sx
Joined: Apr 2003
Posts: 2,451
DiabloGTS
Wheezy Joe
DiabloGTS Jan 21, 6:02am - #87204 

Wheezy Joe
2002 Kawasaki Ninja 250

Joined: Apr 2003
Posts: 2,451
Lafayette, LA
then it's most likely the alternator.

the other belts would whir or pulse, the alternator whirs when it revvs up! thumbsup

To have played and laughed with enthusiasm
and sung with exultation
To know even one life has breathed easier
This is to have succeeded.
Joined: Jun 2003
Posts: 509
FPcelica
Senior Member
FPcelica Jan 22, 4:51am - #87205 
2001 Spectra Blue Mica Toyota Celica GT
Senior Member
2001 Toyota Celica GT

Joined: Jun 2003
Posts: 509
Houston, TX
Originally Posted by DiabloGTS
then it's most likely the alternator.

the other belts would whir or pulse, the alternator whirs when it revvs up! thumbsup


how do i fix this

[Linked Image]
Joined: Apr 2003
Posts: 2,451
DiabloGTS
Wheezy Joe
DiabloGTS Jan 22, 7:41am - #87206 

Wheezy Joe
2002 Kawasaki Ninja 250

Joined: Apr 2003
Posts: 2,451
Lafayette, LA
Originally Posted by FPcelica
Originally Posted by DiabloGTS
then it's most likely the alternator.

the other belts would whir or pulse, the alternator whirs when it revvs up! thumbsup


how do i fix this


It might need to be replaced. If you can afford it, have someone look at it.

To have played and laughed with enthusiasm
and sung with exultation
To know even one life has breathed easier
This is to have succeeded.
Join the conversation - Register now or Sign in to add your comment


Moderated by  isaac 

Customize Your Toyota CelicaPrivacy Policy · About · Contact
CelicaHobby.com is an independent Toyota Celica enthusiast website. CelicaHobby.com is not sponsored by or affiliated with Toyota Motor Sales, USA, Inc. in any way. The Toyota and Celica names and logos are trademarks owned by Toyota Motor Sales, USA, Inc.
© CelicaHobby.com, 2001-2016