Previous Thread
Next Thread
New Reply
Print Thread
Joined: Oct 2003
Posts: 36
celi2k
Member
celi2k
2000 White Toyota Celica
Member
2000 Toyota Celica

Joined: Oct 2003
Posts: 36
CA
Dec 17, 11:44pm - #69597 
Did this happen to anyone else?

I have a 2000 GTS, 5 days ago i put a cold air on it, only two days ago the check engine light came on, everything runs fine but the computer probly recognizes something about the cold air it doesnt like, I caped off ALL the original hoses, but discovered that some arnt supposed to get pluged, what am i supposed to do with the old hoses? Can the check light be fixed, bc nobody seems to have a Chilton manual or computer with celica codes for recognizing problems yet. what should i do? THANKS GUYS! thumbsup

Joined: Nov 2003
Posts: 837
LinkTallica
Senior Member
LinkTallica

Senior Member
1996 Geo Prizm

Joined: Nov 2003
Posts: 837
Cal LA
Dec 17, 11:49pm - #69598 
reset your ecu if that doesn't work then i have no idea sry and good luck thumbsup

Joined: Jun 2003
Posts: 1,307
RoMkApOmKa
Specialist
RoMkApOmKa

Specialist
2002 Toyota Celica GT

Joined: Jun 2003
Posts: 1,307
Maryland USA
Dec 17, 11:50pm - #69599 
It's what i heard that some people have the same problem after the CAI installation... Just do the search. wave

Joined: Sep 2003
Posts: 753
blackcel
Senior Member
blackcel

Senior Member
2000 Toyota Celica GT

Joined: Sep 2003
Posts: 753
Southeastern, Illinois
Dec 18, 3:21am - #69600 
After you reset your ecu, and the light is still on, you will need to clean your maf sensor. After you clean the maf sensor, you will need to reset the ecu, and you should be set. If it is not that, then i have no idea.


[Linked Image]
Joined: Aug 2003
Posts: 2,926
celicaTRDgts
Specialist
celicaTRDgts

Specialist
02 Toyota Celica

Joined: Aug 2003
Posts: 2,926
Arizona
Dec 18, 10:37am - #69601 
yea its very common just reset the ecu...should be good to go


[Linked Image]
Joined: Dec 2003
Posts: 12
Selica81
Member
Selica81
2000 White Toyota Celica
Member
2000 Toyota Celica

Joined: Dec 2003
Posts: 12
NC, USA
Dec 18, 11:55am - #69602 
I'm with black cel, after you clean your MAF make sure all your vacuum hoses are tight and there are no leaks. Reset ECU, and that should be it. thumbsup

Join the conversation - Register Now or Log In to add your comment


Moderated by  isaac 

Member Spotlight
Viper
Viper
2001 Toyota Celica GT
Lebanon

Posts: 131
Joined: October 2003
Show All Member Profiles 
Shout Box
Recent Topics
TradingGTS for GT what should I know.
by GTS25430. 04/24/2017 5:19 PM
Does 01' corolla struts swap in an 01' celica GT?
by Frostysnowman92. 04/24/2017 1:22 PM
WTB: 00-02 amp bypass harness
by MJ00GTS. 04/18/2017 7:36 PM
Does not seem to be much activity for the 5th gens???
by Coop301. 04/18/2017 7:51 AM
Cold wet weather hesitation
by GTS25430. 04/17/2017 6:15 AM
00-02 premium 8spkr 2din gps solutions?
by MJ00GTS. 04/17/2017 2:24 AM
WTB: valve assy, vacuum switch
by hydraea. 04/15/2017 5:32 PM
500awhp project
by Salman. 04/14/2017 8:20 AM
Customize Your Toyota Celica Privacy Policy · About · Contact
Privacy Policy · About · Contact
CelicaHobby.com is an independent Toyota Celica enthusiast website. CelicaHobby.com is not sponsored by or affiliated with Toyota Motor Sales, USA, Inc. in any way. The Toyota and Celica names and logos are trademarks owned by Toyota Motor Sales, USA, Inc.
© CelicaHobby.com, 2001-2017
Powered by UBB.threads™ PHP Forum Software 7.6.1
(Snapshot build 20170416)