Previous Thread
Next Thread
New Reply
Print Thread
Rate Thread
Replaced bad MAF. Now getting p0300/p1300 CEL codes. HELP! #451806 Oct 14, 3:34pm Oct 14, 3:34pm
Joined: Oct 2017
Posts: 7
California
B
Bblee1989 OP
New Member
Bblee1989 OP
B
New Member

Joined: Oct 2017
Posts: 7
California
Replaced bad MAF. Now getting p0300/p1300 CEL codes. HELP!
I've had a bad maf and after changing it my car stalls and dies. It was running fine before I changed it. Im sure I didn't hit any hose or anything. Before I changed it my codes was reading p0700 or something like that. It was running lean and that was the only code. Then after changing my maf it brought out codes p0300-01-02-03-04 and also p1300. I switch it back to my old maf to see if it was it but then it still did the same problem. Now when i start the car and I gas it the cat drops idle like it's going to die. It won't rev pass 2000. Any help would really be appriciated.

Re: Replaced bad MAF. Now getting p0300/p1300 CEL codes. HELP! [Re: Bblee1989] #451807 Oct 14, 3:59pm Oct 14, 3:59pm
Joined: May 2002
Posts: 463
California
CaffeineKid
CelicaSpecialist
2008 Scion tC
CaffeineKid
CelicaSpecialist
2008 Scion tC

Joined: May 2002
Posts: 463
California
Did you reset your ECU after swapping out your MAF sensor?
https://www.celicahobby.com/forums/ubbthreads.php/topics/267456/ecu-how-to-reset.html

Is your new MAF from the same model Celica (GT/GTS) as what you were were replacing? Though, Im not sure that really maters, as the Air Flow Meter (MAF) part numbers are the same same for both the GT and GTS (22204-0D030)

[Linked Image]

Re: Replaced bad MAF. Now getting p0300/p1300 CEL codes. HELP! [Re: CaffeineKid] #451808 Oct 14, 4:10pm Oct 14, 4:10pm
Joined: Oct 2017
Posts: 7
California
B
Bblee1989 OP
New Member
Bblee1989 OP
B
New Member

Joined: Oct 2017
Posts: 7
California
No i didn't reset it. I'll try that right now

Re: Replaced bad MAF. Now getting p0300/p1300 CEL codes. HELP! [Re: CaffeineKid] #451809 Oct 14, 4:20pm Oct 14, 4:20pm
Joined: Oct 2017
Posts: 7
California
B
Bblee1989 OP
New Member
Bblee1989 OP
B
New Member

Joined: Oct 2017
Posts: 7
California
I've reset it and it still does the same thing

Re: Replaced bad MAF. Now getting p0300/p1300 CEL codes. HELP! [Re: Bblee1989] #451810 Oct 14, 4:29pm Oct 14, 4:29pm
Joined: Oct 2017
Posts: 7
California
B
Bblee1989 OP
New Member
Bblee1989 OP
B
New Member

Joined: Oct 2017
Posts: 7
California
I've reset it and it still does the same thing

Re: Replaced bad MAF. Now getting p0300/p1300 CEL codes. HELP! [Re: Bblee1989] #451811 Oct 14, 4:35pm Oct 14, 4:35pm
Joined: May 2002
Posts: 463
California
CaffeineKid
CelicaSpecialist
2008 Scion tC
CaffeineKid
CelicaSpecialist
2008 Scion tC

Joined: May 2002
Posts: 463
California
Resetting your ECU might take a few minutes between pulling the fuse, and reinserting it. Also, as just a random guess, you may want to let your car run for a few minutes (if thats possible?) so each item clears.

You may have something further happening with your vehicle that might not be related to just the MAF. What was your initial reasoning for replacing the MAF?

Inspect for any other sensors that may have been loosened when you performed the work on your Celica. Did you also remove the splatic engine cover, which exposes your spark plug coils? You may have an issue related there. You mentioned that your vehicle car stalls and dies, but without actually inspecting it, or know what sounds it makes just as it stalls -- or when it stalls (hot/cold/sitting still/moving...etc) there isnt much more to go on.

I'd advise that you have a local professional take a look at your Celica and let them perform all the diagnostic test on it, to pinpoint whats truly causing the malfunction and throwing those CELs.

Re: Replaced bad MAF. Now getting p0300/p1300 CEL codes. HELP! [Re: CaffeineKid] #451812 Oct 14, 4:41pm Oct 14, 4:41pm
Joined: Oct 2017
Posts: 7
California
B
Bblee1989 OP
New Member
Bblee1989 OP
B
New Member

Joined: Oct 2017
Posts: 7
California
I was replacing the maf because I wanted to clear my cel. I went to AutoZone and they said my maf was bad. So I bought a new one and replaced it and that's when everything started happening. And I let the engine run a few minutes earlier and still does the same thing.

And no I didn't take off the splatic off when I changed out the maf so I didn't hit anything I'm pretty sure of it.

I took a video on my phone but I couldn't upload it

Re: Replaced bad MAF. Now getting p0300/p1300 CEL codes. HELP! [Re: Bblee1989] #451813 Oct 14, 4:51pm Oct 14, 4:51pm
Joined: May 2002
Posts: 463
California
CaffeineKid
CelicaSpecialist
2008 Scion tC
CaffeineKid
CelicaSpecialist
2008 Scion tC

Joined: May 2002
Posts: 463
California
Did you purchase the MAF from AutoZone or is it a genuine OEM part from Toyota? If its not genuine toyota, that may be whats causing your headaches :\

thumbsup about the plastics. There's nothing wrong with removing them. But I though to ask anyways.

If you have an account with YouTube, you can upload your video to there, and then link to it, if you still feel thats necessary.

Re: Replaced bad MAF. Now getting p0300/p1300 CEL codes. HELP! [Re: Bblee1989] #451814 Oct 14, 4:52pm Oct 14, 4:52pm
Joined: Oct 2017
Posts: 7
California
B
Bblee1989 OP
New Member
Bblee1989 OP
B
New Member

Joined: Oct 2017
Posts: 7
California
I've bought the maf from eBay. But okay I'll upload it to YouTube and load up the link.

Re: Replaced bad MAF. Now getting p0300/p1300 CEL codes. HELP! [Re: Bblee1989] #451815 Oct 14, 4:56pm Oct 14, 4:56pm
Joined: Oct 2017
Posts: 7
California
B
Bblee1989 OP
New Member
Bblee1989 OP
B
New Member

Joined: Oct 2017
Posts: 7
California

Join the conversation - Register Now or Log In to add your comment


Moderated by  isaac 

Member Spotlight
OzzyZR
OzzyZR
2000 Toyota Celica ZR
Australia

Posts: 142
Joined: February 2004
Random: Whoohoo!!! Celica is in my garage!!! But then i dropped it into 2nd on the highway >:( So it's in the workshop now.
Show All Member Profiles 
Recent Topics
Help! New celica owner
by Papito07. 11/18/2017 8:25 PM
WTB: Celica Project
by Excel. 11/18/2017 9:15 AM
Low idle and slow take off
by Wmillerjr. 11/17/2017 9:34 AM
WTB: OEM Floor Mats
by Mac_TheBeard. 11/16/2017 11:06 PM
Smoking after cleaning injectors
by CelicaSW88. 11/15/2017 11:03 AM
What Tail light is this?
by Hanate. 11/14/2017 7:37 PM
2001 Celica VVTI 140 Wheel Studs
by minos316. 11/11/2017 4:06 PM
Is This Transmission Normal??
by Bilster. 11/03/2017 9:25 PM
Customize Your Toyota Celica Privacy Policy · About · Contact
Privacy Policy · About · Contact
CelicaHobby.com is an independent Toyota Celica enthusiast website. CelicaHobby.com is not sponsored by or affiliated with Toyota Motor Sales, USA, Inc. in any way. The Toyota and Celica names and logos are trademarks owned by Toyota Motor Sales, USA, Inc.
© CelicaHobby.com, 2001-2017
Powered by UBB.threads™ PHP Forum Software 7.6.1
(Snapshot build 20171111)