Previous Thread
Next Thread
New Reply
Print Thread
Rate Thread
Very odd issue with my GTS(HELP!) #451069 Mar 3, 2:21pm Mar 3, 2:21pm
Joined: Mar 2016
Posts: 1
North Carolina
S
ShiroiGTS OP
New Member
ShiroiGTS OP
S
New Member

Joined: Mar 2016
Posts: 1
North Carolina
Very odd issue with my GTS(HELP!)
So i'm having this very odd issue with my 2000 GTS, When i turn the car on, the throttle is completely wide open, Nothing stops it, it goes straight to 7000 rpm, no matter what, The weird part is, i don't even have to touch the gas pedal, it stays stationary(neutral, not pressed in) but the Car still revs like the pedal is being floored,

Example, i push in the clutch, put the car in neutral,Turn the key,keep my foot away from the gas pedal, And the car instantly starts to rev to 7000.
Here is another weird issue, if i turn it on, then turn it off, let go of the clutch, and turn the key to battery, the car still revs up, even though the key is turned to battery.

It's like the pedal is no longer connected, but i checked the throttle cable wire, and it pulls as i push it in. so the throttle cable has not snapped (I guess!) i'm so blind to what this is or what to do about it...

I have no clue whats going on, So i need some serious insight..Please help.

Re: Very odd issue with my GTS(HELP!) [Re: ShiroiGTS] #451100 Mar 21, 9:06pm Mar 21, 9:06pm
Joined: Jan 2016
Posts: 11
bradenton, Florida
M
MrEdd
Member
2005 toyota gt
MrEdd
M
Member
2005 toyota gt

Joined: Jan 2016
Posts: 11
bradenton, Florida
are there any code? Have you cleaned the throttle body? has the car been sitting for a while (if it has the idle air control valve might be going)? do you have any water damage (the computer could be fried)? Have you reset the computer?

Re: Very odd issue with my GTS(HELP!) [Re: ShiroiGTS] #451222 Jun 20, 6:40am Jun 20, 6:40am
Joined: Jun 2016
Posts: 1
Ireland
V
vvtli_Peter
New Member
vvtli_Peter
V
New Member

Joined: Jun 2016
Posts: 1
Ireland
hey there, im having a similar problem with a 2001 VVTLI, i had the radiator changed a few weeks ago and the car was lying without water in it for a week or so. i drove it about 20 meters into a shed to fit the new rad and when i was done and filled with coolant i turned on the key and it reved straight up to 4000rpm i cannot figure out what the issue is or if it has anything to do with changing the rad or not.

If i rev up to higher revs it will stay at that until i get out and wind the valve on the throttle body back down to 4000rpm but it get firm at that and wont let it go below 4000.
do the throttle bodys themselves give trouble or is this more likley an ecu problem? any help greatly apriciated!

Join the conversation - Register Now or Log In to add your comment


Moderated by  isaac 

Member Spotlight
Pate
Pate
2005 Toyota Celica GT
Orem, Utah

Posts: 53
Joined: October 2004
Random: "That John Denver's full of shit man!"
Show All Member Profiles 
Recent Topics
stock radio hardware
by 97celica. 12/12/2017 12:12 PM
FS: 2000 Toyota Celica for sale Los Angeles area
by LaRN. 12/10/2017 9:52 AM
Toyota Celica Upgrades
by FlawlessGamerYT. 12/09/2017 11:06 AM
Why did my tachometer stop working
by NinjaMasterShaw. 12/08/2017 6:20 AM
Gauge cluster board aftermarket
by NinjaMasterShaw. 12/07/2017 5:06 PM
How would I go about giving my steering wheel a facelift
by NinjaMasterShaw. 12/06/2017 2:22 PM
Hard to press cluch pedal?
by Arve2afm. 12/05/2017 6:40 AM
Hello! New Member here :)
by Kizmo_JW. 11/29/2017 2:30 PM
Customize Your Toyota Celica Privacy Policy · About · Contact
Privacy Policy · About · Contact
CelicaHobby.com is an independent Toyota Celica enthusiast website. CelicaHobby.com is not sponsored by or affiliated with Toyota Motor Sales, USA, Inc. in any way. The Toyota and Celica names and logos are trademarks owned by Toyota Motor Sales, USA, Inc.
© CelicaHobby.com, 2001-2017
Powered by UBB.threads™ PHP Forum Software 7.6.1
(Snapshot build 20171122)