Previous Thread
Next Thread
New Reply
Print Thread
Joined: Jun 2012
Posts: 6
akib
New Member
akib Jul 9, 11:07pm - #448913 
New Member

Joined: Jun 2012
Posts: 6
nsw
Idling

HI Guys, i been having very poor idling. my car dies out when the elctric fan goes on ???

thanks for any help. smile
Joined: Jun 2012
Posts: 38
skitz
Member
skitz Jul 11, 6:53pm - #448914 
Member

Joined: Jun 2012
Posts: 38
US
Could be literally almost anything. Without plugging it up and getting a code to check it will be difficult to locate.

If it only happens when your fan kicks on it's probably electrical. Check all your battery cables and fuses. If there is a short somewhere your ECU may be freaking out because power isn't supposed to be where power is.

If all of that checks out start checking a little deeper like spark plugs and wires. Something may just not be firing right at lower revs if things aren't happening right it may kill it, where are higher revs it may burn fast enough to keep running. Your fan uses more power, and if your car is stressed already that may be the last straw.

Honestly just check all of your basic components, filters, fuses, fluids, easy to get to stuff. If none of that works it could be anything in the wiring harness or insidey bits. If your fuel injectors aren't flowing right all of the other parts may just not have enough anything to go. Try some fuel injector cleaner, slick 50, seafoam, etc.

Your best bet may just to be to head to someone who can plug it up and see if any codes come up. Something like this could just be a loose spark plug or a huge problem. Without more information I have no idea. Usually if something gets past visible parts I head to my mechanic.
Joined: Jun 2012
Posts: 6
akib
New Member
akib Jul 22, 10:01pm - #448931 
New Member

Joined: Jun 2012
Posts: 6
nsw
Mate, thanks for the reply. I checked the basic stuffs. They are all fine. tried the fuel injectors cleaners 4 or them in 2 months. not sure if i need to use them more. spark plugs been checked. The car takes long time to start when warmed up. I sill get codes of miss firing. i am going to see a mechanic soon and sort this out. i haven't checked the fuses. and haven't check the wires.
Joined: Jun 2012
Posts: 38
skitz
Member
skitz Jul 23, 3:37pm - #448933 
Member

Joined: Jun 2012
Posts: 38
US
Well I was actually going to replace the wires on my car the other day with the spark plugs just as a tune up day but as it turns out you cant get just the wires. At least I couldn't from my local autoparts store, you have to get the entire coil apparently which runs about 100USD. If your code is flashing a misfire it may be one of those, or your timing may just be off.

Hope it all works out for you.
Join the conversation - Register now or Sign in to add your comment


Moderated by  isaac 

Customize Your Toyota CelicaPrivacy Policy · About · Contact
CelicaHobby.com is an independent Toyota Celica enthusiast website. CelicaHobby.com is not sponsored by or affiliated with Toyota Motor Sales, USA, Inc. in any way. The Toyota and Celica names and logos are trademarks owned by Toyota Motor Sales, USA, Inc.
© CelicaHobby.com, 2001-2016