Previous Thread
Next Thread
New Reply
Print Thread
Joined: Apr 2012
Posts: 6
Waynej517
New Member
Waynej517 Apr 15, 10:07pm - #448749 
New Member

Joined: Apr 2012
Posts: 6
South West Michigan
Engine noise I need help!

I have a weird noise comeing from somewhere inside my engine bay on the passanger side it only happen when I'm around 3000 RPM to about 4500 RPM but it sounds like metal rattling on metal I don't know how else to put it but it is horrable and my whole family works on cars and none of us can figure it out I'm wondering if anyone has any clue as to what it could be even a guess would be great please help!!!
Joined: Feb 2012
Posts: 3
wport
New Member
wport Jun 9, 4:04pm - #448848 

New Member

Joined: Feb 2012
Posts: 3
pa
is your oil low i notice the samwe sound when my oil is low and bad thing is i put oil in and week later out of oil
Joined: Apr 2012
Posts: 6
Waynej517
New Member
Waynej517 Jul 6, 1:51pm - #448905 
New Member

Joined: Apr 2012
Posts: 6
South West Michigan
No it's not I just changed the oil and checked the level a few days after. Someone told me it could be my heat shield above my converter but idk frown
Joined: Jun 2012
Posts: 38
skitz
Member
skitz Jul 6, 9:00pm - #448908 
Member

Joined: Jun 2012
Posts: 38
US
Check your oil again just to make sure you havent sprung a leak since the last time you changed it. Pop your Hood and hit the throttle, see if you can narrow it down by listening from inside the engine bay. More than likely you just have a loose panel or a bolt thats sitting somewhere wierd. Its not a rod knocking type noise is it?
Joined: Jan 2013
Posts: 11
killerbillygoat
Member
killerbillygoat Feb 1, 4:23pm - #449133 
Member

Joined: Jan 2013
Posts: 11
AR
is your check engine light on? mine is on and it makes the same sound but usualy when car is at idle or when i let off the gas completly after accelerating it starts tapping. i was told my vvt gear is "hanging retarded" from toyota.
Joined: Feb 2013
Posts: 11
Alexswi
Member
Alexswi Feb 2, 7:00am - #449136 
Member

Joined: Feb 2013
Posts: 11
CA
I have the same problem... I my buddy told me it is my heat shield... but soon after that happened a engine light went on about 2 weeks later... duno if its the exact same problem as yours. but i got a p0420. it is def. not my cat.. i got a new one about a year ago..
Join the conversation - Register now or Sign in to add your comment


Moderated by  isaac 

Customize Your Toyota CelicaPrivacy Policy · About · Contact
CelicaHobby.com is an independent Toyota Celica enthusiast website. CelicaHobby.com is not sponsored by or affiliated with Toyota Motor Sales, USA, Inc. in any way. The Toyota and Celica names and logos are trademarks owned by Toyota Motor Sales, USA, Inc.
© CelicaHobby.com, 2001-2016