Previous Thread
Next Thread
New Reply
Print Thread
Joined: Apr 2005
Posts: 17
300zx2GTS
Member
300zx2GTS Apr 7, 11:47pm - #437304 
2000 Black Toyota Celica
Member
2000 Toyota Celica

Joined: Apr 2005
Posts: 17
westerly, rhode island
Feels like hitting rev limiter at 7000ish rpm range in 00GTS...

Before you trash me hear me out for a minute. Yes this is my first post and yes I just got a 00 GTS but no I am not new to cars. Thanks. I just noticed that when I hit 6800-7000RPMs the car feels like I am hitting a rev limiter. It will not go any further and it just bounces off 6800-7000. It will not go into that extra valve lift stage (sorry not sure what it is called in the celica yet). The cars speed sensor just went out a couple of weeks ago but I dont know if that would cause the problem. I am pretty sure that I have got it past it before even with the speed sensor not working. The car feels perfect up until the 7000ish range. Any ideas???
Joined: Aug 2003
Posts: 399
SCOTT03
Member
SCOTT03 Apr 7, 11:51pm - #437305 
2000 Black Toyota Celica
Member
2000 Toyota Celica

Joined: Aug 2003
Posts: 399
Buies Creek/Sanford, NC
is your car warmed up or is thowing a CEL. The ECU does not allow the 2nd cam to be engaged if the oil pressure has not built up/thus the oil temperature has warmed up. Typically this is about two notches up on the temp gauge. The ECU also goes into a safe mode if it deems a CEL dangerous and also does not activate the 2nd cam.

[Linked Image]
Joined: Apr 2005
Posts: 17
300zx2GTS
Member
300zx2GTS Apr 7, 11:57pm - #437306 
2000 Black Toyota Celica
Member
2000 Toyota Celica

Joined: Apr 2005
Posts: 17
westerly, rhode island
The CEL light was reset tonight. It was on then I had the plugs replaced and the 90 degree plastic hose that goes around the CAI into the computer box in front of battery put on because some dope lost it before I got the car. But with no CEL light on I drove around for about 10 minutes then tried to get it over and the same thing. Yes the car was warmed up also.
Joined: Apr 2005
Posts: 17
300zx2GTS
Member
300zx2GTS Apr 8, 2:05pm - #437307 
2000 Black Toyota Celica
Member
2000 Toyota Celica

Joined: Apr 2005
Posts: 17
westerly, rhode island
I have been searching for this problem for hours now and the only thing I found was lift bolts. Could the lift bolts be broken and causing it not to hit lift 2?
Joined: Jan 2004
Posts: 233
drivethru1986
Member
drivethru1986 Apr 8, 4:17pm - #437308 

Member
2004 Toyota Celica

Joined: Jan 2004
Posts: 233
jersey
^^ that could be possible...check them out thumbsup

2004 AUTO GT-S............

"I may go slow.....but i look fucking good doing it...."
Joined: Dec 2004
Posts: 468
GTS_Rosh
Senior Member
GTS_Rosh Apr 8, 5:06pm - #437309 

Senior Member
2004 Toyota Celica

Joined: Dec 2004
Posts: 468
Vancouver, BC, Canada
Lift filter dirty?
Joined: Apr 2005
Posts: 17
300zx2GTS
Member
300zx2GTS Apr 8, 5:38pm - #437310 
2000 Black Toyota Celica
Member
2000 Toyota Celica

Joined: Apr 2005
Posts: 17
westerly, rhode island
Still new to this car, so I just got into those topics. How long does it take to check the filter? Just so I know how long the car will be down for. Thanks
Joined: Apr 2004
Posts: 427
speed_celica
Senior Member
speed_celica Apr 8, 5:47pm - #437311 

Senior Member
2000 Toyota Celica

Joined: Apr 2004
Posts: 427
Calgary, AB, Canada
It's a blown fuse! Not sure which fuse it was but I had the exact same problem on my 00 GTS a couple years back. I had no lift and the rev limit kicked in @ 7000 RPM. The dealer replaced the fuse for $15
Joined: Feb 2005
Posts: 100
Super_celica
Member
Super_celica Apr 8, 8:21pm - #437312 
2001 Silver Toyota Celica
Member
2001 Toyota Celica

Joined: Feb 2005
Posts: 100
Ohio
mine does this when i go to work in the morning, you gotta let it warm up a bit, just rev the engine a few times in front of ur house its what i do.
Joined: Oct 2004
Posts: 233
Lasherccl
Member
Lasherccl Apr 9, 1:53am - #437313 

Member
2001 Toyota Celica

Joined: Oct 2004
Posts: 233
Arizona
mine does that as soon as i hit 7k rpms, i always thought it was cause one of my lift bolts was broken though.

I fought the law and the law won, i lost my girl and i lost my fun, i fought the law and the law won.....
Joined: Oct 2004
Posts: 233
Lasherccl
Member
Lasherccl Apr 9, 1:56am - #437314 

Member
2001 Toyota Celica

Joined: Oct 2004
Posts: 233
Arizona
actually it stutters at 7k for a lil bit and then goes back up and if i do this more than twice a CEL comes on.

I fought the law and the law won, i lost my girl and i lost my fun, i fought the law and the law won.....
Joined: Feb 2004
Posts: 1,716
celicafourotwo
Specialist
celicafourotwo Apr 9, 2:02am - #437315 

Specialist
2000 Toyota Celica

Joined: Feb 2004
Posts: 1,716
Nebraska
Originally Posted by speed_celica
It's a blown fuse! Not sure which fuse it was but I had the exact same problem on my 00 GTS a couple years back. I had no lift and the rev limit kicked in @ 7000 RPM. The dealer replaced the fuse for $15


was it one of them big brown fuse with mini fuse inside it?? it got like 3teeth on it..if it is...check the fuse box on the passenger side, left kick panel...they are in there, and under the Hood too..good luck with that...i've never had that happen b4..the only time rev limiter hit is when my car not warm enuf..2nd notch on the temp gauge..

sorry you already have problem and you just got the car...happen to me with the clutch..feel really disappointed in the car then..but now it's all good..

welcome to the community!! thumbsup

Originally Posted by pesho01
Question:
Whenever my car is at a full stop or even in park the RPM never sits on 0. what does this mean?
Joined: Apr 2004
Posts: 427
speed_celica
Senior Member
speed_celica Apr 10, 8:46am - #437316 

Senior Member
2000 Toyota Celica

Joined: Apr 2004
Posts: 427
Calgary, AB, Canada
All I know is, the fuse isn't cheap, I paid $15 after it was changed and only $5 was for labour grin
Joined: Apr 2005
Posts: 17
300zx2GTS
Member
300zx2GTS Apr 13, 2:37pm - #437317 
2000 Black Toyota Celica
Member
2000 Toyota Celica

Joined: Apr 2005
Posts: 17
westerly, rhode island
I am going to look into the fuse today thanks for the info. Oh one more question, did the CEL come on because of this fuse?
Joined: Apr 2004
Posts: 427
speed_celica
Senior Member
speed_celica Apr 13, 6:12pm - #437318 

Senior Member
2000 Toyota Celica

Joined: Apr 2004
Posts: 427
Calgary, AB, Canada
nope, I didn't get the check engine light! which is why I was so confused when it happened! grin
Joined: Apr 2005
Posts: 17
300zx2GTS
Member
300zx2GTS Apr 17, 6:44pm - #437319 
2000 Black Toyota Celica
Member
2000 Toyota Celica

Joined: Apr 2005
Posts: 17
westerly, rhode island
Ok I had the car checked at the dealership for the CEL and it was the speed sensor. It has been malfunctioning lately. I ordered the sensor and hopefully that is my problem. From my search I learned that if the speedometer is not hooked up the computer will not activate lift but does that mean that it will still go over 7000rpms? just with no lift or will it cause a safety mode rev limiter to come in at about 6800?
Joined: Apr 2004
Posts: 427
speed_celica
Senior Member
speed_celica Apr 18, 2:35pm - #437320 

Senior Member
2000 Toyota Celica

Joined: Apr 2004
Posts: 427
Calgary, AB, Canada
well no, cause in order to go in lift it means the larger cams have to be enaged. if your not in lift even @ 7000rpm you're still running with the smaller cams. the ecu won't let the car run higher than 7000rpm with the smaller cams.
Joined: Sep 2004
Posts: 191
shonen
Member
shonen Apr 18, 5:09pm - #437321 
2001 absolutely red Toyota Celica
Member
2001 Toyota Celica

Joined: Sep 2004
Posts: 191
North Carolina
I think your cel came on because of the pipe to the computer box, you need that tube to get air to cool down the computer or you will get a cel. My bro pulled out the pipe and didnt properly replace it later and I was getting a cel, after securely replacing it back, the cel went away.
Joined: Apr 2005
Posts: 17
300zx2GTS
Member
300zx2GTS Apr 18, 6:59pm - #437322 
2000 Black Toyota Celica
Member
2000 Toyota Celica

Joined: Apr 2005
Posts: 17
westerly, rhode island
thanks for all the help. I just got the piping to the ecu and installed it and now I am just waiting for the lift bolts and speed sensor to come in. I will keep everyone posted.
Join the conversation - Register now or Sign in to add your comment


Moderated by  isaac 

Customize Your Toyota CelicaPrivacy Policy · About · Contact
CelicaHobby.com is an independent Toyota Celica enthusiast website. CelicaHobby.com is not sponsored by or affiliated with Toyota Motor Sales, USA, Inc. in any way. The Toyota and Celica names and logos are trademarks owned by Toyota Motor Sales, USA, Inc.
© CelicaHobby.com, 2001-2016