Previous Thread
Next Thread
New Reply
Print Thread
Joined: Mar 2004
Posts: 132
Parabol
Member
Parabol Apr 2, 12:37am - #431932 
2004 red Toyota Celica
Member
2004 Toyota Celica

Joined: Mar 2004
Posts: 132
FL
intake cel

just installed Injen CAI last night took about 2 1/2 hours everything went smooth got noticable gains and no bogging yet but today when driving around a threw a cel... i read on the forums that there is an extra plug in somewhere not mentioned on injens install guide or EC for that matter for the 04's (gts) wondering if anybody knows what it is and ill see if its the problem if not i guess ill just have to clean the MAFS and all that other crap. thx
Joined: Sep 2004
Posts: 49
TRDxvvtl
Member
TRDxvvtl Apr 2, 4:43am - #431933 

Member
2001 Toyota Celica

Joined: Sep 2004
Posts: 49
San Gabriel,California
yea clean it but it might come back a week later. My car is messed up because the CEL is always on. IT also came on after installin my TRD exhaust. You might get a P0441 code but not sure what to do because there are many things to check out. The extra plug just leave it alone.
Join the conversation - Register now or Sign in to add your comment


Moderated by  isaac 

Customize Your Toyota CelicaPrivacy Policy · About · Contact
CelicaHobby.com is an independent Toyota Celica enthusiast website. CelicaHobby.com is not sponsored by or affiliated with Toyota Motor Sales, USA, Inc. in any way. The Toyota and Celica names and logos are trademarks owned by Toyota Motor Sales, USA, Inc.
© CelicaHobby.com, 2001-2016