Previous Thread
Next Thread
New Reply
Print Thread
Joined: Jun 2004
Posts: 1,870
Chelica815
Specialist
Chelica815 Mar 29, 10:31pm - #428818 
2000 Silver Toyota Celica
Specialist
2000 Toyota Celica

Joined: Jun 2004
Posts: 1,870
San Francisco -The Bay
HELP. No power Radio and Clock!

Hey guys, I am in need of your advice.

The story goes:
A friend of mine was installing a new Head Unit for my 00 Celica GTS. Everything seems to be going great. Before putting everything back we power up the car and see if the new head unit works. It does...

So we put everything back. When I power up my car again, no power on the radio, and no power on the clock. We put the stock radio in and still no power on the radio and no power on the clock. We check the fuse, and one of them was blown. It was number 24 I believe. Went to Radio Shack and replaced it. Still no go. Check the fuse box in the engine compartment and only one was blown. It was the DFI one. Weird thing about this was the fuse on it was a 15 and it needed a 25. My gauge was tripping out because of this. We replaced it with a 20 because they did not have a 25 there, and that gauge and door locks became normal.

Still no power on the stock head unit and clock.

Ideas??? What went wrong?

I have a Fosgate Amp in my trunk that runs the line inverter underneath the glove box if that makes any diff.

But the thing was, the radio WAS working and it just stopped working, no power at all.

Agressively Driven
[Linked Image]
2000 Celica GT-S 6 Speed
Joined: Jan 2004
Posts: 1,230
FloydianSlip6
Specialist
FloydianSlip6 Mar 29, 11:16pm - #428819 

Specialist
2002 Toyota Celica

Joined: Jan 2004
Posts: 1,230
Massachusetts
You must have shorted something out, I'd check for a semi blown fuse somewhere, and try to get a 25 in that fuse. It could be that the fuse in question isn't fully destroyed but it's still blown. Also make sure the fuses that you checked are back in all the way.

This probably woun't help but you could also try resetting your ECU (disconnect the negative battery terminal for a few minutes).
Joined: Aug 2004
Posts: 1,029
kmlgts
Specialist
kmlgts Mar 30, 1:13am - #428820 

Specialist
2000 Toyota Celica

Joined: Aug 2004
Posts: 1,029
California
your friend blew a fuse.. check your fuse thumbsup

[Linked Image]
Joined: Feb 2004
Posts: 1,716
celicafourotwo
Specialist
celicafourotwo Mar 30, 2:38am - #428821 

Specialist
2000 Toyota Celica

Joined: Feb 2004
Posts: 1,716
Nebraska
check ALL ur fuse..look at the fuses under/behind the shifter..

Originally Posted by pesho01
Question:
Whenever my car is at a full stop or even in park the RPM never sits on 0. what does this mean?
Joined: Jun 2004
Posts: 1,870
Chelica815
Specialist
Chelica815 Mar 30, 3:17am - #428822 
2000 Silver Toyota Celica
Specialist
2000 Toyota Celica

Joined: Jun 2004
Posts: 1,870
San Francisco -The Bay
I replaced the 15 with the 25 just recently and still nothing. It is very dark outside, I will check the fuse tomorrow morning. I also tried ressetting the ECU, still nothing. Any other ideas? Any other connection points? Where is the power that goes to the head unit comes from? I got check the source to see if anything is burnt.

Are there any correct way of replacing your fuse? And in the fuse box, there are big ones, how do I check if they are bad? You can't see thru them like the regular fuses.

What does a semi blown fuse look like?

THANKS!

I really hope that I can get this fix. Does Toyota extended warranty cover this??

Agressively Driven
[Linked Image]
2000 Celica GT-S 6 Speed
Joined: Jun 2004
Posts: 1,870
Chelica815
Specialist
Chelica815 Mar 31, 1:59am - #428823 
2000 Silver Toyota Celica
Specialist
2000 Toyota Celica

Joined: Jun 2004
Posts: 1,870
San Francisco -The Bay
Nevermind. Mod/Admin can close this. The problem is the 7.5 Fuse located in the kicker panel. 2 out of the 4in1 was blown. Can only be purchased at Toyota. Everything now works.

Thanks!

Agressively Driven
[Linked Image]
2000 Celica GT-S 6 Speed
Joined: Mar 2005
Posts: 104
lpfan076
Member
lpfan076 Mar 31, 3:26am - #428824 

Member
2001 Ford Focus

Joined: Mar 2005
Posts: 104
Milford, Ohio
who put a 15 fuse in there in the first place?

[Linked Image]
Studio Traffic
[color:"red"]^^Earn some easy money <img src="/ubbthreads/images/graemlins/biggrin.gif" alt="" />[/color]
Joined: Jun 2004
Posts: 1,870
Chelica815
Specialist
Chelica815 Mar 31, 4:44am - #428825 
2000 Silver Toyota Celica
Specialist
2000 Toyota Celica

Joined: Jun 2004
Posts: 1,870
San Francisco -The Bay
That I have no idea. It was prolly the Toyota dealership. I got the car used, so I have no idea who did what to the car. Good thing we checked the fuse box in the engine bay.

That was not the problem tho. The problem was the 7.5 fuse in the kicker panel. The 4in1 fuse that even the Toyota Parts guy said was a stupid design. Celica was the first car to use that type of fuse. $5.09 for the fuse.

Agressively Driven
[Linked Image]
2000 Celica GT-S 6 Speed
Joined: Jul 2003
Posts: 1,587
xmangt1
4 All U Haterz!
xmangt1 Apr 1, 5:56am - #428826 

4 All U Haterz!
2000 Toyota Celica GT

Joined: Jul 2003
Posts: 1,587
Chicago, IL
Glad you figured it out. I had that problem a while back & I actually helped a few people on that. I even posted a pic of the fuse & where it goes.
Joined: Aug 2003
Posts: 678
celicatalbot
Senior Member
celicatalbot Apr 1, 4:37pm - #428827 
2003 Absolutely Red Toyota Celica GT
Senior Member
2003 Toyota Celica GT

Joined: Aug 2003
Posts: 678
New York
OMG dude I had the same problem. It was a pain in the ass!

My car might be slow, but at least it looks nice!
Joined: Jan 2004
Posts: 1,230
FloydianSlip6
Specialist
FloydianSlip6 Apr 1, 5:02pm - #428828 

Specialist
2002 Toyota Celica

Joined: Jan 2004
Posts: 1,230
Massachusetts
That's what a semi blown fuse looks like wink
Joined: Sep 2004
Posts: 208
ApuPimpin
Member
ApuPimpin Apr 3, 6:29am - #428829 

Member
2000 Toyota Celica GT

Joined: Sep 2004
Posts: 208
St. Thomas, USVI
dude it's that one huge wierd fuse you can only get from toyota you have an extra one under your Hood...how do I know this b/c the same shit happend to me thumbsdown
Joined: Jun 2004
Posts: 1,870
Chelica815
Specialist
Chelica815 Apr 3, 7:32am - #428830 
2000 Silver Toyota Celica
Specialist
2000 Toyota Celica

Joined: Jun 2004
Posts: 1,870
San Francisco -The Bay
eh, it was only $5 bucks.

Agressively Driven
[Linked Image]
2000 Celica GT-S 6 Speed
Joined: May 2013
Posts: 1
Nix
New Member
Nix May 1, 7:22pm - #449335 
New Member

Joined: May 2013
Posts: 1
Portland, OR
So glad I found u guys. I'm having the same problem where all the fuses seem intact. I replaced the 7.5 with the spare under the Hood (saved five bucks) but I've still got no power. My clock works though. Does this mean I have a bad deck? Any other trouble shoots out there, er does anybody have an extra factory deck I could get? Thanks
Joined: Jun 2013
Posts: 2
SundownCelica01
New Member
SundownCelica01 Jun 9, 7:52pm - #449398 
New Member

Joined: Jun 2013
Posts: 2
dallas, tx
having the same issue now but my 7.5 in the kick panel seems to be fine!!!
Joined: May 2002
Posts: 421
CaffeineKid
CelicaSpecialist
CaffeineKid Jun 9, 8:56pm - #449399 

CelicaSpecialist
2008 Scion tC

Joined: May 2002
Posts: 421
California
Originally Posted by SundownCelica01
having the same issue now but my 7.5 in the kick panel seems to be fine!!!


Swap the 7.5 fuse in your kick panel for the spare that is in your engine fuse box. If you're still having a problem, reference this post: https://www.celicahobby.com/forums/ubbthreads.php/topics/86523.html#Post86523

There is not a lot of detail in that post, but the pictures, links and a bit of research may be able to get you going in the right direction.
Joined: Aug 2013
Posts: 1
lost7spirif
New Member
lost7spirif Aug 17, 11:36am - #449549 
New Member

Joined: Aug 2013
Posts: 1
United States
I just installed a after market radio, the funny thing is that I'm having the same issue. I had the harness connected but with out the antenna, I the the car on and the radio powered up but I the decided to connect the antenna. That wasn't a good idea and now the factory radio or the aftermarket radio will not show life. The clock isn't working and I check the fuses. But I'm still losted!!!
Joined: Jan 2015
Posts: 1
Nokturnal
New Member
Nokturnal Jan 12, 6:59am - #450433 
New Member

Joined: Jan 2015
Posts: 1
Nokturnal
Ok, so I am having a similar problem but I have more things that aren't working. Recently I plugged in my radar detector into my cig. Lighter and it blew my fuse. The only other one I had at the time was a higher amp fuse so I used that. When I put the radar back in again it blew this fuse as well as the 7.5 multi fuse by the kickbox. So I have replaced that now turned the car on and now my windows don't work, climate control doesn't work and guage cluster doesn't work. I have rechecked all fuses and they are all fine. What could be the cause of everything not working? Any help would be much appreciated. I have searched everywhere. Thanks
Join the conversation - Register now or Sign in to add your comment


Moderated by  isaac 

Customize Your Toyota CelicaPrivacy Policy · About · Contact
CelicaHobby.com is an independent Toyota Celica enthusiast website. CelicaHobby.com is not sponsored by or affiliated with Toyota Motor Sales, USA, Inc. in any way. The Toyota and Celica names and logos are trademarks owned by Toyota Motor Sales, USA, Inc.
© CelicaHobby.com, 2001-2016