Previous Thread
Next Thread
New Reply
Print Thread
Joined: Aug 2004
Posts: 138
Kenton2k
Member
Kenton2k Feb 17, 5:31am - #402273 
2000 Silver Toyota Celica
Member
2000 Toyota Celica

Joined: Aug 2004
Posts: 138
Colchester, Illinois
Injen CAI Install Question. URGENT.

I just bought a 1st gen Injen CAI. It only has one red hose running from the CAI tube itself. Can anyone show me a picture of where that hose hooks up to? The install guide doesnt show a good enough pic and i cant tell which of the 234234 hoses that are loose is the one it hooks up to.
Joined: Jun 2004
Posts: 3,748
hombredelassrtas
CF Connoisseur
hombredelassrtas Feb 17, 8:18pm - #402274 

CF Connoisseur
2004 Toyota Celica

Joined: Jun 2004
Posts: 3,748
Gainesville, FL
hey budd.y i dont have a pic but this si what it goes ot. There is an equvilent size hose homing out of the "lower sensor" just take out the stock hose fomrthe sensor and Hood this to it. The other smaller hose needs to be plugged. so you onlyuse 1 hose for the CAI setup. IF this didnt make sense let me knwo. Look under the RMM SRI install secitno it shows waht i am tlakign aobut. the isntall section with real pics not the drawing

[Linked Image]
Joined: Aug 2004
Posts: 138
Kenton2k
Member
Kenton2k Feb 18, 4:26am - #402275 
2000 Silver Toyota Celica
Member
2000 Toyota Celica

Joined: Aug 2004
Posts: 138
Colchester, Illinois
Alight maybe im just dumb... i really need a pic. Even without that hose hooked up to anythign the car is running great and NOT throwing a CEL surprisingly.
Join the conversation - Register now or Sign in to add your comment


Moderated by  isaac 

Customize Your Toyota CelicaPrivacy Policy · About · Contact
CelicaHobby.com is an independent Toyota Celica enthusiast website. CelicaHobby.com is not sponsored by or affiliated with Toyota Motor Sales, USA, Inc. in any way. The Toyota and Celica names and logos are trademarks owned by Toyota Motor Sales, USA, Inc.
© CelicaHobby.com, 2001-2016