Previous Thread
Next Thread
New Reply
Print Thread
Joined: Nov 2004
Posts: 306
JettaMan
Member
JettaMan Jan 27, 9:08pm - #385008 

Member
2002 Volkswagon Jetta GLS

Joined: Nov 2004
Posts: 306
Annapolis, Maryland
Um what the fuck is this... does not look good...

cracked an engine mount
1953451598-shit.JPG

[Linked Image]
Joined: Nov 2004
Posts: 306
JettaMan
Member
JettaMan Jan 27, 9:17pm - #385009 

Member
2002 Volkswagon Jetta GLS

Joined: Nov 2004
Posts: 306
Annapolis, Maryland
can you say torque? lol i guess the engine has a good amount to do that hehe fucking 2.0's wink

[Linked Image]
Joined: Jul 2004
Posts: 416
GTS02
Senior Member
GTS02 Jan 27, 10:06pm - #385010 

Senior Member
2002 Toyota Celica

Joined: Jul 2004
Posts: 416
Richland, WA
Thats Crazy, and its goig to be a bitch to fix thumbsdown
Joined: Nov 2004
Posts: 306
JettaMan
Member
JettaMan Jan 27, 10:12pm - #385011 

Member
2002 Volkswagon Jetta GLS

Joined: Nov 2004
Posts: 306
Annapolis, Maryland
nope fixed in 1 hour i am getting the car back right now

[Linked Image]
Joined: Sep 2004
Posts: 323
jl2fast4u
Member
jl2fast4u Jan 27, 11:06pm - #385012 
2001 Black Toyota Celica GT
Member
2001 Toyota Celica GT

Joined: Sep 2004
Posts: 323
Central Ca
When I first looked at the picture, I was thinking to myself, "What the fuck is up with that engine, and why is the fucking Intake put in all wrong..." Then I looked at your name and realized that it wasnt a celica engine. rofl

[Linked Image]
'01 Black Celica GT 5spd - custom catback exhaust, polished AEM CAI, TWM SS, TYC black tails, 6500k h3/h7, s2000 antenna, tein s.techs, 35%/5% tint, debadged
Joined: Nov 2004
Posts: 306
JettaMan
Member
JettaMan Jan 27, 11:17pm - #385013 

Member
2002 Volkswagon Jetta GLS

Joined: Nov 2004
Posts: 306
Annapolis, Maryland
lol ya well i just got the car back and the dealership put the right part on it (audi transmition mounts hehe)... but when they put my Intake back on they put NO bolts on it what so ever those fuckers! so all the little things you screw onto the bolts to keep them tight ya... they are gone... o well i am to make sure they made everything tight

[Linked Image]
Joined: Nov 2004
Posts: 638
mrluilou
Senior Member
mrluilou Jan 28, 12:22am - #385014 

Senior Member
2001 Toyota Celica GT

Joined: Nov 2004
Posts: 638
Palmdale, California
The good thing is that you got it fixed quick

[Linked Image]
Joined: Jan 2004
Posts: 1,612
eric_h
2low2slow
eric_h Jan 28, 12:40am - #385015 

2low2slow
2002 Toyota Celica GT

Joined: Jan 2004
Posts: 1,612
St.George, UT
haha thats a sign of excellent german engineering


JK

[Linked Image]
A boats a boat, but the mystery box could be anything....Even a boat!
Joined: Nov 2004
Posts: 306
JettaMan
Member
JettaMan Jan 28, 12:50am - #385016 

Member
2002 Volkswagon Jetta GLS

Joined: Nov 2004
Posts: 306
Annapolis, Maryland
lol thanks... and i just found that where ever the external hose goes from the Intake the thing that goes into when they bent my Intake up to fix the mount they broke 2 more rubber mounts on this thing (i have no idea what it is or what it does i know it has something to do with helping presurive the oil or fuel system...). so they lost my one and only Intake bolt and now broke 2 rubber mounts tomorrow i'm probably going to get a damn tire that falls off

[Linked Image]
Joined: Aug 2004
Posts: 1,029
kmlgts
Specialist
kmlgts Jan 28, 4:11am - #385017 

Specialist
2000 Toyota Celica

Joined: Aug 2004
Posts: 1,029
California
good luck

[Linked Image]
Joined: Aug 2004
Posts: 541
DSGB4LYF23
Senior Member
DSGB4LYF23 Jan 28, 8:24am - #385018 

Senior Member
2000 Toyota Celica GT

Joined: Aug 2004
Posts: 541
Tulsa, OK
eek
Joined: Nov 2004
Posts: 306
JettaMan
Member
JettaMan Jan 28, 10:26pm - #385019 

Member
2002 Volkswagon Jetta GLS

Joined: Nov 2004
Posts: 306
Annapolis, Maryland
well i brought my car back to volkswagon and the guys were dicks and denied that they didn't break my Intake mount and didn't break my 2nd air pump... one replacement bolt for the air pump $20 confused. O well i called them up when i got home and told them i was very unhappy with the service because i had spent $2000 earlier from getting the cars back right fixed from me sliding into the curb.. (different story). and then 250 yesterday from the broken mount... i would expect them to treat me better.. i just gave them $2200... damn...

[Linked Image]
Joined: Nov 2004
Posts: 306
JettaMan
Member
JettaMan Mar 21, 2:50am - #385020 

Member
2002 Volkswagon Jetta GLS

Joined: Nov 2004
Posts: 306
Annapolis, Maryland
and to add to this story.. this same mount just broke again after less than a month driving time (when the car was broken into.. of cource it was not driven)... i am calling them up tomorrow and being like WTF a 2.0 with 130 torque can break this mount what cheap ass stuff are you using up there

[Linked Image]
Joined: May 2004
Posts: 82
jway83
Member
jway83 Mar 21, 2:47pm - #385021 
2000 Spec Blue Mica Toyota Celica
Member
2000 Toyota Celica

Joined: May 2004
Posts: 82
Greensboro, NC
Originally Posted by JettaMan
and to add to this story.. this same mount just broke again after less than a month driving time (when the car was broken into.. of cource it was not driven)... i am calling them up tomorrow and being like WTF a 2.0 with 130 torque can break this mount what cheap ass stuff are you using up there


check your other mounts. something's causing that sucker to break, and i'd bet it's not the torque from your engine. do you spin tires a lot, and do you get wheelhop when you do? if so, you're your own culprit. if not, pay close attention to ANYTHING out of the ordinary that you can see, hear, or feel and check it out ASAP.
Join the conversation - Register now or Sign in to add your comment


Moderated by  isaac 

Customize Your Toyota CelicaPrivacy Policy · About · Contact
CelicaHobby.com is an independent Toyota Celica enthusiast website. CelicaHobby.com is not sponsored by or affiliated with Toyota Motor Sales, USA, Inc. in any way. The Toyota and Celica names and logos are trademarks owned by Toyota Motor Sales, USA, Inc.
© CelicaHobby.com, 2001-2016