Previous Thread
Next Thread
New Reply
Print Thread
Joined: Oct 2003
Posts: 1,549
JBing
Pizza Geek
JBing Jan 13, 10:20pm - #373725 

Pizza Geek
2002 Toyota Celica GT

Joined: Oct 2003
Posts: 1,549
Detroit
RPM's, Loss of Power?

just got home and the strangest thing happened while about 1/2 mile out. The car started to chug a wee bit, almost hardly noticible, then while driving it almost felt like the car came outa gear. The Rpm's shot up, then came down and the engine almost stalled out eek, I tried to give er' some gas but the car didnt wanna move, but the rpm's would sputter up? I pulled over and turned it off cause I thought I mighta hydro-locked it then turned it back on and she fired up but the rpms were bobbling between 300 and 0. so I sat there and kept reving it up and finally got them to become stable then drove home?

Anyone have a problem like this before? I let it run for 5 min in the driveway and it seems to be doing fine now confused

[Linked Image]
FS: 19" ADR M Sports
Joined: Sep 2003
Posts: 2,242
Lucky_317
Specialist
Lucky_317 Jan 13, 10:53pm - #373726 

Specialist
2000 Toyota Celica

Joined: Sep 2003
Posts: 2,242
Fontana, CA
auto or 6spd?

Best 60' 1.959 best 1/4 - 13.7 @ 101mph
Joined: Oct 2003
Posts: 1,549
JBing
Pizza Geek
JBing Jan 13, 10:53pm - #373727 

Pizza Geek
2002 Toyota Celica GT

Joined: Oct 2003
Posts: 1,549
Detroit
5 speed

[Linked Image]
FS: 19" ADR M Sports
Joined: Dec 2004
Posts: 468
GTS_Rosh
Senior Member
GTS_Rosh Jan 13, 11:07pm - #373728 

Senior Member
2004 Toyota Celica

Joined: Dec 2004
Posts: 468
Vancouver, BC, Canada
Did you go through some massive puddle with your CAI?
Joined: Oct 2003
Posts: 1,549
JBing
Pizza Geek
JBing Jan 13, 11:12pm - #373729 

Pizza Geek
2002 Toyota Celica GT

Joined: Oct 2003
Posts: 1,549
Detroit
nope, but its been raining alot. But it idles fine for now and I cant hear a knock or a tick. after I started driving it the rpms would jump from 500 to 2k when the car was at a stop. Then as fast as it started it was gone?

[Linked Image]
FS: 19" ADR M Sports
Joined: Dec 2004
Posts: 468
GTS_Rosh
Senior Member
GTS_Rosh Jan 13, 11:13pm - #373730 

Senior Member
2004 Toyota Celica

Joined: Dec 2004
Posts: 468
Vancouver, BC, Canada
It seems to me like a vacuum leak, so the ECU is trying to adjust here and there. You may wanna double-check all your hoses, make sure none of them got loose or cracked. It could also be MAF problem, not really sure.
Join the conversation - Register now or Sign in to add your comment


Moderated by  isaac 

Customize Your Toyota CelicaPrivacy Policy · About · Contact
CelicaHobby.com is an independent Toyota Celica enthusiast website. CelicaHobby.com is not sponsored by or affiliated with Toyota Motor Sales, USA, Inc. in any way. The Toyota and Celica names and logos are trademarks owned by Toyota Motor Sales, USA, Inc.
© CelicaHobby.com, 2001-2016