Previous Thread
Next Thread
New Reply
Print Thread
Rate Thread
Helpme trouble shoot Amp #373683 Jan 13, 1:16pm Jan 13, 1:16pm
Joined: Aug 2004
Posts: 415
California
BigTony OP
Senior Member
2000 Toyota Celica GT
BigTony OP
Senior Member
2000 Toyota Celica GT

Joined: Aug 2004
Posts: 415
California
Helpme trouble shoot Amp
I had my sony Amp connected to my car. Friend fucked with it and the ground wire hit the positive wire and got a spark. After that it didn't work. First time this happened all i had to do was replace the fuse on the 12v + wire and it worked again. This time it isn't working for me. The PowerProtector that is suppose to light up red when something is fucked up doesn't show. So i have no idea wtf is wrong. I called up crutchfield to help and did everything he suggested that i try to do:



I did a remote bypass by connecting the + 12v to the remote input.
I replaced the fuse on the 8 gauge wire.
I tried connecting it up to my other car's battery.
I looked at all the fuses on the amp and they were fine.


Then I tried connecting ANOTHER amp to my car...and to my amazment it didn't work either. So wtf is wrong here, I've set up systems before and had no problems until now...


[Linked Image]
Re: Helpme trouble shoot Amp [Re: BigTony] #373684 Jan 13, 2:04pm Jan 13, 2:04pm
Joined: Sep 2003
Posts: 2,242
Fontana, CA
Lucky_317
Specialist
2000 Toyota Celica
Lucky_317
Specialist
2000 Toyota Celica

Joined: Sep 2003
Posts: 2,242
Fontana, CA
try this, hook the remote to the power terminal with a small wire, then hook a small ground wire to the negative battery terminal and a small wire to the positive. if the fuses on the amp are ok then this SHOULD turn on the amp.

if it does then perhaps there's a break in your wire somewhere.

also take a multi meter and measure the current from teh power and ground you were using. that'll tell you if the juice is coming.

just some suggestions.

or you could drive out here if you cant figure it out and I can look at it rofl


Best 60' 1.959 best 1/4 - 13.7 @ 101mph
Re: Helpme trouble shoot Amp [Re: Lucky_317] #373685 Jan 13, 2:08pm Jan 13, 2:08pm
Joined: Sep 2003
Posts: 2,242
Fontana, CA
Lucky_317
Specialist
2000 Toyota Celica
Lucky_317
Specialist
2000 Toyota Celica

Joined: Sep 2003
Posts: 2,242
Fontana, CA
also I'm gonna be in live chat for a bit


Best 60' 1.959 best 1/4 - 13.7 @ 101mph
Join the conversation - Register Now or Log In to add your comment


Moderated by  isaac 

Member Spotlight
silverOOgts
silverOOgts
2000 Toyota Celica GTS
DSM, IA

Posts: 520
Joined: October 2003
Thanks: To the big guy in the sky........
Random: NO officer its a UNICYCLE with a SPARE tire!
Show All Member Profiles 
Recent Topics
97 celica cluster bulbs
by 97celica. 01/17/2018 3:06 PM
parts for the celica
by Mac_TheBeard. 01/13/2018 11:58 PM
Gen 7 washer and rear fog lights
by Craigf. 01/12/2018 11:46 AM
1989 GT (not s) suspension options
by lexlothar. 01/10/2018 6:24 AM
Engine swapping my 1999 celica
by Kyles_celica. 01/08/2018 1:21 PM
hi guys. im very dissapointed with my celica
by nandi. 01/06/2018 1:52 PM
Buying another Celica .
by Geno. 01/05/2018 6:46 PM
Noob Help / No heat
by avoll. 01/05/2018 5:36 AM
Customize Your Toyota Celica Privacy Policy · About · Contact
Privacy Policy · About · Contact
CelicaHobby.com is an independent Toyota Celica enthusiast website. CelicaHobby.com is not sponsored by or affiliated with Toyota Motor Sales, USA, Inc. in any way. The Toyota and Celica names and logos are trademarks owned by Toyota Motor Sales, USA, Inc.
© CelicaHobby.com, 2001-2018
Powered by UBB.threads™ PHP Forum Software 7.6.2
(Preview build 20180114)