Previous Thread
Next Thread
New Reply
Print Thread
Joined: Aug 2004
Posts: 415
BigTony
Senior Member
BigTony

Senior Member
2000 Toyota Celica GT

Joined: Aug 2004
Posts: 415
California
Jan 13, 2:16pm - #373683 
Helpme trouble shoot Amp

I had my sony Amp connected to my car. Friend fucked with it and the ground wire hit the positive wire and got a spark. After that it didn't work. First time this happened all i had to do was replace the fuse on the 12v + wire and it worked again. This time it isn't working for me. The PowerProtector that is suppose to light up red when something is fucked up doesn't show. So i have no idea wtf is wrong. I called up crutchfield to help and did everything he suggested that i try to do:



I did a remote bypass by connecting the + 12v to the remote input.
I replaced the fuse on the 8 gauge wire.
I tried connecting it up to my other car's battery.
I looked at all the fuses on the amp and they were fine.


Then I tried connecting ANOTHER amp to my car...and to my amazment it didn't work either. So wtf is wrong here, I've set up systems before and had no problems until now...


[Linked Image]
Joined: Sep 2003
Posts: 2,242
Lucky_317
Specialist
Lucky_317

Specialist
2000 Toyota Celica

Joined: Sep 2003
Posts: 2,242
Fontana, CA
Jan 13, 3:04pm - #373684 
try this, hook the remote to the power terminal with a small wire, then hook a small ground wire to the negative battery terminal and a small wire to the positive. if the fuses on the amp are ok then this SHOULD turn on the amp.

if it does then perhaps there's a break in your wire somewhere.

also take a multi meter and measure the current from teh power and ground you were using. that'll tell you if the juice is coming.

just some suggestions.

or you could drive out here if you cant figure it out and I can look at it rofl


Best 60' 1.959 best 1/4 - 13.7 @ 101mph
Joined: Sep 2003
Posts: 2,242
Lucky_317
Specialist
Lucky_317

Specialist
2000 Toyota Celica

Joined: Sep 2003
Posts: 2,242
Fontana, CA
Jan 13, 3:08pm - #373685 
also I'm gonna be in live chat for a bit


Best 60' 1.959 best 1/4 - 13.7 @ 101mph
Join the conversation - Register Now or Log In to add your comment


Moderated by  isaac 

Member Spotlight
Carbonblue2005GT
Carbonblue2005GT
2005 Toyota Celica GT
Walnut Creek, CA

Posts: 51
Joined: January 2005
Show All Member Profiles 
Recent Topics
Audio wiring issue
by redmarien. 06/24/2017 3:49 PM
Electrical Issue
by zenbone. 06/17/2017 12:40 PM
Manifold intake hose
by Celicafannn23. 06/10/2017 12:29 PM
Wheel size
by enjoi94. 06/08/2017 6:33 PM
Replaced Lock Actuator Issues
by geekbits. 06/08/2017 12:06 PM
Engine swap
by Darkgazer666. 06/06/2017 3:50 PM
What brand of wheels are these guys?
by jennmarkov. 06/05/2017 7:24 AM
WTB: Tsunami Rear Bumper
by valkyrie_gt. 06/04/2017 11:31 AM
Customize Your Toyota Celica Privacy Policy · About · Contact
Privacy Policy · About · Contact
CelicaHobby.com is an independent Toyota Celica enthusiast website. CelicaHobby.com is not sponsored by or affiliated with Toyota Motor Sales, USA, Inc. in any way. The Toyota and Celica names and logos are trademarks owned by Toyota Motor Sales, USA, Inc.
© CelicaHobby.com, 2001-2017
Powered by UBB.threads™ PHP Forum Software 7.6.1
(Snapshot build 20170611)