Previous Thread
Next Thread
New Reply
Print Thread
Joined: Apr 2003
Posts: 802
shox
Senior Member
shox

Senior Member
2003 Toyota Celica GT

Joined: Apr 2003
Posts: 802
Calgary, Alberta
Aug 14, 4:01pm - #36122 
something's seriously wrong wit my car...

ok, i took out my CAI and installed the stock Intake back into my 2003. anyways, it was working fine at first, sounds normal, whatever, then now, the car revs by itself! then, after revving by itself (in neutral that is), it might not rev at all. like, it'll rev 500RPM which rumbles the car like crazy like it's gonna stall. then b4 you know it, it stalls, all on it's own. then you go start it up again, it stalls, start up, stalls...shit man, i starting to get sick of this car. anyways, anyone know what might be wrong?

Joined: Dec 2002
Posts: 1,660
Grand-Touring-Dan
ECelica Staff
Grand-Touring-Dan
2001 Spec Blue Toyota Celica
ECelica Staff
2001 Toyota Celica

Joined: Dec 2002
Posts: 1,660
Houston, TX
Aug 14, 4:33pm - #36123 
Could you have possibly hooked up a hose wrong, Your air snesor could be dirty.

Joined: Oct 2002
Posts: 1,233
EuRoBoYGT
black & blue 4 you
EuRoBoYGT

black & blue 4 you
2000 Toyota Celica GT

Joined: Oct 2002
Posts: 1,233
El Paso, TX
Aug 14, 4:40pm - #36124 
after checking the hosing disconnect the battery for about 10 mins to let the ecu reset


[Linked Image]
i've been changing but you'll never see me now
now i'm blaming you for everything
Joined: Mar 2003
Posts: 399
Celicatastrophe
Member
Celicatastrophe
Member
2000 Toyota Celica GT

Joined: Mar 2003
Posts: 399
Jacksonville, Florida
Aug 14, 6:00pm - #36125 
make sure you don't have any vacuum hoses disconnected.


SURGEON GENERAL'S WARNING:
Post Whoring May Result In
Premature Brain Retardation

Joined: Jun 2002
Posts: 820
GOLDCELICA
Senior Member
GOLDCELICA

Senior Member

Joined: Jun 2002
Posts: 820
San Diego
Aug 14, 6:09pm - #36126 
Make sure you put all the hoses in properly and see if the manifold hose is connect. Clean maf and reset. If it's throwing a cell figure out the code of what's going on.


Originate, Innovate, Never Imitate. Since 2000-04.
Joined: Jan 2003
Posts: 2,161
Street Prototype
ECelica Staff
Street Prototype

ECelica Staff
2002 Toyota Celica GT

Joined: Jan 2003
Posts: 2,161
Guam, U.S.A.
Aug 14, 6:41pm - #36127 
like these guys said


[Linked Image]
Joined: Jul 2002
Posts: 10,123
VSGTS14
05 WRB
VSGTS14

05 WRB
2005 Subaru WRX STi

Joined: Jul 2002
Posts: 10,123
Milford, NJ
Aug 14, 8:42pm - #36128 
Originally Posted by Street Prototype
like these guys said


SUBARU TECNICA INTERNATIONAL
Joined: Apr 2003
Posts: 802
shox
Senior Member
shox

Senior Member
2003 Toyota Celica GT

Joined: Apr 2003
Posts: 802
Calgary, Alberta
Aug 14, 9:17pm - #36129 
hoses are all connected properly, i had the battery disconnected for over an hour.

my car, is officially stuck in my friggin garage...

Joined: Feb 2003
Posts: 524
celica2kgts
Senior Member
celica2kgts
2000 Viper Red W/ Purple Toyota Celica
Senior Member
2000 Toyota Celica

Joined: Feb 2003
Posts: 524
New Hampshire
Aug 15, 2:02am - #36130 
frown sorry bro thats no good thumbsdown
so why did you take the Intake off????

Joined: May 2003
Posts: 5,346
spaztikid
dikitzaps
spaztikid
dikitzaps
1974 Toyota Celica

Joined: May 2003
Posts: 5,346
LA
Aug 15, 5:58am - #36131 
put the Intake back on and see if it works.

Joined: Apr 2003
Posts: 802
shox
Senior Member
shox

Senior Member
2003 Toyota Celica GT

Joined: Apr 2003
Posts: 802
Calgary, Alberta
Aug 17, 12:37am - #36132 
Originally Posted by celica2kgts
frown sorry bro thats no good thumbsdown
so why did you take the intake off????


i dunno, didn't feel like it no more ya know...
like i was figuring since i'm gonna go for looks anyways, what's the point of 1 little engine mod that does barely anything.

Joined: Apr 2003
Posts: 802
shox
Senior Member
shox

Senior Member
2003 Toyota Celica GT

Joined: Apr 2003
Posts: 802
Calgary, Alberta
Aug 17, 12:39am - #36133 
Originally Posted by spaztikid
put the intake back on and see if it works.


too late, it's in the shop... i wouldn't put it back in anyways because the check engine light is always on and it's starting to piss me off. another reason why i took it out, i couldn't figure out why that damn light is always on.

well, let's all hope for some good news, maybe the warranty will work for this. they dunno i've put in a CAI so lol, i'll pretend stupid and say "i dunno what's wrong".

Joined: Jul 2003
Posts: 161
Pnoiracerz
Member
Pnoiracerz
2003 Carbon Blue Toyota Celica GT
Member
2003 Toyota Celica GT

Joined: Jul 2003
Posts: 161
(Wangan!) Honolulu, Hawaii
Aug 17, 3:08am - #36134 
lol, Good luck bro. rice

Joined: Aug 2003
Posts: 15
Ernest
Member
Ernest
1981 Red Toyota Celica
Member
1981 Toyota Celica

Joined: Aug 2003
Posts: 15
Philippines
Aug 17, 10:47am - #36135 
It would either be a vacume leak or your MAF was not properly plugged in. I would bet on the vacume leak. smile Good luck and tell us how it turns out! smile


<The Car GeEk>
Joined: Jul 2003
Posts: 431
ssgsky
Senior Member
ssgsky

Senior Member
2002 Toyota Celica GT

Joined: Jul 2003
Posts: 431
fort hood texas
Aug 17, 2:39pm - #36136 
guess either i am lucky or my check engine light dont work, it has never come on since i put my Short Ram on


10.7157 @ 131.31 on my bike
Joined: Apr 2003
Posts: 802
shox
Senior Member
shox

Senior Member
2003 Toyota Celica GT

Joined: Apr 2003
Posts: 802
Calgary, Alberta
Aug 19, 6:38pm - #36137 
okay, so the dealership finally gave me some news after they towed my car away last friday.

first of all, they didn't touch my car at all until monday and they said i could pick it up monday. i then call back and they said they're not gonna be done, that i can pick it up tuesday. i called tuesday (today), and they took apart my car again and found that my VVT-I Control Chip (i think that's what you call it) is fried. need a new one, it'll take another day or 2 to fix. i'm guessing it's gonna be another week knowing these guys.

second of all...i'm frustrated with no car man...this sux! so much stuff to do this week and i couldn't get it done.

Joined: May 2002
Posts: 3,295
Steven
ECelica Staff
Steven
2001 Spectra Blue Mica Toyota Celica GTS
ECelica Staff
2001 Toyota Celica GTS

Joined: May 2002
Posts: 3,295
Riverside, CA
Aug 20, 12:17am - #36138 
shox - ask for a loaner car.

Joined: Apr 2003
Posts: 802
shox
Senior Member
shox

Senior Member
2003 Toyota Celica GT

Joined: Apr 2003
Posts: 802
Calgary, Alberta
Aug 20, 4:21pm - #36139 
nah, i'll live...for now...

"Patience is a Virtue"

Join the conversation - Register Now or Log In to add your comment


Moderated by  isaac 

Member Spotlight
aspen
aspen
2003 Toyota Celica GT Turbo
Guam, USA

Posts: 298
Joined: April 2003
Thanks: Shout out to all members of R TOY/GUARANTEED especially for Richard and Totoy for putting my turbo on and being the first in Guam and maybe few on all places!
Show All Member Profiles 
Recent Topics
Audio wiring issue
by redmarien. 06/24/2017 3:49 PM
Electrical Issue
by zenbone. 06/17/2017 12:40 PM
Manifold intake hose
by Celicafannn23. 06/10/2017 12:29 PM
Wheel size
by enjoi94. 06/08/2017 6:33 PM
Replaced Lock Actuator Issues
by geekbits. 06/08/2017 12:06 PM
Engine swap
by Darkgazer666. 06/06/2017 3:50 PM
What brand of wheels are these guys?
by jennmarkov. 06/05/2017 7:24 AM
WTB: Tsunami Rear Bumper
by valkyrie_gt. 06/04/2017 11:31 AM
Customize Your Toyota Celica Privacy Policy · About · Contact
Privacy Policy · About · Contact
CelicaHobby.com is an independent Toyota Celica enthusiast website. CelicaHobby.com is not sponsored by or affiliated with Toyota Motor Sales, USA, Inc. in any way. The Toyota and Celica names and logos are trademarks owned by Toyota Motor Sales, USA, Inc.
© CelicaHobby.com, 2001-2017
Powered by UBB.threads™ PHP Forum Software 7.6.1
(Snapshot build 20170611)