Previous Thread
Next Thread
New Reply
Print Thread
Rate Thread
something from my engine blew... #3581 Dec 10, 10:19pm Dec 10, 10:19pm

A
Anonymous OP
Unregistered
Anonymous OP
A
Unregistered



something from my engine blew...
well basically...ever since i got my Injen Intake...i couldn't get my CEL off...and everytime i refill the gas...my engine starts idling weird and almost stalls...it never stalled on me...but today it did...after i put in gas my engine stalled on me in NEUTRAL...after it stalled the first time...it stalled AGAIN the second time...and when it stalled the second time something under my Hood went POP..and smoke started coming from my left side Hood... i popped my Hood...but couldn't see anything burning and the smoke already stopped...maybe 20 seconds...cuz i was surprised on what just happened...so if you guys know anything that could be problems please tell me...thanks

[ 12-10-2002, 10:22 PM: Message edited by: Doublez ]

Re: something from my engine blew... #3582 Dec 10, 11:01pm Dec 10, 11:01pm
Joined: Dec 2002
Posts: 24
California
T
TIGERSTYLE87
Member
TIGERSTYLE87
T
Member

Joined: Dec 2002
Posts: 24
California
Check if the Intake was installed improperly. The piping may be too low and hitting other parts or tubing to vital engine parts. When the piping on your Intake heats, it could melt something. I could be wrong but this is just my two cents. thumbsup

Re: something from my engine blew... [Re: TIGERSTYLE87] #3583 Dec 12, 4:07pm Dec 12, 4:07pm
Joined: May 2002
Posts: 224
Irvine
E
Eugic92
Member
Eugic92
E
Member

Joined: May 2002
Posts: 224
Irvine
something like that happened to my car...car just kept stalling after getting gas...one time i got gas and started the engine and i heard the loud pop sound, i drove it a bit and when i checked later, it was one of the silicon hoses that popped off the Intake. check it.

Re: something from my engine blew... [Re: Eugic92] #3584 Dec 12, 4:28pm Dec 12, 4:28pm

A
Anonymous OP
Unregistered
Anonymous OP
A
Unregistered



yea make sure you installed it correctly, make sure all your hoses are on tight with clamps, and put everythinng back together

Re: something from my engine blew... #3585 Dec 15, 7:29pm Dec 15, 7:29pm

A
Anonymous OP
Unregistered
Anonymous OP
A
Unregistered



thanks...i'll check it out...

Join the conversation - Register Now or Log In to add your comment


Moderated by  isaac 

Member Spotlight
TRDOTC
TRDOTC
2003 Toyota Celica GT
Pocasset, MA

Posts: 722
Joined: September 2004
Thanks: To Gas and Bing (C2Power) for helping me out, and everyone on this site for their knowledge
Random: Can't live without ecelica.com (or my Celica!!)
Show All Member Profiles 
Recent Topics
stock radio hardware
by 97celica. 12/12/2017 12:12 PM
FS: 2000 Toyota Celica for sale Los Angeles area
by LaRN. 12/10/2017 9:52 AM
Toyota Celica Upgrades
by FlawlessGamerYT. 12/09/2017 11:06 AM
Why did my tachometer stop working
by NinjaMasterShaw. 12/08/2017 6:20 AM
Gauge cluster board aftermarket
by NinjaMasterShaw. 12/07/2017 5:06 PM
How would I go about giving my steering wheel a facelift
by NinjaMasterShaw. 12/06/2017 2:22 PM
Hard to press cluch pedal?
by Arve2afm. 12/05/2017 6:40 AM
Hello! New Member here :)
by Kizmo_JW. 11/29/2017 2:30 PM
Customize Your Toyota Celica Privacy Policy · About · Contact
Privacy Policy · About · Contact
CelicaHobby.com is an independent Toyota Celica enthusiast website. CelicaHobby.com is not sponsored by or affiliated with Toyota Motor Sales, USA, Inc. in any way. The Toyota and Celica names and logos are trademarks owned by Toyota Motor Sales, USA, Inc.
© CelicaHobby.com, 2001-2017
Powered by UBB.threads™ PHP Forum Software 7.6.1
(Snapshot build 20171122)