Previous Thread
Next Thread
New Reply
Print Thread
Joined: Sep 2004
Posts: 722
TRDOTC
Senior Member
TRDOTC Dec 21, 11:38pm - #356118 

Senior Member
2003 Toyota Celica GT

Joined: Sep 2004
Posts: 722
Pocasset, MA
Help with f'd up light situation

My hyper whites have been working fine since i have had then for a couple of weeks...i started my car tonight to run it since i haven't driven it for the past two days. Well, with the ebrake on, no lights come on so i took of the ebrake and put it back on after the lights came on. The driver side low beam which automatically is on at night is fine (not the parking light so you don't think i mean them) but the passenger side the parking light is on but no low beam...i didn't know both were on at the same time but someone help...and hopefully isaac will send me a new bulb for free and ill send this one back if i find out it is blown since i just bought them and this will be the third set of hyper white lights i have bought and this isn't cool anymore, especially how much it costs. The two days ago it was fine. I should probably check my fog lights but i think they were fine. Could it be from the cold?? Just snowed last night. By the way, when i installed them i didn't touch them with my skin nor any of the car. Thanks for any help. smile
Joined: Sep 2003
Posts: 2,242
Lucky_317
Specialist
Lucky_317 Dec 21, 11:58pm - #356119 

Specialist
2000 Toyota Celica

Joined: Sep 2003
Posts: 2,242
Fontana, CA
hmm thats pretty wierd. did you try putting a stock bulb in its place to see if its the bulb or not? or perhaps the bulb came loose somehow?

Best 60' 1.959 best 1/4 - 13.7 @ 101mph
Joined: Sep 2004
Posts: 722
TRDOTC
Senior Member
TRDOTC Dec 22, 12:00am - #356120 

Senior Member
2003 Toyota Celica GT

Joined: Sep 2004
Posts: 722
Pocasset, MA
i would try but it is freckin pitch black and 20 degrees lol, ill try tomorrow with the bulb but i am going to pop the Hood anyway and see if wires are loose..i hope just came loose
Joined: Feb 2004
Posts: 965
morris
Berraquísima!
morris Dec 22, 6:46am - #356121 
2000 White Toyota Celica GT
Berraquísima!
2000 Toyota Celica GT

Joined: Feb 2004
Posts: 965
Orange County, CA
Originally Posted by TRDOTC

My hyper whites have been working fine since i have had then for a couple of weeks...i started my car tonight to run it since i haven't driven it for the past two days. Well, with the ebrake on, no lights come on so i took of the ebrake and put it back on after the lights came on. The driver side low beam which automatically is on at night is fine (not the parking light so you don't think i mean them) but the passenger side the parking light is on but no low beam...i didn't know both were on at the same time but someone help...and hopefully isaac will send me a new bulb for free and ill send this one back if i find out it is blown since i just bought them and this will be the third set of hyper white lights i have bought and this isn't cool anymore, especially how much it costs. The two days ago it was fine. I should probably check my fog lights but i think they were fine. Could it be from the cold?? Just snowed last night. By the way, when i installed them i didn't touch them with my skin nor any of the car. Thanks for any help. smile

I got exactly the same situation...
Check the fuses happywink
spineyes here is my story https://www.celicahobby.com/ubbthreads/thread.f_1953339884_0_collapsed_5__1.html
Joined: Feb 2004
Posts: 1,716
celicafourotwo
Specialist
celicafourotwo Dec 22, 6:53am - #356122 

Specialist
2000 Toyota Celica

Joined: Feb 2004
Posts: 1,716
Nebraska
that was really hard to understand..but i guess my reading stinks.. grin..might want to check ur connection..that's all i can suggest..

Originally Posted by pesho01
Question:
Whenever my car is at a full stop or even in park the RPM never sits on 0. what does this mean?
Joined: Feb 2004
Posts: 965
morris
Berraquísima!
morris Dec 22, 7:10am - #356123 
2000 White Toyota Celica GT
Berraquísima!
2000 Toyota Celica GT

Joined: Feb 2004
Posts: 965
Orange County, CA
Originally Posted by morris
Originally Posted by TRDOTC
My hyper whites have been working fine since i have had then for a couple of weeks...i started my car tonight to run it since i haven't driven it for the past two days. Well, with the ebrake on, no lights come on so i took of the ebrake and put it back on after the lights came on. The driver side low beam which automatically is on at night is fine (not the parking light so you don't think i mean them) but the passenger side the parking light is on but no low beam...i didn't know both were on at the same time but someone help...and hopefully isaac will send me a new bulb for free and ill send this one back if i find out it is blown since i just bought them and this will be the third set of hyper white lights i have bought and this isn't cool anymore, especially how much it costs. The two days ago it was fine. I should probably check my fog lights but i think they were fine. Could it be from the cold?? Just snowed last night. By the way, when i installed them i didn't touch them with my skin nor any of the car. Thanks for any help. smile

I got exactly the same situation...
Check the fuses happywink
spineyes here is my story https://www.celicahobby.com/ubbthreads/thread.f_1953339884_0_collapsed_5__1.html


Check the fuses with the red arrows happywink
More info about the fuse box: https://www.celicahobby.com/photos/ShopMan2_BE/celicashopmanual2_Page_0837?full=1 wave
1953396658-fuse_box_engine_lights.jpg
Joined: Sep 2004
Posts: 722
TRDOTC
Senior Member
TRDOTC Dec 22, 10:04pm - #356124 

Senior Member
2003 Toyota Celica GT

Joined: Sep 2004
Posts: 722
Pocasset, MA
thanks guys...took my bulb about about 5 minutes ago...the f'er burned my black piece that connects that to the white plug angry angry haven't had them long at all..these lights are really, really annoying now...they seem not to be worth the money...bulb blew and burned shit...that plug doesn't come with the light bulbs does it?? the black bigger plug i have to order from toyota??? thanks
Joined: Jul 2003
Posts: 1,276
DJ_Curtiz
Specialist
DJ_Curtiz Dec 22, 11:12pm - #356125 
2001 Liquid Silver Toyota Celica GT
Specialist
2001 Toyota Celica GT

Joined: Jul 2003
Posts: 1,276
Orange County, CA
damm that sux bro... frown

DJ CURTIZ - taking over the world one record at a time
Live life on the edge, otherwise you take up too much space.
Joined: May 2003
Posts: 522
Rave669
Senior Member
Rave669 Dec 23, 8:15pm - #356126 

Senior Member
2002 Toyota Celica

Joined: May 2003
Posts: 522
Lisle, IL
when upgrading to Aftermarket bulbs like the hyper whites, it's usually best to upgrade the wiring harnesses for the bulbs as well, since they draw more current and burn hotter.

Most aftermarket shops (online and storefront shops) carry upgrade harness kits with heavier gauge wires and new plugs for the bulbs.

Speaking from experience, aftermarket bulbs (anything brighter than a silverstar) will eventually melt lamp housings, wire insulation, etc. This is the main reason why I don't run those sort of bulbs anymore.

[Linked Image]
Joined: May 2004
Posts: 2,979
RookieGTS
Boobie Vision
RookieGTS Dec 23, 8:53pm - #356127 

Boobie Vision
2000 Toyota Celica

Joined: May 2004
Posts: 2,979
925 Nor Cal
sorry to hear about your dilemma! Good Luck in the long run.
Join the conversation - Register now or Sign in to add your comment


Moderated by  isaac 

Customize Your Toyota CelicaPrivacy Policy · About · Contact
CelicaHobby.com is an independent Toyota Celica enthusiast website. CelicaHobby.com is not sponsored by or affiliated with Toyota Motor Sales, USA, Inc. in any way. The Toyota and Celica names and logos are trademarks owned by Toyota Motor Sales, USA, Inc.
© CelicaHobby.com, 2001-2016