Previous Thread
Next Thread
New Reply
Print Thread
Joined: Jun 2004
Posts: 1,337
celicadragon
Specialist
celicadragon Dec 6, 2:17pm - #344340 

Specialist
2002 Toyota Celica

Joined: Jun 2004
Posts: 1,337
Pittsburgh, PA
@has this ever happend to you?@

i was on my way to work this morning started my car up fine for the first time today and made it about one mile when my rpms got stuck 2000 and when i floored my gas my car moved slightly faster but not more than 2 mph faster so i pulled over and revved my engine and it went up while i was in nuetral like it was supposed to and then i turned my car off and thought i smelled maybe a sweet smell but not sure if it was coming from my car since i was by a creek thats pretty nasty i popped the Hood nothin seemed out of place checked my exhauset for anything stuck in it i found nothin so i turned her back on and drove fine for the next 3 miles to work-i am so confused what could this be my car is a 2002 gts automatic-thanks
Joined: Jun 2004
Posts: 1,337
celicadragon
Specialist
celicadragon Dec 6, 5:25pm - #344341 

Specialist
2002 Toyota Celica

Joined: Jun 2004
Posts: 1,337
Pittsburgh, PA
i dont know what to do

respect the gt-s
Joined: Jun 2004
Posts: 182
UnlimitationZ
Member
UnlimitationZ Dec 6, 6:21pm - #344342 

Member

Joined: Jun 2004
Posts: 182
San Francisco
It would be great if you used punctuation. Thank.

.::Expect The Unexpected::.

{o.0}
Joined: Apr 2004
Posts: 427
speed_celica
Senior Member
speed_celica Dec 6, 6:59pm - #344343 

Senior Member
2000 Toyota Celica

Joined: Apr 2004
Posts: 427
Calgary, AB, Canada
It's pretty confusing trying to read what you've typed... anyways, doesn't sound like any common problem among celicas. Is it due for a tune up? Your cars fairly new so maybe you should mention it to Toyota!
...and yeah, punctuation would be good! thumbsup
Joined: Oct 2003
Posts: 3,038
Clos
Specialist
Clos Dec 6, 7:29pm - #344344 
2000 Spectra Blue Toyota Celica
Specialist
2000 Toyota Celica

Joined: Oct 2003
Posts: 3,038
Alexandria, VA
try this first MAF
if not clean your throttle body, if nothing works take it to the dealer
Joined: Jun 2004
Posts: 1,337
celicadragon
Specialist
celicadragon Dec 6, 10:02pm - #344345 

Specialist
2002 Toyota Celica

Joined: Jun 2004
Posts: 1,337
Pittsburgh, PA
thanks. sorry about the confusing post. i will try that.

respect the gt-s
Joined: Oct 2003
Posts: 95
racergts03
Member
racergts03 Dec 7, 9:39am - #344346 

Member
2003 Toyota Celica

Joined: Oct 2003
Posts: 95
Dyess AF Base, Abilene, TX
The way you described it sounded like the same thing that happened to me. For me it was a bad electronic throttle body(2003 DBW) Since your's is a 02, I don't think that's the case. I would try cleaning your MAF sensor.
Joined: Jun 2004
Posts: 1,337
celicadragon
Specialist
celicadragon Dec 7, 7:44pm - #344347 

Specialist
2002 Toyota Celica

Joined: Jun 2004
Posts: 1,337
Pittsburgh, PA
i guess i will try that-thanks--it hasnt happend agian

respect the gt-s
Joined: Jan 2004
Posts: 1,612
eric_h
2low2slow
eric_h Dec 8, 3:12am - #344348 

2low2slow
2002 Toyota Celica GT

Joined: Jan 2004
Posts: 1,612
St.George, UT
sweet smell.. i heard what thats a sign of but i cant remember, some kind of engine fluid, if i can remember ill let you know

[Linked Image]
A boats a boat, but the mystery box could be anything....Even a boat!
Joined: Jun 2004
Posts: 1,696
Polykarb
Metal Storm 2040
Polykarb Dec 8, 6:02am - #344349 

Metal Storm 2040
2000 Toyota Celica

Joined: Jun 2004
Posts: 1,696
Tampa, Florida
Originally Posted by eric_h
sweet smell.. i heard what thats a sign of but i cant remember, some kind of engine fluid, if i can remember ill let you know


It's Coolant

FF TWINCAM BEAUTY: CELICA
Joined: Jun 2004
Posts: 1,337
celicadragon
Specialist
celicadragon Dec 8, 2:14pm - #344350 

Specialist
2002 Toyota Celica

Joined: Jun 2004
Posts: 1,337
Pittsburgh, PA
i will have to check the coolant but my engine hasnt been running hot-ill look anyway-but still hasnt happend again-could this be bad fuel maybe?

respect the gt-s
Joined: Jun 2004
Posts: 1,337
celicadragon
Specialist
celicadragon Dec 16, 2:43pm - #344351 

Specialist
2002 Toyota Celica

Joined: Jun 2004
Posts: 1,337
Pittsburgh, PA
well, it happend again for the second time today at the same spot. and this time i tried using my m-mode while it happend and m-mode wouldnt work. the only thing that fixed it this time was putting in neutral then back to drive. and then it was fine the rest of the way i think i am gonna make an appointment at the dealer to check my auto transmission

respect the gt-s
Join the conversation - Register now or Sign in to add your comment


Moderated by  isaac 

Customize Your Toyota CelicaPrivacy Policy · About · Contact
CelicaHobby.com is an independent Toyota Celica enthusiast website. CelicaHobby.com is not sponsored by or affiliated with Toyota Motor Sales, USA, Inc. in any way. The Toyota and Celica names and logos are trademarks owned by Toyota Motor Sales, USA, Inc.
© CelicaHobby.com, 2001-2016