Previous Thread
Next Thread
New Reply
Print Thread
Joined: Feb 2003
Posts: 165
Deseck
Member
Deseck Oct 28, 10:37pm - #312272 

Member
2002 Toyota Celica GT

Joined: Feb 2003
Posts: 165
San Antonio, TX
ANOTHER CEL QUESTION

ok...I had my CAI installed about 3 weeks ago...last weeekend I got a CEL...i disconnected the neg. battery and reset the ECU...CEL went away for 3 days, and now its back. I went to get the codes checked and it came back with these:

1. P0440
The PCM has determined that a malfunction exists in the evaporative emission control system.

2. P0441
The PCM has determined that the purge flow in the evaporative emission control system is incorrect for the current engine operating conditions.

3. P0446
The PCM has determined that a malfunction exists in the electrical circuit for the vent control in the evaporative emission control system.


What does this mumbo jumbo mean? Any help?

"I ride big body Benz, Gucci shade lens/
Me an all my friends got the platinum diamond grin/
Everything Im in spin, on 20" Larenz/
Lay back on buckskin, wit my braids in the wind."
Joined: Apr 2004
Posts: 405
importcarbabe
Turbonator
importcarbabe Oct 28, 10:40pm - #312273 

Turbonator
2000 Toyota Celica

Joined: Apr 2004
Posts: 405
Minnesota....Yaa!!!
Check all the vacuum lines that are connected to the Intake, make sure you didnt mix them up. it could also be a 02 sensor. and what kind of Intake did you install?

"If you dont like Hair blowers why would you like Turbo's"

Last car '92 Eagle Talon TSI AWD, R.I.P, Current car '00 Toyota Celica GT-S. Next car Fully Built 1st Gen AWD DSM.


Joined: Feb 2003
Posts: 165
Deseck
Member
Deseck Oct 28, 11:08pm - #312274 

Member
2002 Toyota Celica GT

Joined: Feb 2003
Posts: 165
San Antonio, TX
AEM gen 2.

"I ride big body Benz, Gucci shade lens/
Me an all my friends got the platinum diamond grin/
Everything Im in spin, on 20" Larenz/
Lay back on buckskin, wit my braids in the wind."
Joined: May 2004
Posts: 300
Miketrd
Member
Miketrd Oct 29, 4:31am - #312275 
2003 Silver Toyota Celica GT
Member
2003 Toyota Celica GT

Joined: May 2004
Posts: 300
Puerto Rico
shit, i have that same problem and that stupid cel light does't stop from coming on,

i also have the AEM gen 2 but i don't have any idea what to do!

can someone help?
Joined: Aug 2004
Posts: 1,002
Pnoy
Specialist
Pnoy Oct 29, 4:36am - #312276 
02 Spectra Blue Toyota Celica
Specialist
02 Toyota Celica

Joined: Aug 2004
Posts: 1,002
Chicago, IL
take a close snapshot of your Intake together with the hose connection. oh and make sure you disconnect that blue plug coz you don't need it in there. And please oh please disconnect the battery when fixing your CAI. I have AEM CAI gen2, it's over a month now and no CAI. thumbsup
Joined: May 2004
Posts: 300
Miketrd
Member
Miketrd Oct 29, 4:49am - #312277 
2003 Silver Toyota Celica GT
Member
2003 Toyota Celica GT

Joined: May 2004
Posts: 300
Puerto Rico
here it is
1953300911-AEM Intake 003.jpg
Joined: Feb 2003
Posts: 165
Deseck
Member
Deseck Oct 29, 10:31pm - #312278 

Member
2002 Toyota Celica GT

Joined: Feb 2003
Posts: 165
San Antonio, TX
bumpin...anyone have any other info?

"I ride big body Benz, Gucci shade lens/
Me an all my friends got the platinum diamond grin/
Everything Im in spin, on 20" Larenz/
Lay back on buckskin, wit my braids in the wind."
Joined: Jan 2004
Posts: 744
Blue_Bomber
Senior Member
Blue_Bomber Oct 30, 12:02am - #312279 
2000 Spectra Blue Mica Toyota Celica
Senior Member
2000 Toyota Celica

Joined: Jan 2004
Posts: 744
Freehold, NJ
On the little cylinder shaped vacuum switch attached to the lower half of the Intake, are both hoses connected to it, and is the black wiring plug connected? Have any close ups of that area?
Joined: Feb 2003
Posts: 165
Deseck
Member
Deseck Oct 30, 12:32am - #312280 

Member
2002 Toyota Celica GT

Joined: Feb 2003
Posts: 165
San Antonio, TX
^^^ jus the man i was waitin for.


but my CAI doesnt look like that one up there...i think the dumbasses at the shop put it on wrong. angry i'll get a pic up soon.

"I ride big body Benz, Gucci shade lens/
Me an all my friends got the platinum diamond grin/
Everything Im in spin, on 20" Larenz/
Lay back on buckskin, wit my braids in the wind."
Joined: Jan 2004
Posts: 744
Blue_Bomber
Senior Member
Blue_Bomber Oct 30, 1:06am - #312281 
2000 Spectra Blue Mica Toyota Celica
Senior Member
2000 Toyota Celica

Joined: Jan 2004
Posts: 744
Freehold, NJ
Uh oh, never trust shops. thumbsdown Take lots of pics, like wide shots and closeups of all the sensors and hoses and where they're attached to. Also, take a pick of the front right side of the Intake manifold.
Joined: Sep 2004
Posts: 60
Toyotapartsdude
Member
Toyotapartsdude Oct 30, 1:38am - #312282 
2002 black Toyota Celica
Member
2002 Toyota Celica

Joined: Sep 2004
Posts: 60
Ann Arbor, Mi
those codes are evap codes like they said , all you can do is check all of your connections , it happens to everyone , thier not serious codes, but it sounds like one of those could be the charcoal canister , or a bad vacuum switching valve
3/36 covers those but... ill ask our master tech on monday what they are for sure, he'll tell me what they'd replace to fix it. (if it requires such)
Joined: Jan 2004
Posts: 744
Blue_Bomber
Senior Member
Blue_Bomber Oct 30, 4:25am - #312283 
2000 Spectra Blue Mica Toyota Celica
Senior Member
2000 Toyota Celica

Joined: Jan 2004
Posts: 744
Freehold, NJ
Your problem is either with the vacuum switching valves (red), or their associated hoses (blue):
1953302750-AEM EVAP.jpg
Joined: Feb 2003
Posts: 165
Deseck
Member
Deseck Oct 30, 2:07pm - #312284 

Member
2002 Toyota Celica GT

Joined: Feb 2003
Posts: 165
San Antonio, TX
another lil tidbit of info...

my friend an i were bullshitting around with our exhausts an were reving them...then he noticed faint white smoke comin from my pipe. angry could this also be a result in misinstallation of the CAI?

"I ride big body Benz, Gucci shade lens/
Me an all my friends got the platinum diamond grin/
Everything Im in spin, on 20" Larenz/
Lay back on buckskin, wit my braids in the wind."
Joined: Jan 2004
Posts: 744
Blue_Bomber
Senior Member
Blue_Bomber Oct 30, 6:46pm - #312285 
2000 Spectra Blue Mica Toyota Celica
Senior Member
2000 Toyota Celica

Joined: Jan 2004
Posts: 744
Freehold, NJ
Sounds more like a coolant leak. White smoke = coolant, blue smoke = oil.
Join the conversation - Register now or Sign in to add your comment


Moderated by  isaac 

Customize Your Toyota CelicaPrivacy Policy · About · Contact
CelicaHobby.com is an independent Toyota Celica enthusiast website. CelicaHobby.com is not sponsored by or affiliated with Toyota Motor Sales, USA, Inc. in any way. The Toyota and Celica names and logos are trademarks owned by Toyota Motor Sales, USA, Inc.
© CelicaHobby.com, 2001-2016