Previous Thread
Next Thread
New Reply
Print Thread
Joined: Sep 2003
Posts: 6
vipertech
New Member
vipertech

New Member
2003 Toyota Celica GT

Joined: Sep 2003
Posts: 6
Colorado
Oct 20, 7:32pm - #305401 
problems with reverse indiglo gauge overlay

has anyone had a problem with the AC gauge overlay? i installed mine 6 months ago without problems; now it doesn't work at all. I have checked the grounding point, the splice to the auto-lights, and the switch (there weren't any broken wires either). Anyone have similar problems or tips?

Joined: Feb 2004
Posts: 965
morris
BerraquĆ­sima!
morris
2000 White Toyota Celica GT
BerraquĆ­sima!
2000 Toyota Celica GT

Joined: Feb 2004
Posts: 965
Orange County, CA
Oct 20, 7:44pm - #305402 
I installed mine 7 months ago. In all this time they failed twice... I don't know why... Linked Image I didn't check anything... next day, they were working normally again. grin I guess fullmoon or just luck. rofl

Joined: Jun 2002
Posts: 820
GOLDCELICA
Senior Member
GOLDCELICA

Senior Member

Joined: Jun 2002
Posts: 820
San Diego
Oct 21, 1:29am - #305403 
Take it all off and directly test it without a fuse on the battery. If nothing glows. Probably the gauge face is done with. Sometimes it has something to do with the electrical box unit that allows it to glow listen if it makes any noise. Mine makes a slight buzzing sound when electric flows through it. If you can't hear nothing then it's shot.


Originate, Innovate, Never Imitate. Since 2000-04.
Joined: Jan 2003
Posts: 1,577
Stephen
Specialist
Stephen
2003 Silver Toyota Celica GT
Specialist
2003 Toyota Celica GT

Joined: Jan 2003
Posts: 1,577
Oct 21, 1:37am - #305404 
^ What he said. I don't think it's a very common problem either but I have heard some stories. I've had mine running since I installed them over a year ago and no problems. Now i've got S7s on the way too thumbsup

Hope you can figure something out.

Joined: Sep 2003
Posts: 6
vipertech
New Member
vipertech

New Member
2003 Toyota Celica GT

Joined: Sep 2003
Posts: 6
Colorado
Oct 21, 10:35am - #305405 
Thanks everybody! wave

Joined: May 2003
Posts: 5,346
spaztikid
dikitzaps
spaztikid
dikitzaps
1974 Toyota Celica

Joined: May 2003
Posts: 5,346
LA
Oct 21, 11:41am - #305406 
sometimes those black boxes burn out...

Joined: Sep 2003
Posts: 88
tai_mai_shu
Member
tai_mai_shu

Member
2002 Toyota Celica GT

Joined: Sep 2003
Posts: 88
Cen+Cal "L-TOWN" (Lemoore)
Oct 21, 12:24pm - #305407 
I got mine about 3-4 weeks ago and had similiar problems. then i got them professionally intstalled and it worked and its been working good ever since.


Lets play that game called I'll light you on fire and I'll piss on you to put you out
AzN PrIdE
Join the conversation - Register Now or Log In to add your comment


Moderated by  isaac 

Member Spotlight
OBi3
OBi3
2002 Toyota Celica
Calgary, AB, Canada

Posts: 335
Joined: February 2004
Show All Member Profiles 
Shout Box
Recent Topics
White plug in next to hood release
by Celli4Life. 05/26/2017 7:32 PM
02' Celica GT pictures - New member
by Daweed. 05/21/2017 3:34 PM
Engine Developed Slight Tapping Noise
by ciaranleeman. 05/17/2017 12:49 AM
Apexi N1 exhaust
by Felix0697. 05/15/2017 4:58 PM
Toyota celica GT 2004 - 6 gears?
by Arve2afm. 05/13/2017 5:33 AM
FS: Custom OEM Tsunami Badge
by 00BlkCeli. 05/08/2017 11:11 AM
Looking for parts sources
by Calparts. 05/05/2017 11:18 PM
2004 GTS my 6th gear going to neutral by itself
by CapistranCelica. 05/05/2017 3:16 AM
Customize Your Toyota Celica Privacy Policy · About · Contact
Privacy Policy · About · Contact
CelicaHobby.com is an independent Toyota Celica enthusiast website. CelicaHobby.com is not sponsored by or affiliated with Toyota Motor Sales, USA, Inc. in any way. The Toyota and Celica names and logos are trademarks owned by Toyota Motor Sales, USA, Inc.
© CelicaHobby.com, 2001-2017
Powered by UBB.threads™ PHP Forum Software 7.6.1
(Snapshot build 20170512)