Previous Thread
Next Thread
New Reply
Print Thread
Joined: Aug 2004
Posts: 283
injencelicagts
Member
injencelicagts Sep 28, 9:34pm - #286643 

Member
2000 Toyota Celica

Joined: Aug 2004
Posts: 283
new jersey
stalling spudring

ive been wondring y every time i get gas my car starts spudring and then staling after i start it after i get gas confused
Joined: Jul 2004
Posts: 777
ExNihilo
Cold Warrior
ExNihilo Sep 28, 10:11pm - #286644 
Cold Warrior
2004 Toyota Celica GTS

Joined: Jul 2004
Posts: 777
Tempe, AZ
So, after a while the stalling/sputtering goes away and it runs OK?

300,000 KM/Sec. Its not just a good idea, its the law.
Joined: Aug 2004
Posts: 283
injencelicagts
Member
injencelicagts Sep 28, 11:59pm - #286645 

Member
2000 Toyota Celica

Joined: Aug 2004
Posts: 283
new jersey
yupp
Joined: Jul 2004
Posts: 777
ExNihilo
Cold Warrior
ExNihilo Sep 29, 12:59am - #286646 
Cold Warrior
2004 Toyota Celica GTS

Joined: Jul 2004
Posts: 777
Tempe, AZ
Possibilities that come to mind:

1) Are you fueling up with premium (at least 91 octane) fuel?

2) It may have something to do with back pressure, or lack of it, in the tank (i.e. more when its emptier?)? (Gas cap problem?)

3) Water in the gas, settles to the bottom, then gets pumped out first? Do you always refuel at the same station? If so, try a different station. Also, try running some fuel injector cleaner or moisture remover through the gas tank.

Anyone else have some ideas?

300,000 KM/Sec. Its not just a good idea, its the law.
Joined: May 2004
Posts: 528
renfield90
Senior Member
renfield90 Sep 29, 1:12am - #286647 

Senior Member
2001 Toyota Celica GT

Joined: May 2004
Posts: 528
Tempe, AZ
Wow, I had a similar problem about a half hour ago.

I was slowing down at a red light, and my car was shaking like crazy. I thought it was the road, because it didn't look too good, but then I came to a full stop and the car kept shaking. I look at my tach, and it's jumping like crazy between 500-700, and even dips below 500 at one point. I swear I thought my car would stall and die (I drive an auto btw). When the light was green I stepped on the gas, and it smoothened out a bit (maybe it was just me or the road, but I think the car was still shaking a bit at 2000 RPMs). It didn't happen again.

Check your Air Filter, if it's really clogged it could be choking your engine. I checked oil and tranny fluid and they were good. Maybe I should run some fuel injector cleaner...I honestly have no clue though about why this happened.
Joined: May 2004
Posts: 528
renfield90
Senior Member
renfield90 Sep 29, 1:35am - #286648 

Senior Member
2001 Toyota Celica GT

Joined: May 2004
Posts: 528
Tempe, AZ
can anyone help?
Joined: Jul 2004
Posts: 777
ExNihilo
Cold Warrior
ExNihilo Sep 29, 2:26am - #286649 
Cold Warrior
2004 Toyota Celica GTS

Joined: Jul 2004
Posts: 777
Tempe, AZ
Hey renfield, you know we had a weather system come through the valley today (I actually live in Tempe, too)? Who knows, maybe it was the ECU just adjusting to the higher humidity and change in air pressure. I've seen that happen on other cars

300,000 KM/Sec. Its not just a good idea, its the law.
Joined: May 2004
Posts: 528
renfield90
Senior Member
renfield90 Sep 29, 5:16am - #286650 

Senior Member
2001 Toyota Celica GT

Joined: May 2004
Posts: 528
Tempe, AZ
Good point. However, it happened before any of the storms hit, so I don't think it's related. I've driven for about 2 hours tonight, and it hasn't happened again, so who know idunno

On a side note, I was at my parents house, and they got two storms. Dust storm, rain, then dust storm just as the rain was drying, and the rain came too little and too late to wash it off angry
Joined: Aug 2004
Posts: 283
injencelicagts
Member
injencelicagts Sep 29, 5:46am - #286651 

Member
2000 Toyota Celica

Joined: Aug 2004
Posts: 283
new jersey
ok its only when i get gas it proly has somethin ta do with my CAI and yes i do fill with surper 93 or at snoco with 94 my Air Filter is cleaned ever other oil change wich i run mobil 1 and k&n Oil Filter mafs is cleaned every oil change but still it stalls as soon as i drive away from the pump then i start it back up and rev it a lil then go then wen i stop its fine maby its somethin to do with the fule system idk ill call toyota thumbsdown
Joined: May 2004
Posts: 2,979
RookieGTS
Boobie Vision
RookieGTS Sep 29, 5:54am - #286652 

Boobie Vision
2000 Toyota Celica

Joined: May 2004
Posts: 2,979
925 Nor Cal
do you run fuel injector cleaner every oil change too? Because i know i do every oil change
Joined: May 2004
Posts: 528
renfield90
Senior Member
renfield90 Sep 29, 5:55am - #286653 

Senior Member
2001 Toyota Celica GT

Joined: May 2004
Posts: 528
Tempe, AZ
^^ Anyone recommend a specific brand?
Joined: Jul 2004
Posts: 9
00Steben
New Member
00Steben Sep 29, 10:41pm - #286654 
2002 Carbon Fiber Blue Toyota Celica GT
New Member
2002 Toyota Celica GT

Joined: Jul 2004
Posts: 9
CT., US
that happened to me right after i bought my car. toyota looked at it a few times and said "theres nothing we can do until the computer gives us a code" then... the outboard on my computer went. i got a new computer under warrenty.
Joined: May 2002
Posts: 3,295
Steven
ECelica Staff
Steven Sep 29, 11:33pm - #286655 
2001 Spectra Blue Mica Toyota Celica GTS
ECelica Staff
2001 Toyota Celica GTS

Joined: May 2002
Posts: 3,295
Riverside, CA
clean your mass air flow sensor!!!
Joined: May 2004
Posts: 528
renfield90
Senior Member
renfield90 Sep 29, 11:49pm - #286656 

Senior Member
2001 Toyota Celica GT

Joined: May 2004
Posts: 528
Tempe, AZ
^^ I considered that. I pulled it out but it looked pretty clean...worth a shot I guess. The thing is, this only happened once, it's not like a constant problem, so I'm not to sure its the MAFS.

EDIT: And if I clean the MAFS...Q-tips on the MAF wires or just spray? I never really understood that...
Joined: May 2002
Posts: 3,295
Steven
ECelica Staff
Steven Sep 29, 11:50pm - #286657 
2001 Spectra Blue Mica Toyota Celica GTS
ECelica Staff
2001 Toyota Celica GTS

Joined: May 2002
Posts: 3,295
Riverside, CA
trust me it's the mass air flow sensor, clean it, reset your ecu and it will go away
Joined: May 2004
Posts: 528
renfield90
Senior Member
renfield90 Sep 30, 12:41am - #286658 

Senior Member
2001 Toyota Celica GT

Joined: May 2004
Posts: 528
Tempe, AZ
I know the instructions say Q-tips on the temperature probe, but it doesn't specify for the MAF wires...should I just spray them or should I swab them w/a Q-tip?
Joined: Aug 2004
Posts: 283
injencelicagts
Member
injencelicagts Sep 30, 4:04am - #286659 

Member
2000 Toyota Celica

Joined: Aug 2004
Posts: 283
new jersey
my mafs is clean and i have a new computer in it
Joined: May 2004
Posts: 528
renfield90
Senior Member
renfield90 Sep 30, 4:28am - #286660 

Senior Member
2001 Toyota Celica GT

Joined: May 2004
Posts: 528
Tempe, AZ
ok, cleaned MAFS (you were right Steven - I did a before/after and they were really dirty) and I let them dry out then plugged everything in, reconnected my battery. When I put the key in and turned it to on (didn't start the car) I heard a buzzing noise coming from the engine bay. I turned it off and it went away and never came back...is this normal?

Somewhat unrelated (i'm doing a search, will start a new thread if I don't find anything) I get back from a short drive to make sure everything is working, and my tranny starts squealing as i'm pulling in. It didn't squeal in neutral or reverse, only drive. Any clue what's going on? Could my recent problems be part of a larger tranny issue?
Joined: May 2004
Posts: 528
renfield90
Senior Member
renfield90 Oct 18, 11:10pm - #286661 

Senior Member
2001 Toyota Celica GT

Joined: May 2004
Posts: 528
Tempe, AZ
Ok, I know I'm bringing this back from the dead, but it happened again - as I pulled into my driveway, the revs dropped to 500 and the car was threatening to die. As you can see above I cleaned my MAFS recently so that isn't the problem. Oddly enough, the weather has changed today almost the same way as it did the last time.

Otherwise, my car was running great today, probably better than normal. My acceleration on a flat freeway onramp was better than what it normally is on an onramp with a slight decline...my gas pedal felt like it had a little less resistance today. I've also had a continuing problem (this may be unrelated) of hearing rapid clicking noises while driving around. I've removed every last rock from my tires and I still hear it.

What next? Clean the throttle body? Fuel injector cleaner? Could this be a larger problem? Or is it just weather? (Keep in mind that my car has been through more dramatic weather shifts than this with no problem). Anyone have a clue?
Joined: Jan 2004
Posts: 744
Blue_Bomber
Senior Member
Blue_Bomber Oct 19, 12:37am - #286662 
2000 Spectra Blue Mica Toyota Celica
Senior Member
2000 Toyota Celica

Joined: Jan 2004
Posts: 744
Freehold, NJ
Sounds like it might be a problem with your EvAP system, possibly the charcoal canister. What year Celica do you have? There's a recall for the 02s, I believe, since the check valve for the gas tank can break off, and cause similar symptoms, also including the tank overflowing at the gas station.
Joined: May 2004
Posts: 528
renfield90
Senior Member
renfield90 Oct 19, 12:47am - #286663 

Senior Member
2001 Toyota Celica GT

Joined: May 2004
Posts: 528
Tempe, AZ
I have a 2001 GT.
Joined: May 2004
Posts: 528
renfield90
Senior Member
renfield90 Oct 20, 3:38am - #286664 

Senior Member
2001 Toyota Celica GT

Joined: May 2004
Posts: 528
Tempe, AZ
I'm going to take it to my mechanic, and he'll just inspect anything he can think of...but is there any maintenance I should do to help this?

It happened almost at every stop today, idling under 600, not as bad as before but definitely more frequent. It's not weather because I drove in colder temps in Cali over the summer (at night).

Does anyone know the idling level of an auto GT (warm) in Neutral and Drive, so I can compare?
Joined: May 2004
Posts: 528
renfield90
Senior Member
renfield90 Oct 21, 10:07pm - #286665 

Senior Member
2001 Toyota Celica GT

Joined: May 2004
Posts: 528
Tempe, AZ
bump

can anyone at least answer my last question?
Joined: May 2004
Posts: 2,979
RookieGTS
Boobie Vision
RookieGTS Oct 21, 10:46pm - #286666 

Boobie Vision
2000 Toyota Celica

Joined: May 2004
Posts: 2,979
925 Nor Cal
nope sorry.. i have a manuel GTS
Join the conversation - Register now or Sign in to add your comment


Moderated by  isaac 

Customize Your Toyota CelicaPrivacy Policy · About · Contact
CelicaHobby.com is an independent Toyota Celica enthusiast website. CelicaHobby.com is not sponsored by or affiliated with Toyota Motor Sales, USA, Inc. in any way. The Toyota and Celica names and logos are trademarks owned by Toyota Motor Sales, USA, Inc.
© CelicaHobby.com, 2001-2016