Previous Thread
Next Thread
New Reply
Print Thread
Joined: Aug 2004
Posts: 3
erics1one
New Member
erics1one Aug 27, 9:32pm - #261192 
1996 Silver Toyota Celica GT
New Member
1996 Toyota Celica GT

Joined: Aug 2004
Posts: 3
Arizona
My Acceleration Problem, Think it might be Air/Fuel mixture

'96 Celcia

5SFE - CT-26 Turbo with HKS Turbo Timer and HKS Super AFR Air/Fuel management system.

Other than Weak Idle my car...

Stuters, shunts, floods itself, etc. typically in low gears, at low RPMs. If I keep RPMs between 3k-4k I can normally pop it out of First and Second gear. If I let it down to low RPMs while getting outta first and second gear, it almost seems as its gonna stall itself, but never has, just a violent back and forth chug untill I rev upto high RPM (if it does come out...sometimes I'll have the clutch all the way in with the gas DOWN for 10-15sec and no change...just chug chug chug).

At first I thought it might be a vacuum issues, and replaced the MAP sensor, and checked out vacuum lines. Problem still exsists.

The reason I think its a Air/Fuel mixture problem, is because I followed this guide:
http://www.6gc.net/index.php?action=howto&itu=33

After resetting my computer's Air/Fuel mixture IT RUNS PERFECTLY FINE, for about 12-18 hours. And then goes back to its origional problem.

Does this limit my problems to tuning my HKS AFR on a Dyno? It was installed in California, and I live in Arizona, so I know I should get it tuned anyway. But should that controller alone cause such a bad problem?

Any help would be appricated.

TIA.
Joined: Aug 2004
Posts: 3
erics1one
New Member
erics1one Aug 30, 8:34pm - #261193 
1996 Silver Toyota Celica GT
New Member
1996 Toyota Celica GT

Joined: Aug 2004
Posts: 3
Arizona
Was suggested that this might be a problem with my O2 sensor. I'll be replaceing that shortly, but was wondering if anyone though it might also be my Knock Sensor.

TIA
Joined: Aug 2004
Posts: 3
erics1one
New Member
erics1one Aug 31, 7:19pm - #261194 
1996 Silver Toyota Celica GT
New Member
1996 Toyota Celica GT

Joined: Aug 2004
Posts: 3
Arizona
Update:

My car...

-Smokes when I'm NOT ACCELERATING
-Gets 200 miles a tank
-Just recently the "Check engine light" went off...it has been on since I bought the car, but yesterday when I reset the ECU & EFI fuses the gas was probably 1/8 - 1/4 full and the light went off. When I refilled the gas, the Check engine light came back on.

Kinda wierd...but wanted to see if this info would help gettin any more input. My O2 sensor will show up tomorrow and I'm hoping thats the only problem.

Thanks.
Joined: Jul 2004
Posts: 2,016
Haulin_A_Doo
Specialist
Haulin_A_Doo Aug 31, 7:27pm - #261195 
Specialist

Joined: Jul 2004
Posts: 2,016
Ontario
Yah, probably the 02 thumbsup
Join the conversation - Register now or Sign in to add your comment


Moderated by  isaac 

Customize Your Toyota CelicaPrivacy Policy · About · Contact
CelicaHobby.com is an independent Toyota Celica enthusiast website. CelicaHobby.com is not sponsored by or affiliated with Toyota Motor Sales, USA, Inc. in any way. The Toyota and Celica names and logos are trademarks owned by Toyota Motor Sales, USA, Inc.
© CelicaHobby.com, 2001-2016