Previous Thread
Next Thread
New Reply
Print Thread
Joined: Aug 2004
Posts: 3
erics1one
New Member
erics1one
1996 Silver Toyota Celica GT
New Member
1996 Toyota Celica GT

Joined: Aug 2004
Posts: 3
Arizona
Aug 27, 2:32pm - #261192 
My Acceleration Problem, Think it might be Air/Fuel mixture

'96 Celcia

5SFE - CT-26 Turbo with HKS Turbo Timer and HKS Super AFR Air/Fuel management system.

Other than Weak Idle my car...

Stuters, shunts, floods itself, etc. typically in low gears, at low RPMs. If I keep RPMs between 3k-4k I can normally pop it out of First and Second gear. If I let it down to low RPMs while getting outta first and second gear, it almost seems as its gonna stall itself, but never has, just a violent back and forth chug untill I rev upto high RPM (if it does come out...sometimes I'll have the clutch all the way in with the gas DOWN for 10-15sec and no change...just chug chug chug).

At first I thought it might be a vacuum issues, and replaced the MAP sensor, and checked out vacuum lines. Problem still exsists.

The reason I think its a Air/Fuel mixture problem, is because I followed this guide:
http://www.6gc.net/index.php?action=howto&itu=33

After resetting my computer's Air/Fuel mixture IT RUNS PERFECTLY FINE, for about 12-18 hours. And then goes back to its origional problem.

Does this limit my problems to tuning my HKS AFR on a Dyno? It was installed in California, and I live in Arizona, so I know I should get it tuned anyway. But should that controller alone cause such a bad problem?

Any help would be appricated.

TIA.

Joined: Aug 2004
Posts: 3
erics1one
New Member
erics1one
1996 Silver Toyota Celica GT
New Member
1996 Toyota Celica GT

Joined: Aug 2004
Posts: 3
Arizona
Aug 30, 1:34pm - #261193 
Was suggested that this might be a problem with my O2 sensor. I'll be replaceing that shortly, but was wondering if anyone though it might also be my Knock Sensor.

TIA

Joined: Aug 2004
Posts: 3
erics1one
New Member
erics1one
1996 Silver Toyota Celica GT
New Member
1996 Toyota Celica GT

Joined: Aug 2004
Posts: 3
Arizona
Aug 31, 12:19pm - #261194 
Update:

My car...

-Smokes when I'm NOT ACCELERATING
-Gets 200 miles a tank
-Just recently the "Check engine light" went off...it has been on since I bought the car, but yesterday when I reset the ECU & EFI fuses the gas was probably 1/8 - 1/4 full and the light went off. When I refilled the gas, the Check engine light came back on.

Kinda wierd...but wanted to see if this info would help gettin any more input. My O2 sensor will show up tomorrow and I'm hoping thats the only problem.

Thanks.

Joined: Jul 2004
Posts: 2,016
Haulin_A_Doo
Specialist
Haulin_A_Doo
Specialist

Joined: Jul 2004
Posts: 2,016
Ontario
Aug 31, 12:27pm - #261195 
Yah, probably the 02 thumbsup

Join the conversation - Register Now or Log In to add your comment


Moderated by  isaac 

Member Spotlight
Glove
Glove
2005 Toyota Camry SE
Delaware, U.S.

Posts: 102
Joined: June 2004
Thanks: Ziptied.com & Gripvideo.com // CHECK THESE GUYS OUT!!
Show All Member Profiles 
Recent Topics
FS: 2001 GTS
by Skip. 07/21/2017 11:25 AM
Water in footwell of rear passenger seat
by ciaranleeman. 07/21/2017 1:24 AM
A/C doesn't work, water leak
by Zaon_Prime. 07/20/2017 1:06 PM
2000 Celica GT instrument lights go out
by Herby. 07/19/2017 1:49 PM
Need some guidance to buying a celica!
by Hanate. 07/17/2017 4:23 PM
4th Gen owners...
by Cherry88Celica. 07/15/2017 1:04 AM
Can someone please help
by 96celicast. 07/13/2017 1:54 PM
Stock Stereo Volume Knob Removal???
by Katherine. 07/13/2017 8:35 AM
Customize Your Toyota Celica Privacy Policy · About · Contact
Privacy Policy · About · Contact
CelicaHobby.com is an independent Toyota Celica enthusiast website. CelicaHobby.com is not sponsored by or affiliated with Toyota Motor Sales, USA, Inc. in any way. The Toyota and Celica names and logos are trademarks owned by Toyota Motor Sales, USA, Inc.
© CelicaHobby.com, 2001-2017
Powered by UBB.threads™ PHP Forum Software 7.6.1
(Snapshot build 20170611)