Previous Thread
Next Thread
New Reply
Print Thread
Joined: Apr 2004
Posts: 433
ArumnDark
Senior Member
ArumnDark Aug 23, 5:10am - #256914 
2004 Silver Streak Toyota Celica
Senior Member
2004 Toyota Celica

Joined: Apr 2004
Posts: 433
Independence, California
2004 Celica AEM CAI CEL... Fixed?

I was playing around with the hoses, since my CEL had been coming on after putting the Intake in.

Anyways, I think the instructions for 2000-2003 may tell you to cap the wrong thing (when installing on a 2004 model)! Ok, let's see if I can convey this:
1870191064-Engine Bay copy.jpg
Joined: Apr 2004
Posts: 433
ArumnDark
Senior Member
ArumnDark Aug 23, 5:13am - #256915 
2004 Silver Streak Toyota Celica
Senior Member
2004 Toyota Celica

Joined: Apr 2004
Posts: 433
Independence, California
Ok, click the picture to get it to full-sized if you can't see what I'm saying there.

I set it up like this, re-set the ECU, and have driven nearly 1,000 miles (been about 3-4 days since I did this), and so far the CEL has not come back (it was coming back in about 24 hours before).
I haven't noticed any ill-effects, and it performs just as well as it always did!

I'll be taking my car in for some horn-work on Friday, I'll ask the guy to check this out as well and see if it will cause any damage (I doubt it will, since mine has been working perfectly, but I should double-check for safety smile ).


Hope this helps someone!

[Linked Image]
Joined: Sep 2002
Posts: 3,030
Erick
Bread Fishing..
Erick Aug 23, 6:23am - #256916 

Bread Fishing..
2001 Toyota Celica GT

Joined: Sep 2002
Posts: 3,030
Bay Area, CA
horn work confused you going to be putting in a new horn.. an air horn perhaps thumbsup

hmm i capped the part you uncapped although i do have an '01 gt idunnoalso i cleaned the mafs sensor and that fixed things on mine...

LNK
"you only need something when you know it exists..then it becomes a want"
Joined: Apr 2004
Posts: 433
ArumnDark
Senior Member
ArumnDark Aug 23, 7:50am - #256917 
2004 Silver Streak Toyota Celica
Senior Member
2004 Toyota Celica

Joined: Apr 2004
Posts: 433
Independence, California
I think the wiring or relays or something are messed up, concerning the horn smile But, I wouldn't mind a big ass fog horn on something tongue

But yeah, the instructions say to cap it, but they also say that they are for 2000-2003 Celicas, so... idunno

I've also cleaned the sensors, but the CEL kept coming on, complaining about a vacuum valve being stuck closed.


Out of curiousity, do the 01's (or any 2003- for that matter) have the T connector thing? (pointed to in green on the picture above.)

[Linked Image]

**DONOTDELETE**
Unregistered
Anonymous Aug 23, 9:04pm - #256918 
Unregistered



This looks like the correct solution for 2004 GTSs... after trying this workaround, the CEL has NOT come on (and it's been a few days), whereas it would come on after about 24hrs previously (and I had tried everything recommended up to that point).

Good job guys, and thanks for sharing the solution.
Joined: Aug 2003
Posts: 153
GjGts
Member
GjGts Aug 24, 3:38am - #256919 

Member
2004 Toyota Celica

Joined: Aug 2003
Posts: 153
San Bernardino
you are totally right thats the way i have my 04 setup and no cel yet, actually no i take that back i had one for like an hour from my drive to vegas to cali, temperature was my only idea of what caused it, we went from 119 degrees to 80 degrees but nothing since then
Join the conversation - Register now or Sign in to add your comment


Moderated by  isaac 

Customize Your Toyota CelicaPrivacy Policy · About · Contact
CelicaHobby.com is an independent Toyota Celica enthusiast website. CelicaHobby.com is not sponsored by or affiliated with Toyota Motor Sales, USA, Inc. in any way. The Toyota and Celica names and logos are trademarks owned by Toyota Motor Sales, USA, Inc.
© CelicaHobby.com, 2001-2016