Previous Thread
Next Thread
New Reply
Print Thread
Joined: Apr 2004
Posts: 433
ArumnDark
Senior Member
ArumnDark Aug 13, 5:59am - #247988 
2004 Silver Streak Toyota Celica
Senior Member
2004 Toyota Celica

Joined: Apr 2004
Posts: 433
Independence, California
AEM CAI CEL... Again ;)

Ok, had my AEM CAI installed, everything runs great and all, but after a week or so, I got a CEL. So I reset the ECU, it went away for about a day.. then came back. And it's been repeating this tongue

So, I took it to the dealer and had them read the code... "Secondary Air Injection System Valve Stuck Closed Bank 1."

That's the hose that is eliminated when installing the CAI, right?

Any idea how to get the computer to ignore that part of the system? (I have the connection for the hose capped off, as per the instructions, and the hose itself is plugged as well (light came on with or without the hose plugged.))


It doesn't really hurt anything, car runs great, but that light is annoying!! So, how do I get rid of it, short of just sticking tape over it? tongue
Joined: Sep 2003
Posts: 3,077
slidr
Specialist
slidr Aug 13, 6:04am - #247989 

Specialist
2000 Toyota Celica

Joined: Sep 2003
Posts: 3,077
Saint Louis, MO
What did you plug the hole with?

Are you sure that the seal is tight?

Aqua Teen Hunger Force...number one in the hood, G
Joined: Apr 2004
Posts: 433
ArumnDark
Senior Member
ArumnDark Aug 13, 6:09am - #247990 
2004 Silver Streak Toyota Celica
Senior Member
2004 Toyota Celica

Joined: Apr 2004
Posts: 433
Independence, California
It's plugged with a screw.

And I'm guessing it's tight, the screw was just slightly larger than the opening (enough for a seal, but not enough to damage the hose).

[Linked Image]
Joined: Jan 2004
Posts: 5,129
Sultan
Speed Omen
Sultan Aug 13, 8:48am - #247991 

Speed Omen
2002 Toyota Celica GT

Joined: Jan 2004
Posts: 5,129
Philadelphia, PA
idunno- get a TPR
Joined: Apr 2004
Posts: 433
ArumnDark
Senior Member
ArumnDark Aug 13, 7:17pm - #247992 
2004 Silver Streak Toyota Celica
Senior Member
2004 Toyota Celica

Joined: Apr 2004
Posts: 433
Independence, California
If I had the money... maybe wink

[Linked Image]
Joined: Jan 2004
Posts: 2,373
AZZKIKR
SHO - NUFF
AZZKIKR Aug 13, 7:25pm - #247993 

SHO - NUFF
2003 Toyota Celica GT

Joined: Jan 2004
Posts: 2,373
ATL GA
get used to it
Joined: Aug 2003
Posts: 1,292
CaLiGTS
Phantom
CaLiGTS Aug 13, 7:26pm - #247994 

Phantom
2001 Toyota Celica

Joined: Aug 2003
Posts: 1,292
Bay Area, NorCal
spineyes

[Linked Image]
Ask yourself one question. Is the juice worth the squeeze?
Joined: Apr 2004
Posts: 123
Workshop4Ever
Member
Workshop4Ever Aug 13, 8:31pm - #247995 

Member
2000 Toyota Celica

Joined: Apr 2004
Posts: 123
Midland Park, New Jersey
find something bigger to cap the hose...it has to be completely sealed or you will get the CEL

Always remember....The Early Bird May Get The Worm, But The Second Mouse Gets The Cheese!
Joined: Oct 2003
Posts: 1,154
Larry_GTS
Specialist
Larry_GTS Aug 14, 1:55pm - #247996 
2003 Yellow/Red Toyota Celica
Specialist
2003 Toyota Celica

Joined: Oct 2003
Posts: 1,154
Texas
make sure the cap is sealed. go to Advanced Auto Parts they work god.
Joined: Jun 2003
Posts: 375
sho
Member
sho Aug 14, 5:33pm - #247997 

Member
2003 Toyota Celica

Joined: Jun 2003
Posts: 375
so cal
im having the same problem..can someone post pic of that hose ur talking about>?

[Linked Image]
Joined: Jun 2003
Posts: 375
sho
Member
sho Aug 14, 6:12pm - #247998 

Member
2003 Toyota Celica

Joined: Jun 2003
Posts: 375
so cal
is it bcuz my Intakes for 2000 n my car is 2003>???

[Linked Image]
Joined: Aug 2004
Posts: 45
Mike2000gt
Member
Mike2000gt Aug 14, 8:26pm - #247999 
2000 Red Toyota Celica GT
Member
2000 Toyota Celica GT

Joined: Aug 2004
Posts: 45
Ohio
Not sure. I installed the same CAI on my Celica and had no problem at all. Did you make sure that you didn't connect the wire with the blue clip to anything. That one is supposed to be left out once the CAI is installed. What year by the way...I did it on a 2000.
Joined: Aug 2003
Posts: 2,873
cycocelica
daman
cycocelica Aug 14, 8:31pm - #248000 

daman
2000 Toyota Celica GT

Joined: Aug 2003
Posts: 2,873
Washington
Originally Posted by Sultan
idunno- get a TPR
Joined: Jun 2003
Posts: 375
sho
Member
sho Aug 14, 8:36pm - #248001 

Member
2003 Toyota Celica

Joined: Jun 2003
Posts: 375
so cal
Originally Posted by Mike2000gt
Not sure. I installed the same CAI on my Celica and had no problem at all. Did you make sure that you didn't connect the wire with the blue clip to anything. That one is supposed to be left out once the CAI is installed. What year by the way...I did it on a 2000.
i left that wire with blue clip alone,but theres another hose coming out from the engine.what do you do with that one.it seems like it sux in air through that hose.r you suppose to leave it alone so that it can suck in air??

[Linked Image]
Joined: Apr 2004
Posts: 433
ArumnDark
Senior Member
ArumnDark Aug 16, 3:49am - #248002 
2004 Silver Streak Toyota Celica
Senior Member
2004 Toyota Celica

Joined: Apr 2004
Posts: 433
Independence, California
Ok. I went ahead and stuck a bigger screw in there and reset the ECU. I guess I'll know in a few days if it works or not smile

And I have the grey connector plugged in, the blue one left alone, like the instructions said. (I had it done professionally, and inspected it myself afterward)
1870177772-Engine Bay copy.jpg

[Linked Image]

**DONOTDELETE**
Unregistered
Anonymous Aug 19, 2:12pm - #248003 
Unregistered



Same problem on my 04 GTS... any workarounds for this issue? I heard somewhere that since the 2004 GTS is slightly different, the included CAI instructions are incorrect in one step... just not sure what step that is.
Joined: Apr 2004
Posts: 74
Lyth0s
Member
Lyth0s Aug 19, 5:50pm - #248004 
2002 Silver Toyota Celica GT
Member
2002 Toyota Celica GT

Joined: Apr 2004
Posts: 74
Southern California
DONT cap that hose...what you need to do is go to auto zone and buy a "breather filter" (usally in the customaztion section of the store)...keep the hose that is already there and add the breather filter to the end of hose...check engine light will go off and you wont mess up your car by not letting it get air and the air is filtered. Does AEM really tell you to cap it?
Joined: Oct 2003
Posts: 3,038
Clos
Specialist
Clos Aug 19, 5:54pm - #248005 
2000 Spectra Blue Toyota Celica
Specialist
2000 Toyota Celica

Joined: Oct 2003
Posts: 3,038
Alexandria, VA
i had my Intake for like 6 months and i had never had a problem, never got a engine code. i got Injen, but good luck thumbsup and i install it my self,
Joined: Mar 2004
Posts: 647
hector
Senior Member
hector Aug 19, 5:58pm - #248006 

Senior Member
2001 Toyota Celica GT

Joined: Mar 2004
Posts: 647
san bernardino, california
Originally Posted by Lyth0s
DONT cap that hose...what you need to do is go to auto zone and buy a "breather filter" (usally in the customaztion section of the store)...keep the hose that is already there and add the breather filter to the end of hose...check engine light will go off and you wont mess up your car by not letting it get air and the air is filtered. Does aem really tell you to cap it?




DONT DO THIS PEOPLE...everyone i hear says to plug it. i installed my SRI a week ago and i have had the same problem. i installed a breather to that hose and the CEL light came on. i am going to plug it and hopefully that works, because the breather sure as heck didnt
Joined: Apr 2004
Posts: 433
ArumnDark
Senior Member
ArumnDark Aug 19, 8:38pm - #248007 
2004 Silver Streak Toyota Celica
Senior Member
2004 Toyota Celica

Joined: Apr 2004
Posts: 433
Independence, California
Ok, CEL is back on again wink

I wouldn't think capping that hose would do anything harmful. Isn't it the hose that is capped when you remove the butterfly as well? It's not used by the CAI system at all, it's just that the engine computer still thinks it is supposed to be working, hence the CEL.

Which direction does air go? Does the hose suck the air, or is the air sucked from the hose?


I have a 2004, by the way.

[Linked Image]
Joined: Jun 2003
Posts: 375
sho
Member
sho Aug 19, 10:07pm - #248008 

Member
2003 Toyota Celica

Joined: Jun 2003
Posts: 375
so cal
it sux in air.i capped that hose n my cel went away,. thumbsup

[Linked Image]
Joined: Apr 2004
Posts: 433
ArumnDark
Senior Member
ArumnDark Aug 20, 6:15am - #248009 
2004 Silver Streak Toyota Celica
Senior Member
2004 Toyota Celica

Joined: Apr 2004
Posts: 433
Independence, California
Ok, the engine sucks air out of that hose (the part that is pointed to in green does the sucking).

I played around with things for a while and reset the ECU. Will wait another day or two and see if I stumbled across a solution wink

[Linked Image]
Join the conversation - Register now or Sign in to add your comment


Moderated by  isaac 

Customize Your Toyota CelicaPrivacy Policy · About · Contact
CelicaHobby.com is an independent Toyota Celica enthusiast website. CelicaHobby.com is not sponsored by or affiliated with Toyota Motor Sales, USA, Inc. in any way. The Toyota and Celica names and logos are trademarks owned by Toyota Motor Sales, USA, Inc.
© CelicaHobby.com, 2001-2016