Previous Thread
Next Thread
New Reply
Print Thread
Cold Air Intake #23563 Jun 28, 12:37am Jun 28, 12:37am
Joined: Apr 2003
Posts: 802
Calgary, Alberta
shox OP
Senior Member
2003 Toyota Celica GT
shox OP

Senior Member
2003 Toyota Celica GT

Joined: Apr 2003
Posts: 802
Calgary, Alberta
Cold Air Intake
ok, this is starting to bug me...

alrite, i installed Cold Air Intake, and disconnected the battery and all that. the check engine light doesn't come on and after a while it came on. i checked wit my dealership and they juss said it's b/c my cold air is putting too much O2 into the engine and the O2 sensor is going off. well, i stopped worrying about it, and the light has never gone away. i tried disconnecting the batt again but it's still goin out.

so my question is, is there another way to turn that sh*t off or is there really something wrong wit my car? (maybe the possibility of it being a 2003 has something to do with it??)

Re: Cold Air Intake [Re: shox] #23564 Jun 28, 12:49am Jun 28, 12:49am
Joined: May 2002
Posts: 6,007
Los Angeles, CA
2001 Absolutely Red Toyota Celica GT isaac
ECelica Admin
2001 Toyota Celica GT
isaac
2001 Absolutely Red Toyota Celica GT
ECelica Admin
2001 Toyota Celica GT

Joined: May 2002
Posts: 6,007
Los Angeles, CA
Double-check the "nub" (located slightly up and to the left of the dip-stick in this photo)

This is where that hose that was connected to your butterfly use'ta be...

Has it been pluged on your setup?... it should be.

Linked Image


[Linked Image]
It's not just your imagination...
Your day really does go by twice as fast while on EverythingCelica.com
Re: Cold Air Intake [Re: shox] #23565 Jun 28, 6:59pm Jun 28, 6:59pm
Joined: Apr 2003
Posts: 802
Calgary, Alberta
shox OP
Senior Member
2003 Toyota Celica GT
shox OP

Senior Member
2003 Toyota Celica GT

Joined: Apr 2003
Posts: 802
Calgary, Alberta
i checked, all the tubes and plugged into the CAI that were originally connected into the butterfly Intake

Join the conversation - Register Now or Log In to add your comment


Moderated by  isaac 

Member Spotlight
kenny_celi
kenny_celi
1995 Nissan 240SX (s14)
Seattle, WA

Posts: 184
Joined: November 2003
Show All Member Profiles 
Recent Topics
System 10 Speakers not working
by willlcurry. 09/18/2017 3:35 PM
how do u bleed clutch line
by scorpionafw. 09/12/2017 3:20 PM
CELICA GEN 7 WELCOME DOOR LIGHTS
by Jinxy1965. 09/10/2017 1:36 PM
Need advice with buying Celica GT 2005 (t23)
by DarkSorrow. 09/05/2017 10:51 AM
Need advice on my engine.
by Tameah21. 09/05/2017 6:39 AM
Help! Looking to replace all 4 shocks & springs + rear calipers
by Kristofer. 09/03/2017 9:25 PM
Fuel filter replacement
by enee1988. 09/02/2017 7:05 PM
New to Celica
by Tooter. 08/29/2017 5:33 AM
Customize Your Toyota Celica Privacy Policy · About · Contact
Privacy Policy · About · Contact
CelicaHobby.com is an independent Toyota Celica enthusiast website. CelicaHobby.com is not sponsored by or affiliated with Toyota Motor Sales, USA, Inc. in any way. The Toyota and Celica names and logos are trademarks owned by Toyota Motor Sales, USA, Inc.
© CelicaHobby.com, 2001-2017
Powered by UBB.threads™ PHP Forum Software 7.6.1
(Snapshot build 20170912)