Previous Thread
Next Thread
New Reply
Print Thread
Joined: Apr 2004
Posts: 11
gtXtc
Member
gtXtc

Member
2004 Toyota Celica

Joined: Apr 2004
Posts: 11
Seattle, WA
Jun 2, 11:53am - #190480 
Anyone have an 2004 GTS with AEM CAI?

I am just curious because I just installed it on Memorial Day everything was running fine until that night and the CEL came on. Did anyone else have there CEL come on when they installed it on there '04? I tried using the "search" feature but when I typed in "AEM" I get random stuff that doesn't have anything to do with an Intake.
Thanks.

Joined: Apr 2003
Posts: 282
joylover24
Member
joylover24

Member

Joined: Apr 2003
Posts: 282
Buffalo, NY
Jun 2, 12:08pm - #190481 
yep happened to me, east problem to fix. the hose that they give you that runs from the CAI towards the cone of the of the piece that runs up to the CAI higher up on the CAI is too short and gets a bend in it that trips an o2 sensor.
https://www.celicahobby.com/ubbthrea...apsed_2__1.html

it is the first pic and the black hose in the middle of the shot. just buy a longer hose and the problem with go away in about 70 miles


Heaven is 8600 RPM's
Joined: Sep 2004
Posts: 896
celicajonz
Senior Member
celicajonz
Senior Member
2004 Toyota Celica

Joined: Sep 2004
Posts: 896
*562* , CA
Sep 14, 10:48am - #190482 
I GOT AN '04 GTS W/ COLD AIR N DONT HAVE A CEL PROBLEM(KNOCK ON WOOD)...COULD B A LOOSE HOSE


Originally posted by A_Bathing_Ape:
I hit, what else, oh plus dome.
Joined: Apr 2004
Posts: 320
khmer215
Member
khmer215

Member
2004 Toyota Celica GT

Joined: Apr 2004
Posts: 320
Philly
Sep 14, 11:54am - #190483 
i have an 04 GT but i got rid of my CEL by plugging the blue cable what was hanging loose into the MAF sensor. I had the back on in the MAF by accident. it was my fault i was going to fast w/o reading the instructions. other then that check all cables. make sure all of ur tubes are securely tight. then fill up ur tank and ur good to go...


[Linked Image]
Join the conversation - Register Now or Log In to add your comment


Moderated by  isaac 

Member Spotlight
SLVCELI
SLVCELI
2002 Toyota Celica GT
West Chester, Ohio

Posts: 1,304
Joined: February 2003
Show All Member Profiles 
Recent Topics
Electrical Issue
by zenbone. 06/17/2017 12:40 PM
Manifold intake hose
by Celicafannn23. 06/10/2017 12:29 PM
Wheel size
by enjoi94. 06/08/2017 6:33 PM
Replaced Lock Actuator Issues
by geekbits. 06/08/2017 12:06 PM
Engine swap
by Darkgazer666. 06/06/2017 3:50 PM
What brand of wheels are these guys?
by jennmarkov. 06/05/2017 7:24 AM
WTB: Tsunami Rear Bumper
by valkyrie_gt. 06/04/2017 11:31 AM
Water in transmission fluid?
by Afroduck. 06/03/2017 7:41 PM
Customize Your Toyota Celica Privacy Policy · About · Contact
Privacy Policy · About · Contact
CelicaHobby.com is an independent Toyota Celica enthusiast website. CelicaHobby.com is not sponsored by or affiliated with Toyota Motor Sales, USA, Inc. in any way. The Toyota and Celica names and logos are trademarks owned by Toyota Motor Sales, USA, Inc.
© CelicaHobby.com, 2001-2017
Powered by UBB.threads™ PHP Forum Software 7.6.1
(Snapshot build 20170611)