Previous Thread
Next Thread
New Reply
Print Thread
Joined: Sep 2003
Posts: 1,261
rem
Specialist
rem May 24, 4:25pm - #184132 
2000 arrest me red Toyota Celica GT
Specialist
2000 Toyota Celica GT

Joined: Sep 2003
Posts: 1,261
1228 celica blvd
somethin wrong with my car (auto GT)

ok guys.. something weird with my car.

NORMALLY when i gun it with the car.. it would kick in like a sec later and start picking up..


and NOW, when i press the pedal all the way down it sounds like its ready to take off, but then it takes about 3 seconds sometimes 4 to finally register that im trying to make it go.. its really weird.. and my CEL light is on.. i tried resetting battery and all.. and it still does it and the CEL light just comes back on. you think maybe i have to clean the MAF sensor on my Intake? or maybe hoses on my Intake is not on tight enough?.. i have no clue guys.. maybe someone has same problem as me..

help me resolve this issue!! cry
Joined: Apr 2003
Posts: 2,451
DiabloGTS
Wheezy Joe
DiabloGTS May 24, 4:37pm - #184133 

Wheezy Joe
2002 Kawasaki Ninja 250

Joined: Apr 2003
Posts: 2,451
Lafayette, LA
clean the MAF sensor is the first thing.

Also clean your throttle plate, it might be tacky from carbon.

Whens the last time you changed your tranny fluid?

To have played and laughed with enthusiasm
and sung with exultation
To know even one life has breathed easier
This is to have succeeded.
Joined: Sep 2003
Posts: 1,261
rem
Specialist
rem May 24, 4:39pm - #184134 
2000 arrest me red Toyota Celica GT
Specialist
2000 Toyota Celica GT

Joined: Sep 2003
Posts: 1,261
1228 celica blvd
i dont think ive ever changed the tranny fluid.. i let someone check the cars tranny fluid not to long ago they said its ok.. ionno tho lol
Joined: Aug 2003
Posts: 4,278
Virgilson
TheFilipinoCrew
Virgilson May 24, 4:46pm - #184135 

TheFilipinoCrew
2000 Toyota Celica GT

Joined: Aug 2003
Posts: 4,278
Pomona, CA
Get a Tune Up, Replace Spark Plugs thumbsup
Joined: Apr 2004
Posts: 338
Brian63
Member
Brian63 May 24, 6:27pm - #184136 

Member
2000 Toyota Celica

Joined: Apr 2004
Posts: 338
Macomb IL
When I got my car there was the delay but they replaced the MAF and it runs ok now. I cant spin my tires or even make them squeel. oh well
Joined: Jan 2004
Posts: 733
Tru_gts
Senior Member
Tru_gts May 28, 2:04am - #184137 
2002 Black Toyota Celica
Senior Member
2002 Toyota Celica

Joined: Jan 2004
Posts: 733
Frisco
I had that happen several times but i just double pumped the gas pedal and the rev went sky high.

To my girl Truboo
Joined: Oct 2003
Posts: 1,549
JBing
Pizza Geek
JBing May 28, 2:06am - #184138 

Pizza Geek
2002 Toyota Celica GT

Joined: Oct 2003
Posts: 1,549
Detroit
how many miles, 36k or less take it to the dealer... Thats why the have warrantys on em' thumbsup

[Linked Image]
FS: 19" ADR M Sports
Joined: Sep 2003
Posts: 3,077
slidr
Specialist
slidr May 28, 2:18am - #184139 

Specialist
2000 Toyota Celica

Joined: Sep 2003
Posts: 3,077
Saint Louis, MO
Get the CEL code.

Aqua Teen Hunger Force...number one in the hood, G
Joined: Feb 2004
Posts: 965
morris
BerraquĆ­sima!
morris May 28, 6:52am - #184140 
2000 White Toyota Celica GT
BerraquĆ­sima!
2000 Toyota Celica GT

Joined: Feb 2004
Posts: 965
Orange County, CA
Does it happen with O/D on or off??? confused
I'm asking, because the first thing I do to get my car faster is turn off O/D... I only use it after I reach 60 mph., and turn it off when I want to stop quickly, or pass some dumb at the freeway... happywink anyway, you must wait 1 second to get response.

I also think, that it would be a good idea to get a Trans.fluid flush, and check sparkplugs.
thumbsup
Joined: Sep 2003
Posts: 1,261
rem
Specialist
rem Jul 12, 12:27am - #184141 
2000 arrest me red Toyota Celica GT
Specialist
2000 Toyota Celica GT

Joined: Sep 2003
Posts: 1,261
1228 celica blvd
well guys, i dropped my car off at toyota today for them to check out this problem.. i'll keep you guys posted
Joined: Dec 2003
Posts: 245
silverceli21
Member
silverceli21 Jul 12, 2:55am - #184142 

Member
01 Toyota Celica GT

Joined: Dec 2003
Posts: 245
ma
hmmm i would of gotten a stick then you wouldnt have this problem grin

SiLvErCeLi
Joined: Sep 2003
Posts: 1,261
rem
Specialist
rem Jul 13, 5:01am - #184143 
2000 arrest me red Toyota Celica GT
Specialist
2000 Toyota Celica GT

Joined: Sep 2003
Posts: 1,261
1228 celica blvd
they said it was the mass air flow was wrong or something.. o well they said theyd fix it free of charge under my exd. warranty lol yay
Joined: May 2003
Posts: 1,296
bmw52786
Specialist
bmw52786 Jul 13, 5:44am - #184144 

Specialist
2001 Toyota Celica GT

Joined: May 2003
Posts: 1,296
Orlando/Gainesville, FL
Originally Posted by rem
ok guys.. something weird with my car.

NORMALLY when i gun it with the car.. it would kick in like a sec later and start picking up..


and NOW, when i press the pedal all the way down it sounds like its ready to take off, but then it takes about 3 seconds sometimes 4 to finally register that im trying to make it go.. its really weird.. and my CEL light is on.. i tried resetting battery and all.. and it still does it and the CEL light just comes back on. you think maybe i have to clean the MAF sensor on my Intake? or maybe hoses on my Intake is not on tight enough?.. i have no clue guys.. maybe someone has same problem as me..

help me resolve this issue!! cry


same thing is wrong with my car, yet to fix it though, prolly takin it to the dealer soon

IF YOU POST IT -- THEY WILL COME
Joined: Sep 2003
Posts: 1,261
rem
Specialist
rem Jul 13, 5:46am - #184145 
2000 arrest me red Toyota Celica GT
Specialist
2000 Toyota Celica GT

Joined: Sep 2003
Posts: 1,261
1228 celica blvd
weird it happened to two of my friends also. FACTORY RECALL! lol. jk

Originally Posted by bmw52786
Originally Posted by rem
ok guys.. something weird with my car.

NORMALLY when i gun it with the car.. it would kick in like a sec later and start picking up..


and NOW, when i press the pedal all the way down it sounds like its ready to take off, but then it takes about 3 seconds sometimes 4 to finally register that im trying to make it go.. its really weird.. and my CEL light is on.. i tried resetting battery and all.. and it still does it and the CEL light just comes back on. you think maybe i have to clean the MAF sensor on my Intake? or maybe hoses on my Intake is not on tight enough?.. i have no clue guys.. maybe someone has same problem as me..

help me resolve this issue!! cry


same thing is wrong with my car, yet to fix it though, prolly takin it to the dealer soon
Joined: Jun 2003
Posts: 57
CsGTS
Member
CsGTS Jul 13, 6:53am - #184146 
2000 Abosolutely Red Toyota Celica
Member
2000 Toyota Celica

Joined: Jun 2003
Posts: 57
Arcadia, Ca
the best thing to do is take it to the dealer and get a overlook on the problem , then concider if you can get it done cheaper somewhere else, if you don't have warranty...
Join the conversation - Register now or Sign in to add your comment


Moderated by  isaac 

Customize Your Toyota CelicaPrivacy Policy · About · Contact
CelicaHobby.com is an independent Toyota Celica enthusiast website. CelicaHobby.com is not sponsored by or affiliated with Toyota Motor Sales, USA, Inc. in any way. The Toyota and Celica names and logos are trademarks owned by Toyota Motor Sales, USA, Inc.
© CelicaHobby.com, 2001-2016