Previous Thread
Next Thread
New Reply
Print Thread
Injen CAI Problems! #172225 May 5, 2:34pm May 5, 2:34pm
Joined: Dec 2003
Posts: 775
MN
tgts2000 OP
Senior Member
2002 Acura RSX-S
tgts2000 OP

Senior Member
2002 Acura RSX-S

Joined: Dec 2003
Posts: 775
MN
Injen CAI Problems!
Hey i got a CEL a few days ago, took it to Autozone and got the code P0172, the guy said i was running too rich.. does anyone know what I could do to fix this?!?!? Thanks!

Re: Injen CAI Problems! [Re: tgts2000] #172226 May 5, 2:48pm May 5, 2:48pm
Joined: Nov 2003
Posts: 453
Marietta, GA
Jtultra
Senior Member
2000 Toyota Celica
Jtultra

Senior Member
2000 Toyota Celica

Joined: Nov 2003
Posts: 453
Marietta, GA
check your to see if you have everything tight, make sure all hoses are secured/bypassed correctly, and Clean MAF sensor


The 2ZZ god
Re: Injen CAI Problems! [Re: Jtultra] #172227 May 5, 2:49pm May 5, 2:49pm
Joined: Jan 2003
Posts: 1,619
Pennsylvania
LostAngel
Specialist
LostAngel

Specialist

Joined: Jan 2003
Posts: 1,619
Pennsylvania
did you trey resetting your ECU? Unplug your battery for a lil bit. That might help.

Re: Injen CAI Problems! [Re: Jtultra] #172228 May 5, 4:20pm May 5, 4:20pm
Joined: Dec 2003
Posts: 775
MN
tgts2000 OP
Senior Member
2002 Acura RSX-S
tgts2000 OP

Senior Member
2002 Acura RSX-S

Joined: Dec 2003
Posts: 775
MN
I checked and resecured all hoses, and I did clean the MAFS, and doesnt disconnecting the battery make it go away for a little while then it just comes back?

Re: Injen CAI Problems! [Re: tgts2000] #172229 May 5, 6:10pm May 5, 6:10pm
Joined: Nov 2003
Posts: 53
san diego ca 858
gtsbryan
Member
2000 Toyota Celica GTS
gtsbryan

Member
2000 Toyota Celica GTS

Joined: Nov 2003
Posts: 53
san diego ca 858
MY CAR HAS THE SAME PROBLEM --- PEOPLE SAY THE ECU TURNS ITSELF TO "SAFE MODE" --- BATTARY WILL ONLY TURN IT OFF FOR 3 - 4 MILES THE ONLY THING YOUR DOING WHEN YOUR DISCON'IN THE BATTERY IS RESETING THE ECU..SO YOUR REALY NOT DOING DIDDLY... ITS BETTER YOU LEAVE THE CHK LIGHT ON... TILL YOU FIX THE PROBLEM... ADVISE CHANGE BACK TO STOCK SEE IF THAT HELPS IF NOT THEN THAT WHAT YOU GET FOR GETTING A TOYOTA ... I HATE TOYOTA FOR THIS ... THIS PROBLEM IS ALWASY GUNNA BE AN ISSUSE...

1869974744-bryan1.jpg
Re: Injen CAI Problems! [Re: gtsbryan] #172230 May 6, 9:14am May 6, 9:14am
Joined: Dec 2003
Posts: 775
MN
tgts2000 OP
Senior Member
2002 Acura RSX-S
tgts2000 OP

Senior Member
2002 Acura RSX-S

Joined: Dec 2003
Posts: 775
MN
TTT I need help!

Re: Injen CAI Problems! [Re: tgts2000] #172231 May 6, 9:16am May 6, 9:16am
Joined: Apr 2003
Posts: 1,899
Maryland
2003 silver streak Toyota Celica GT Gen7fan
ThE iRoN mAiDeN
2003 Toyota Celica GT
Gen7fan
2003 silver streak Toyota Celica GT
ThE iRoN mAiDeN
2003 Toyota Celica GT

Joined: Apr 2003
Posts: 1,899
Maryland
go back to stock and see if it goes away.

Re: Injen CAI Problems! [Re: Gen7fan] #172232 May 6, 11:44am May 6, 11:44am
Joined: Jul 2003
Posts: 1,143
Austin, TX
2000 Black Toyota Celica GT booyaolian
Specialist
2000 Toyota Celica GT
booyaolian
2000 Black Toyota Celica GT
Specialist
2000 Toyota Celica GT

Joined: Jul 2003
Posts: 1,143
Austin, TX
this thread makes me think twice if i should get a SRI

anyway...i will get header first

Re: Injen CAI Problems! [Re: booyaolian] #172233 May 6, 2:07pm May 6, 2:07pm
Joined: Jul 2003
Posts: 584
LA 626 area
RyCeCuBe
Senior Member
01 Toyota Celica GT
RyCeCuBe

Senior Member
01 Toyota Celica GT

Joined: Jul 2003
Posts: 584
LA 626 area
i used to have check engine light problems, i used to think it was the Cold Air Intake..but tunrs out because i had an exhaust leak and after i fixed it, no more check engine light, yay!


[Linked Image]
Re: Injen CAI Problems! [Re: tgts2000] #172234 May 6, 9:16pm May 6, 9:16pm
Joined: Jul 2003
Posts: 16
gtsleeper
Member
gtsleeper

Member

Joined: Jul 2003
Posts: 16
the same thing happen to me I took it to toyota and they didn't even know so i decided to give it a try and clean the maf sensor the light is off now and don't have any problems with just try to clean it really good until there is no more dirt residue on the tip on the sensor but be careful if you break it, it'll cost you big $$$ but give it a try i'll bet you 100% that will solve your problem

note: remember to disconnect your battery when cleaning the sensor

Re: Injen CAI Problems! [Re: gtsleeper] #172235 May 6, 9:21pm May 6, 9:21pm
Joined: Aug 2003
Posts: 128
San Diego, CA
Ferris
Member
2002 Toyota Celica
Ferris

Member
2002 Toyota Celica

Joined: Aug 2003
Posts: 128
San Diego, CA
Word...clean the maf sensor perfectly. Not much you can do other than that...other than sell it and get an AEM CAI which is better overall in my opinion. Sorry you are having problems and good luck.


02 GT-S R.I.P.
00 S2000
Re: Injen CAI Problems! [Re: Ferris] #172236 May 21, 8:33am May 21, 8:33am
Joined: Dec 2003
Posts: 775
MN
tgts2000 OP
Senior Member
2002 Acura RSX-S
tgts2000 OP

Senior Member
2002 Acura RSX-S

Joined: Dec 2003
Posts: 775
MN
UPDATE: I was going to put my stock air box back in last night and see if the CEL would go away but before i did that I took out my Injen Intake 100% then reinstalled it, reconnected all hoses and put the filter back on, started my car back up CEL was still on. Got in the car this morning and after about 10 minutes of driving it shut off!! So far so good!! thumbsup

Re: Injen CAI Problems! [Re: tgts2000] #172237 May 21, 11:01am May 21, 11:01am
Joined: Feb 2004
Posts: 1,716
Nebraska
celicafourotwo
Specialist
2000 Toyota Celica
celicafourotwo

Specialist
2000 Toyota Celica

Joined: Feb 2004
Posts: 1,716
Nebraska
^^^good deal..did you disc the bat..b4 installing??


Originally Posted by pesho01
Question:
Whenever my car is at a full stop or even in park the RPM never sits on 0. what does this mean?
Re: Injen CAI Problems! [Re: celicafourotwo] #172238 May 21, 12:06pm May 21, 12:06pm
Joined: Dec 2003
Posts: 775
MN
tgts2000 OP
Senior Member
2002 Acura RSX-S
tgts2000 OP

Senior Member
2002 Acura RSX-S

Joined: Dec 2003
Posts: 775
MN
Originally Posted by celicafourotwo
^^^good deal..did you disc the bat..b4 installing??


Nope i didnt even reset the ECU, so I know its fixed!! grin

Re: Injen CAI Problems! [Re: tgts2000] #172239 May 21, 3:22pm May 21, 3:22pm
Joined: Feb 2004
Posts: 1,716
Nebraska
celicafourotwo
Specialist
2000 Toyota Celica
celicafourotwo

Specialist
2000 Toyota Celica

Joined: Feb 2004
Posts: 1,716
Nebraska
it's a good thing it went away..but i think you might have forgotten to unhook the bat. the first time you install ur Intake..maybe that's y you got the light..but if it dont' show now then it's all good..


Originally Posted by pesho01
Question:
Whenever my car is at a full stop or even in park the RPM never sits on 0. what does this mean?
Re: Injen CAI Problems! [Re: celicafourotwo] #172240 May 21, 4:24pm May 21, 4:24pm
Joined: Mar 2004
Posts: 372
darksidecelica
Member
2001 Toyota Celica
darksidecelica

Member
2001 Toyota Celica

Joined: Mar 2004
Posts: 372
my CEL came on the first time i installed my Intake but after disconnecting the battery the CEL hasnt come back since

Re: Injen CAI Problems! [Re: gtsbryan] #172241 May 21, 4:28pm May 21, 4:28pm
Joined: Aug 2003
Posts: 2,269
Seattle, WA
NorwayGT
Specialist
2004 Dodge SRT4
NorwayGT

Specialist
2004 Dodge SRT4

Joined: Aug 2003
Posts: 2,269
Seattle, WA
Originally Posted by gtsbryan
MY CAR HAS THE SAME PROBLEM --- PEOPLE SAY THE ECU TURNS ITSELF TO "SAFE MODE" --- BATTARY WILL ONLY TURN IT OFF FOR 3 - 4 MILES THE ONLY THING YOUR DOING WHEN YOUR DISCON'IN THE BATTERY IS RESETING THE ECU..SO YOUR REALY NOT DOING DIDDLY... ITS BETTER YOU LEAVE THE CHK LIGHT ON... TILL YOU FIX THE PROBLEM... ADVISE CHANGE BACK TO STOCK SEE IF THAT HELPS IF NOT THEN THAT WHAT YOU GET FOR GETTING A TOYOTA ... I HATE TOYOTA FOR THIS ... THIS PROBLEM IS ALWASY GUNNA BE AN ISSUSE...

please tell me that you didnt paint your kit black to make it look like it was carbon fiber or something rolleyes


was....5speed with i/h/e
15.41 @ 89.30mph 2.282 60'

is....04 srt4 stock
13.936 100.15mph 2.177 60'
Re: Injen CAI Problems! [Re: NorwayGT] #172242 May 26, 12:48am May 26, 12:48am
Joined: Jan 2004
Posts: 98
California
BAC
Member
2000 Toyota Celica GT
BAC

Member
2000 Toyota Celica GT

Joined: Jan 2004
Posts: 98
California
what do i clean the MAF sensor with? my cel keeps lighting up? DO i need to clean my Intake filter or get a new one? just a thought...i took a look at the maf sensor and saw that the tip of the q-tip looking thingy is all covered with dirt..what do i clean it with? thanks for the help...greatly appreciated

Re: Injen CAI Problems! [Re: BAC] #172243 May 26, 1:17am May 26, 1:17am
Joined: Oct 2003
Posts: 1,549
Detroit
JBing
Pizza Geek
2002 Toyota Celica GT
JBing

Pizza Geek
2002 Toyota Celica GT

Joined: Oct 2003
Posts: 1,549
Detroit
I had the same problem when I installed mine at first, turned out that I hadnt pushed the mass air plug in all the way thumbsup


FS: 19" ADR M Sports
Re: Injen CAI Problems! [Re: BAC] #172244 May 26, 6:57am May 26, 6:57am
Joined: Dec 2003
Posts: 775
MN
tgts2000 OP
Senior Member
2002 Acura RSX-S
tgts2000 OP

Senior Member
2002 Acura RSX-S

Joined: Dec 2003
Posts: 775
MN
Originally Posted by BAC
what do i clean the MAF sensor with? my cel keeps lighting up? DO i need to clean my Intake filter or get a new one? just a thought...i took a look at the maf sensor and saw that the tip of the q-tip looking thingy is all covered with dirt..what do i clean it with? thanks for the help...greatly appreciated


Use q tips and choke & throttle body cleaner! thumbsup

Re: Injen CAI Problems! [Re: tgts2000] #172245 May 27, 11:39pm May 27, 11:39pm
Joined: Jan 2004
Posts: 98
California
BAC
Member
2000 Toyota Celica GT
BAC

Member
2000 Toyota Celica GT

Joined: Jan 2004
Posts: 98
California
whats the mass air plug?

Re: Injen CAI Problems! [Re: BAC] #172246 May 28, 6:12am May 28, 6:12am
Joined: Sep 2003
Posts: 476
Mass
2000 Spectra BLUE BABY! Toyota Celica Easy_C
Senior Member
2000 Toyota Celica
Easy_C
2000 Spectra BLUE BABY! Toyota Celica
Senior Member
2000 Toyota Celica

Joined: Sep 2003
Posts: 476
Mass
lol this is a common problem with Injen and AEM CAI's...maybe you should consider getting a better Intake. I honestly dont think anything you can do will change it unless of course you installed it incorrectly which it sounds like your installation is fine


TPR Intake! - Injens high end with AEM's low end and NO BOGGING!
TPR EXHAUST! - Exhaust made 10.5 whp peak and 32 whp at 6300 on my car!!!
http://www.tuningprecisionracing.com/shop
Re: Injen CAI Problems! [Re: Easy_C] #172247 May 28, 6:42am May 28, 6:42am
Joined: Apr 2004
Posts: 162
Kentucky
jenn1356
Member
2000 Toyota Celica GT
jenn1356

Member
2000 Toyota Celica GT

Joined: Apr 2004
Posts: 162
Kentucky
tgts, I wouldn't worry about it. I've had my celi with a CEL on and off for the last 2 years-I even went to the extent of changing both oxygen sensors-lots of $$$$, and it still didn't help even though it read the same. My car is still in great condition and it flies-just listen to it-it'll tell you if somethin's wrong!! It'll be okay!

Injen CAI Problems! [Re: jenn1356] #172248 May 28, 2:40pm May 28, 2:40pm
Joined: Oct 2003
Posts: 166
Houston, tx
celica_182
Member
2002 Toyota Celica GT
celica_182

Member
2002 Toyota Celica GT

Joined: Oct 2003
Posts: 166
Houston, tx
I install My Injen CAI with No problems at all try to secure all the hoses.

Re: Injen CAI Problems! [Re: celica_182] #172249 May 28, 3:58pm May 28, 3:58pm
Joined: Aug 2003
Posts: 203
Virginia Beach, VA
corruptor
Member
05 Mitsubishi EVO VIII
corruptor

Member
05 Mitsubishi EVO VIII

Joined: Aug 2003
Posts: 203
Virginia Beach, VA
I think it also has something to do with the year. I have an 03, and my light's always on. Everyone I know with an 03 has the light prob. Everyone I know with an 01, and earlier don't have that prob. I think the 02s are fine as well, not sure. If you look at the wiring, the 03s will have 2 plugs not connected, where as the previous models will only have 1 not connected. The previous models have some kinda extra thing connect up to a hose that's on the driver's side firewall.

Re: Injen CAI Problems! [Re: corruptor] #172250 May 29, 2:02pm May 29, 2:02pm
Joined: Jan 2004
Posts: 744
Freehold, NJ
2000 Spectra Blue Mica Toyota Celica Blue_Bomber
Senior Member
2000 Toyota Celica
Blue_Bomber
2000 Spectra Blue Mica Toyota Celica
Senior Member
2000 Toyota Celica

Joined: Jan 2004
Posts: 744
Freehold, NJ
Originally Posted by booyaolian
this thread makes me think twice if i should get a SRI

anyway...i will get header first
SRIs have just as many problems, because just about all Intakes are made improperly. Cheap research = cheap product = CEL
Originally Posted by tgts2000
Use q tips and choke & throttle body cleaner! thumbsup
Non-chloronated brake cleaner is the safest stuff to use. Some throttle body cleaners can actually damage MAF sensors (says so right on the can), and they're not cheap at all to replace.

Re: Injen CAI Problems! [Re: Blue_Bomber] #172251 May 29, 3:05pm May 29, 3:05pm
Joined: Dec 2003
Posts: 775
MN
tgts2000 OP
Senior Member
2002 Acura RSX-S
tgts2000 OP

Senior Member
2002 Acura RSX-S

Joined: Dec 2003
Posts: 775
MN
^^ I just used what was recommended in the Install Guide, I didnt know it could be damaging?!? confused

Re: Injen CAI Problems! [Re: tgts2000] #172252 Jun 3, 9:13pm Jun 3, 9:13pm
Joined: Jun 2002
Posts: 10
Phoenix, AZ
JAndre
Member
JAndre

Member

Joined: Jun 2002
Posts: 10
Phoenix, AZ
The CEL problem really sucks! I moved to Boston, so I put my Celica (Sasha) up for sell, very reluctantly. My CEL has been on for the past 2 years, and it still drives great, but try telling that to someone that wants to buy the car.

I have to get this fixed, and I think it may mean going back to the stock Air Filter. The only problem is I'm on the east coast, and my car is at my mom's in Arizona. I can take care of the problem, but the girl that wants to buy it is trying to get me to drop the price down $1000 for that...YEAH RIGHT!

Re: Injen CAI Problems! [Re: JAndre] #172253 Jun 4, 9:29am Jun 4, 9:29am
Joined: Sep 2003
Posts: 476
Mass
2000 Spectra BLUE BABY! Toyota Celica Easy_C
Senior Member
2000 Toyota Celica
Easy_C
2000 Spectra BLUE BABY! Toyota Celica
Senior Member
2000 Toyota Celica

Joined: Sep 2003
Posts: 476
Mass
lol JAndre would you be interested in trying an Intake that doesnt have a CEL, and has better power? Im in mass too right outside the boston suburbs.


TPR Intake! - Injens high end with AEM's low end and NO BOGGING!
TPR EXHAUST! - Exhaust made 10.5 whp peak and 32 whp at 6300 on my car!!!
http://www.tuningprecisionracing.com/shop
Re: Injen CAI Problems! [Re: Easy_C] #172254 Jun 7, 10:24am Jun 7, 10:24am
Joined: Jun 2002
Posts: 10
Phoenix, AZ
JAndre
Member
JAndre

Member

Joined: Jun 2002
Posts: 10
Phoenix, AZ
What Intake would you recommend. I'm going to go back to AZ 4th of July weekend and try to take care of the CEL. I'd rather put a Short Ram Intake on. The girl that's buying it would never be able to deal with the CAI. It would take her years to find the filter.

Re: Injen CAI Problems! [Re: RyCeCuBe] #172255 Jun 7, 10:27am Jun 7, 10:27am
Joined: May 2002
Posts: 6,007
Los Angeles, CA
2001 Absolutely Red Toyota Celica GT isaac
ECelica Admin
2001 Toyota Celica GT
isaac
2001 Absolutely Red Toyota Celica GT
ECelica Admin
2001 Toyota Celica GT

Joined: May 2002
Posts: 6,007
Los Angeles, CA
Originally Posted by Lee_H
i used to have check engine light problems, i used to think it was the cold air Intake..but tunrs out because i had an exhaust leak and after i fixed it, no more check engine light, yay!


ditto thumbsup


[Linked Image]
It's not just your imagination...
Your day really does go by twice as fast while on EverythingCelica.com
Re: Injen CAI Problems! [Re: isaac] #172256 Jun 7, 3:59pm Jun 7, 3:59pm
Joined: Feb 2004
Posts: 96
San Diego, CA
2004 Absolutely Red Toyota Celica Evil_Irish
Bad Toyo
2004 Toyota Celica
Evil_Irish
2004 Absolutely Red Toyota Celica
Bad Toyo
2004 Toyota Celica

Joined: Feb 2004
Posts: 96
San Diego, CA
my CEL came on too...but after 2 days of driving...I rechecked everything...even had Josh look at it and see if I missed anything...cleaned the MAF Sensor...and still NO JOY...the light remains! frown


i do have a question though that wasn't covered in the install guides...

The vacuum hose that has a "y" splitter on it ...connects to the head...and under the stock air box...

I plugged the little vacuum port coming out of the head like the instructions said...but nothing was said about the line that was left hanging there...does it just stay there...or get plugged? Or what? confused


2004 Celica GT-S
A.K.A. "Bad Toyo"
Join the conversation - Register Now or Log In to add your comment


Moderated by  isaac 

Member Spotlight
Kim
Kim
2002 Toyota Celica GT
Bellflower, CA

Posts: 982
Joined: July 2002
Thanks: Isaac, Steven, James and Danny (@ SIX autoworks)
Random: I'm gonna be the fastest street driver!
Show All Member Profiles 
Recent Topics
FS: 18 in rims Rays Wolf 77
by WAYNESKI777. 09/20/2017 10:02 AM
Need help wiring a splice in tail light converter.
by seefeldt321. 09/19/2017 3:26 PM
System 10 Speakers not working
by willlcurry. 09/18/2017 3:35 PM
how do u bleed clutch line
by scorpionafw. 09/12/2017 3:20 PM
CELICA GEN 7 WELCOME DOOR LIGHTS
by Jinxy1965. 09/10/2017 1:36 PM
Need advice with buying Celica GT 2005 (t23)
by DarkSorrow. 09/05/2017 10:51 AM
Need advice on my engine.
by Tameah21. 09/05/2017 6:39 AM
Help! Looking to replace all 4 shocks & springs + rear calipers
by Kristofer. 09/03/2017 9:25 PM
Customize Your Toyota Celica Privacy Policy · About · Contact
Privacy Policy · About · Contact
CelicaHobby.com is an independent Toyota Celica enthusiast website. CelicaHobby.com is not sponsored by or affiliated with Toyota Motor Sales, USA, Inc. in any way. The Toyota and Celica names and logos are trademarks owned by Toyota Motor Sales, USA, Inc.
© CelicaHobby.com, 2001-2017
Powered by UBB.threads™ PHP Forum Software 7.6.1
(Snapshot build 20170920)