Previous Thread
Next Thread
New Reply
Print Thread
Rate Thread
12s not workin #170285 May 2, 9:21pm May 2, 9:21pm
Joined: Jul 2003
Posts: 523
austin tx
jgmx OP
Senior Member
jgmx OP
Senior Member

Joined: Jul 2003
Posts: 523
austin tx
12s not workin
hey guys i upgradeded my 10s to 2 12s... it was workin all good...

but when i was listenin to em w/ the ignition key towards me(so that way it wont hurt the battery) then i turn the ignition key to the other way to start the car and then the subs sotoped workin... it kinda blew the fuse... so i replaced it, and now when i try to ground the amp it always blows the fuse, and some smoke was comin from the amp...

do you guys have any idea what could be happenin??

i'd appreciate any help, thanks guys rice


"The girls are more impressed when you have a 6-pack than when you finish one"
Quote:
Originally posted by Virgilson:
[b]

All I Want is Bang Bang Bang!!!
Re: 12s not workin [Re: jgmx] #170286 May 2, 9:27pm May 2, 9:27pm
Joined: Jan 2004
Posts: 1,248
Idaho Falls, ID
Rocketman
Specialist
01 Toyota Celica
Rocketman
Specialist
01 Toyota Celica

Joined: Jan 2004
Posts: 1,248
Idaho Falls, ID
If smoke was comming from the amp...that is usually not a good sign man. eek

Re: 12s not workin [Re: Rocketman] #170287 May 2, 9:38pm May 2, 9:38pm
Joined: Mar 2004
Posts: 372
darksidecelica
Member
2001 Toyota Celica
darksidecelica
Member
2001 Toyota Celica

Joined: Mar 2004
Posts: 372
you shoulda removed the power wire before grounding the amp...if smoke was comin from the amp you most likely burned out ur amp...how many watts is ur amp and how many watts can ur amp wires handle?

Re: 12s not workin [Re: darksidecelica] #170288 May 2, 9:41pm May 2, 9:41pm
Joined: Jul 2003
Posts: 523
austin tx
jgmx OP
Senior Member
jgmx OP
Senior Member

Joined: Jul 2003
Posts: 523
austin tx
450watts for the amp

and the wires 500watts


it suckz...

do you guys think that the warranty will cover it...?? frown


"The girls are more impressed when you have a 6-pack than when you finish one"
Quote:
Originally posted by Virgilson:
[b]

All I Want is Bang Bang Bang!!!
Re: 12s not workin [Re: jgmx] #170289 May 2, 9:43pm May 2, 9:43pm
Joined: Jul 2003
Posts: 523
austin tx
jgmx OP
Senior Member
jgmx OP
Senior Member

Joined: Jul 2003
Posts: 523
austin tx
theres this light in the amp that says protect which is red and its on???


"The girls are more impressed when you have a 6-pack than when you finish one"
Quote:
Originally posted by Virgilson:
[b]

All I Want is Bang Bang Bang!!!
Re: 12s not workin [Re: jgmx] #170290 May 24, 11:14am May 24, 11:14am
Joined: Mar 2004
Posts: 9
Northern VA
L
LowClass
New Member
1991 Nissan 300ZX
LowClass
L
New Member
1991 Nissan 300ZX

Joined: Mar 2004
Posts: 9
Northern VA
dissconnect the main power wire, ground the amp, mAKe sure you have tohe correct fuse within a foot of your battery, and your ground wire needs to be no loger then a foot and a half long. after you hav edone that make sure all the fuses are of the correct size and then try again. if its still going into protect that means that that amp can not handle the load it takes to push those 2 12's


LOW CLASS CUSTOMS
Re: 12s not workin [Re: LowClass] #170291 May 24, 11:21am May 24, 11:21am
Joined: Apr 2004
Posts: 338
Macomb IL
Brian63
Member
2000 Toyota Celica
Brian63
Member
2000 Toyota Celica

Joined: Apr 2004
Posts: 338
Macomb IL
I will have to say that when smokes comes from your amp its usually dead. But if you get it replaced disconnect the power wire or take the fuse out before you ground it. Also make sure your wire is big enough. I use 4 awg on my 1000/1 and thats plenty big.

Join the conversation - Register Now or Log In to add your comment


Moderated by  isaac 

Member Spotlight
JoInME4aRidE_dup1
JoInME4aRidE_dup1
2001 Toyota Celica
Jersey City

Posts: 30
Joined: August 2004
Show All Member Profiles 
Recent Topics
2000 OEM JDM Celica Door Sill Kick Plates
by TweakMaster. 10/23/2017 3:26 PM
Resurrecting a 2000 GT automatic.
by cosmo64. 10/19/2017 1:19 PM
APR strut bar brace for 2000 GTS
by TweakMaster. 10/15/2017 8:02 PM
Help with vacuum hose
by Chaos. 10/15/2017 6:07 PM
My 2000 GTS
by TweakMaster. 10/14/2017 6:29 PM
Replaced bad MAF. Now getting p0300/p1300 CEL codes. HELP!
by Bblee1989. 10/14/2017 4:34 PM
What kind of rim is this?
by mariahjordan. 10/10/2017 8:05 PM
Changed Headlight but so Dimm
by smsih. 10/10/2017 2:55 PM
Customize Your Toyota Celica Privacy Policy · About · Contact
Privacy Policy · About · Contact
CelicaHobby.com is an independent Toyota Celica enthusiast website. CelicaHobby.com is not sponsored by or affiliated with Toyota Motor Sales, USA, Inc. in any way. The Toyota and Celica names and logos are trademarks owned by Toyota Motor Sales, USA, Inc.
© CelicaHobby.com, 2001-2017
Powered by UBB.threads™ PHP Forum Software 7.6.1
(Snapshot build 20171020)