Previous Thread
Next Thread
New Reply
Print Thread
Joined: Sep 2003
Posts: 705
SSCarbonGTS
Senior Member
SSCarbonGTS Apr 26, 5:46pm - #165392 

Senior Member
2000 Toyota Celica

Joined: Sep 2003
Posts: 705
Quebec, Canada
Rpm problem

When I came back from lunch... and I entered in my parking... the RPM was unstable... it pass from 700 to 200-400... several time...

Just like the engine will stop...
the engine temp was normal...(not cold)
It's a rainy outside...

What do you think is it ??

I have a Injen SRI... the fuel was full(with premium)

should I clean my MAF, my injector, my trottle body ??

Thanks in advance !! wave

[Linked Image]
Mom, I Lost you on April 7th 2004, but I will remember you for ever... I'm missing you
Joined: Jul 2003
Posts: 2,043
trog2233
ECelica Staff
trog2233 Apr 26, 5:52pm - #165393 

ECelica Staff
2004 GMC Canyon Z-71

Joined: Jul 2003
Posts: 2,043
Williamsport, PA
yes mine does the same thing...clean ur MAF thumbsup
Joined: Sep 2003
Posts: 705
SSCarbonGTS
Senior Member
SSCarbonGTS Apr 26, 5:57pm - #165394 

Senior Member
2000 Toyota Celica

Joined: Sep 2003
Posts: 705
Quebec, Canada
thanks ! thumbsup

[Linked Image]
Mom, I Lost you on April 7th 2004, but I will remember you for ever... I'm missing you
Joined: Jul 2003
Posts: 1,143
booyaolian
Specialist
booyaolian Apr 26, 7:25pm - #165395 
2000 Black Toyota Celica GT
Specialist
2000 Toyota Celica GT

Joined: Jul 2003
Posts: 1,143
Austin, TX
my car does the same thing...

i cleaned my MAF...and the problem disappeared!

but after a week...the problem came back!
Joined: Jul 2003
Posts: 460
theretiredpimp
Senior Member
theretiredpimp Apr 26, 7:33pm - #165396 

Senior Member
2000 Toyota Celica GT

Joined: Jul 2003
Posts: 460
Camden, NJ
I have the same problem too. I'll try cleaning the MAF and hope it'll take care of the problem.

They call me Superman, leap tall hoes in a single bound...
Joined: Oct 2003
Posts: 1,864
stefanoc
Specialist
stefanoc Apr 26, 7:58pm - #165397 

Specialist
2002 Toyota Celica

Joined: Oct 2003
Posts: 1,864
CA
how often do you ahve to clean the MAF sensor anyways? seems like everyone is having problems with it
Joined: Nov 2002
Posts: 1,073
grcelica
Specialist
grcelica Apr 27, 1:20am - #165398 

Specialist
2001 Toyota Celica GT

Joined: Nov 2002
Posts: 1,073
NW, PA
I cleaned mine once at 58,000k. Now I have 68,000k still all good! I have SRI also. Problem could also be a bad 02 sensor...
Joined: Oct 2003
Posts: 1,227
hephaestus
Specialist
hephaestus Apr 27, 3:23am - #165399 
Specialist

Joined: Oct 2003
Posts: 1,227
New Jersey
Just for good maintenance on your car you should, especially with any sort of Intake, clean the MAF reset the ECU and clean the throttle body including the IAC valve. It only takes a couple of dollars and a very little amount of time. When did you get your last tune up? I cleaned my IAC, throttle body, and had a tune up and no more problems since. The IAC valve is the thing that regulates your cars idle. It looks like a flathead srewdriver bolt on the bottom front of your throttle body. From the inside it has a slit towards the front on the bottom left centered. Try all the things listed here and previously. If these don't work take it into Toyota or a trusted knowledgeable mechanic.
Joined: Oct 2003
Posts: 1,227
hephaestus
Specialist
hephaestus Apr 27, 3:44am - #165400 
Specialist

Joined: Oct 2003
Posts: 1,227
New Jersey
By the way, from my own experience so it may differ. I cleaned my MAF once, a year after my Intake was installed when I was throwing a CEL. After I cleaned it the CEL was gone. A CEL shouldn't be shruged off for any reason. I haven't touched the MAF since. And this is maybe almost a year, changing filters, and disconnecting the damn CAI many times. Also tightening the throttle cable seems to be a fix here. It's good maintenance. You can try it, but then again from my own experience (and it may differ) it was only part of the problem or masked it. I'm glad I did it and had to do it again. A low idle should never be a quick tighten the throttle cable on any car. Unless you are the one who's cable went way lose by some misfortunate accident.
Joined: Sep 2003
Posts: 705
SSCarbonGTS
Senior Member
SSCarbonGTS Apr 27, 12:41pm - #165401 

Senior Member
2000 Toyota Celica

Joined: Sep 2003
Posts: 705
Quebec, Canada
thanks,

I cleaned my MAF yesterday, after works... and as far I as know the problem is solve... smile

Thanks everyone ! thumbsup wave

[Linked Image]
Mom, I Lost you on April 7th 2004, but I will remember you for ever... I'm missing you
Joined: Oct 2003
Posts: 1,572
DaBigTickett
Rip the Jacker
DaBigTickett Apr 27, 11:25pm - #165402 

Rip the Jacker
2002 Toyota Celica GT

Joined: Oct 2003
Posts: 1,572
Chino Hills, CA
Yup just clean the MAF.
Join the conversation - Register now or Sign in to add your comment


Moderated by  isaac 

Customize Your Toyota CelicaPrivacy Policy · About · Contact
CelicaHobby.com is an independent Toyota Celica enthusiast website. CelicaHobby.com is not sponsored by or affiliated with Toyota Motor Sales, USA, Inc. in any way. The Toyota and Celica names and logos are trademarks owned by Toyota Motor Sales, USA, Inc.
© CelicaHobby.com, 2001-2016