Previous Thread
Next Thread
New Reply
Print Thread
Joined: Nov 2003
Posts: 15
BioNeXuS
Member
BioNeXuS

Member
2003 Toyota Celica

Joined: Nov 2003
Posts: 15
Canada
Apr 8, 11:37am - #148761 
front washer fluid not working

Can anyone help me? I'm leaving town in a couple of hours and it would probably be nice to have some washer fluid...my motor for my front washer doesn't seem to work. No humming sound. I checked all the fuses and I checked the rear washer fluid and it works. I've only had the car for a couple of months so I don't think it's clogged or dirty. I don't have a strut bar either and I can't find any pinches. I'm curious if there are 2 washer motors or is there only one? Anyone got any ideas? Thanks.

Joined: Jul 2003
Posts: 2,043
trog2233
ECelica Staff
trog2233

ECelica Staff
2004 GMC Canyon Z-71

Joined: Jul 2003
Posts: 2,043
Williamsport, PA
Apr 8, 11:40am - #148762 
have you installed a strut bar lately? if so check to make sure you didn't pinch the line...i did that

Joined: Nov 2003
Posts: 15
BioNeXuS
Member
BioNeXuS

Member
2003 Toyota Celica

Joined: Nov 2003
Posts: 15
Canada
Apr 12, 4:57pm - #148763 
I don't have a strut bar yet. I checked all my fuses and I checked the hoses and they all seem ok. When I go to turn on my fluid, I don't hear the motor going. But when I use the rear fluid, it works. Does anyone know if there's two motors or not? Thanks.

Joined: Oct 2002
Posts: 175
megamanx
Member
megamanx

Member
00 Toyota Celica GT

Joined: Oct 2002
Posts: 175
Salt Lake City
Apr 12, 5:22pm - #148764 
i had the same problem, try it with your Hood open, if it works then make sure that your Hood is not pinching the line.

Joined: Jul 2002
Posts: 10,123
VSGTS14
05 WRB
VSGTS14

05 WRB
2005 Subaru WRX STi

Joined: Jul 2002
Posts: 10,123
Milford, NJ
Apr 12, 5:22pm - #148765 
there is no rear fluid?


SUBARU TECNICA INTERNATIONAL
Joined: Jun 2003
Posts: 2,863
v3n0m
Specialist
v3n0m

Specialist
2001 Toyota Celica GT

Joined: Jun 2003
Posts: 2,863
St. George, UT
Apr 12, 5:26pm - #148766 
we don't have one, only in the front

Joined: Jul 2002
Posts: 10,123
VSGTS14
05 WRB
VSGTS14

05 WRB
2005 Subaru WRX STi

Joined: Jul 2002
Posts: 10,123
Milford, NJ
Apr 12, 5:30pm - #148767 
Originally Posted by v3n0m
we don't have one, only in the front


he said when he uses the rear fluid, it works...lol


SUBARU TECNICA INTERNATIONAL
Joined: Nov 2003
Posts: 15
BioNeXuS
Member
BioNeXuS

Member
2003 Toyota Celica

Joined: Nov 2003
Posts: 15
Canada
Apr 13, 7:31am - #148768 
When I use the rear washer fluid, it works fine. But when I use the front, it doesn't work at all. I can't hear the motor going at all. I have tried it with the Hood open too. Maybe I blew a relay? Anyone know which relay it would be?

Join the conversation - Register Now or Log In to add your comment


Moderated by  isaac 

Member Spotlight
HunterGTS
HunterGTS
2000 Toyota Celica
Lexington, Kentucky

Posts: 49
Joined: August 2003
Random: Future Mods:
Wings West Body Kit
TRD Authentic Spoiler
Either Tein or TRD Suspenion revamp
The usual: Intake, Headers, Exhaust
Show All Member Profiles 
Recent Topics
2000 Celica GT instrument lights go out
by Herby. 07/19/2017 1:49 PM
Need some guidance to buying a celica!
by Hanate. 07/17/2017 4:23 PM
4th Gen owners...
by Cherry88Celica. 07/15/2017 1:04 AM
Can someone please help
by 96celicast. 07/13/2017 1:54 PM
Stock Stereo Volume Knob Removal???
by Katherine. 07/13/2017 8:35 AM
P1349 VVTI Malfunction
by ciaranleeman. 07/12/2017 6:42 AM
Toyota stearing logo faded :( please help
by kylecelica. 07/08/2017 9:47 PM
WTB: 01 1zz block and rebuild kit or 2zz trans ecu
by Tvpthemvp. 07/06/2017 12:02 AM
Customize Your Toyota Celica Privacy Policy · About · Contact
Privacy Policy · About · Contact
CelicaHobby.com is an independent Toyota Celica enthusiast website. CelicaHobby.com is not sponsored by or affiliated with Toyota Motor Sales, USA, Inc. in any way. The Toyota and Celica names and logos are trademarks owned by Toyota Motor Sales, USA, Inc.
© CelicaHobby.com, 2001-2017
Powered by UBB.threads™ PHP Forum Software 7.6.1
(Snapshot build 20170611)