Previous Thread
Next Thread
New Reply
Print Thread
Joined: Jan 2004
Posts: 125
iseaniebabyi
Member
iseaniebabyi Apr 4, 12:23am - #143964 
2003 silver Toyota Celica GT
Member
2003 Toyota Celica GT

Joined: Jan 2004
Posts: 125
Jersey City, NJ
problem with reverse indiglo gauges

ok i have a set of a/c autotechnic reverse indiglo s7 3d gauges. me and my friend installed it ourselves.

we connected everything correctly. we connected the power to the parking light and the ground to the cigarette lighter. and we checked all the connections and they're right. we followed everything exactly from the install guide from e-celica.com.

the problem is that it doesn't light up. any reasons why it wouldn't do so?

INJEN for your engine.
Joined: Sep 2003
Posts: 314
Johnny178
Member
Johnny178 Apr 4, 12:26am - #143965 

Member
2003 Toyota Celica GT

Joined: Sep 2003
Posts: 314
Charlotte, NC
test them from the battery
Joined: Dec 2003
Posts: 411
vietnamese2004
Senior Member
vietnamese2004 Apr 4, 2:40am - #143966 

Senior Member
2003 Toyota Celica

Joined: Dec 2003
Posts: 411
Canada - B.C - Vancouver
does the gauge make ur odo meter back to 0?
Joined: May 2003
Posts: 5,346
spaztikid
dikitzaps
spaztikid Apr 4, 2:53am - #143967 
dikitzaps
1974 Toyota Celica

Joined: May 2003
Posts: 5,346
LA
check connections with a multimeter.
Joined: Jan 2004
Posts: 125
iseaniebabyi
Member
iseaniebabyi Apr 4, 5:20am - #143968 
2003 silver Toyota Celica GT
Member
2003 Toyota Celica GT

Joined: Jan 2004
Posts: 125
Jersey City, NJ
well, it's actually working. at first i thought it was some rip-off that i got off ebay but everything is ok now.

i installed the gauges this afternoon into evening. but then it wasn't working. thats when i decided to leave a post up in here in the forum about my little problem. unfortunately for me, i had to go out tonight and i had no other choice but to take my car out. it made me feel so different driving without the lights in my gauges working, except for the needles. i was in my friend's house and when i alarmed my car, the lights from my gauges blinked. i was wtf?! but when i drove again, it didn't work until i hit a few bumps and then it turned back off. so while i was at a stop on a streetlight, i played with the wires and it seems to me that the power connection is loose. so tomorrow, i plan on fixing the problem tomorrow.

when i think about it, this was such a stupid problem. wtf

INJEN for your engine.
Joined: Aug 2003
Posts: 4,278
Virgilson
TheFilipinoCrew
Virgilson Apr 4, 5:23am - #143969 

TheFilipinoCrew
2000 Toyota Celica GT

Joined: Aug 2003
Posts: 4,278
Pomona, CA
rofl
Join the conversation - Register now or Sign in to add your comment


Moderated by  isaac 

Customize Your Toyota CelicaPrivacy Policy · About · Contact
CelicaHobby.com is an independent Toyota Celica enthusiast website. CelicaHobby.com is not sponsored by or affiliated with Toyota Motor Sales, USA, Inc. in any way. The Toyota and Celica names and logos are trademarks owned by Toyota Motor Sales, USA, Inc.
© CelicaHobby.com, 2001-2016