Previous Thread
Next Thread
New Reply
Print Thread
Joined: Sep 2003
Posts: 40
NeCelica
Member
NeCelica Apr 2, 9:08am - #142913 
Member

Joined: Sep 2003
Posts: 40
intake laggg "injen" helpppp plzzz.

does anybody have tis kind of problem before...i have CAI Injen Intake...i was reving at 2500 rpm and the whole car shaking and would not move, it seems dead for a momement...it seem like any thing under 4000 rpm the car is dead...but if i was rev 4000 rpm and up is find...could it happen b/c of to much air or what can i do about it...rev at 4000 rpm is kind of high i think...i install everything correctly..please help ppllllll...
Joined: May 2003
Posts: 583
Jae
Senior Member
Jae Apr 2, 10:21am - #142914 

Senior Member
2001 Toyota Celica

Joined: May 2003
Posts: 583
palm springs, burbank CA
we need more info.
is it gt or gts?
auto or manual?
are you talking about launching or just neutral reving?
then i might be answer your question
Joined: Aug 2003
Posts: 6,372
Speed4TheNeed
Caleb
Speed4TheNeed Apr 2, 12:39pm - #142915 

Caleb
2000 Toyota Celica

Joined: Aug 2003
Posts: 6,372
New Orleans, LA
how long have you had it? what condidtions do you drive in?

if it's a CAI they tend to get dirty rather quickly. if you've slung mud around the filter the air coudl have a hard time entering your engine at lower rpm's because your engine is sucking hard enough.

same thing if it's just old...the dirt will block air from entering your engine.

this would be more of a gradual thing though..like posted above me, we need a bit more info if we are to be able to help you more thumbsup
Joined: Jan 2003
Posts: 2,139
ct
C'mon & hit me!
ct Apr 2, 4:03pm - #142916 

C'mon & hit me!
2000 Toyota Celica GTS

Joined: Jan 2003
Posts: 2,139
Woodland Hills, CA
this is a dyno from Injen on a 6sp GTS...you will notice that it doesn't make a whole lot of power down low...you actually lose some...maybe this will explain the lag...

1869911853-injencai.jpg

Originally posted by SKOOF:
yoru such a clown, i wish you lived in nyc, i would love to just give you the beating that youve probably never gotten in your life.
Joined: May 2003
Posts: 5,346
spaztikid
dikitzaps
spaztikid Apr 2, 6:42pm - #142917 
dikitzaps
1974 Toyota Celica

Joined: May 2003
Posts: 5,346
LA
you need to clean your MAFS.

it will fix the problem.
Joined: Sep 2003
Posts: 40
NeCelica
Member
NeCelica Apr 2, 9:24pm - #142918 
Member

Joined: Sep 2003
Posts: 40
i have 2000 gts..its a manual by ta way..my car is at 63000 miles now...I din't even know it happen after a week later when i was trying to race...i lived in nebraska...my filter are clean...i check every single week and make sure there no mud or anything other component could block the air...the laughing is the problem...it seem the air is not flowing right or low air..by the way...wat maf...is that help after i clean it...how much it cost to clean it...w/ my stock air..there no problem...but ever since the CAI Injen Intake install...the laughing are really suck...could not even take off right away...also when i start my engine and take off right away..sometime there even a lag when i press on gas pedal..it stop for 3 second then go then stop.its weird ever since the Intake install...plezzz let me know about it...does everybody have tis problem w/ Injen Intake...?????
Joined: Oct 2002
Posts: 929
CID498
ECelica Staff
CID498 Apr 2, 9:37pm - #142919 

ECelica Staff
2000 Toyota Celica GT

Joined: Oct 2002
Posts: 929
So.Cal
Originally Posted by NeCelica
w/ my stock air..there no problem...but ever since the cai injen Intake install...the laughing are really suck...



Well then get ready fer some more laughing rofl

It may be a dirty mafs or an improperly installed one.
Joined: Sep 2003
Posts: 40
NeCelica
Member
NeCelica Apr 3, 7:31am - #142920 
Member

Joined: Sep 2003
Posts: 40
hey people...i need more help plzzzz...
Joined: May 2003
Posts: 2,454
Elec-FuYu
Specialist
Elec-FuYu Apr 3, 7:52am - #142921 
2003 Silver Toyota Celica
Specialist
2003 Toyota Celica

Joined: May 2003
Posts: 2,454
B.C. Coquitlam
did you check if the tube is broken??

I am a HID Maniac!!
Joined: Jan 2004
Posts: 1,612
eric_h
2low2slow
eric_h Apr 3, 4:10pm - #142922 

2low2slow
2002 Toyota Celica GT

Joined: Jan 2004
Posts: 1,612
St.George, UT
Originally Posted by Elec-FuYu
did you check if the tube is broken??


yeah thats happened to people before, makes me happy i have AEM

[Linked Image]
A boats a boat, but the mystery box could be anything....Even a boat!
Joined: Feb 2004
Posts: 70
SilverXtreme02
Member
SilverXtreme02 Apr 3, 5:13pm - #142923 
Member
2005 Scion TC

Joined: Feb 2004
Posts: 70
Hicksville, NY
after i first had my Injen CAI installed.. i was driving.. and sitting idle at a red light.. and it was like the car was having a heart attack.. it was stuttering.. and it stopped after i pulled into a parking lot and shut the car off and disconnected the battery then restarted the car.. it was fine after that.. i then later installed the Injen Short Ram.. and have had no complaints! (knock on wood) rofl
Joined: Sep 2003
Posts: 40
NeCelica
Member
NeCelica Apr 4, 7:09pm - #142924 
Member

Joined: Sep 2003
Posts: 40
so basically nothin i could due about it huh...everybody w/ Injen have a lag under 4000 then...let me update ppl...
Joined: Nov 2002
Posts: 1,073
grcelica
Specialist
grcelica Apr 4, 9:52pm - #142925 

Specialist
2001 Toyota Celica GT

Joined: Nov 2002
Posts: 1,073
NW, PA
Originally Posted by NeCelica
so basically nothin i could due about it huh...everybody w/ injen have a lag under 4000 then...let me update ppl...


Its not your Intake dood. One of two things:
1st clean your Mass Air Flow Sensor wire. Easy to do...check this site for instructions.
2nd.it could be your o2 sensor. If its bad you will run WAY lean. Cost ya about $130 to $150 to replace. When this is the case it makes your car run like you have bad gas or water in the gas. Hope this helps.
Joined: Feb 2004
Posts: 89
hucke150
Member
hucke150 Apr 4, 10:01pm - #142926 

Member

Joined: Feb 2004
Posts: 89
ohio
clean the maf air sensor
Joined: Oct 2003
Posts: 1,227
hephaestus
Specialist
hephaestus Apr 5, 1:05am - #142927 
Specialist

Joined: Oct 2003
Posts: 1,227
New Jersey
Have you taken care of you car's engine and the Intake? I've had an Injen CAI since they first made one for our cars. I've had all the problems associated with it including shaking, engine noise, poor idling, CEL, etc. A good tune-up (depending on the miles on your car) including engine purge, injectors cleaned, throttle cable, and throttle plate/throttle body (all could be done yourself with jack stands and the proper tools) will help. Check the connections everywhere including the one to your chasis. Also include cleaning the MAF properly and then resetting the ECU. Just proper maintenance for our cars. There is a bit of lag down low, but that's just Injen engineering. I have absolutley no problems with my CAI and Cels, acceleration, lag, throttle response, engine noise, or shaking for over a year. My Celica with 74,000 miles still wants to go fast all the time and smooth as butter.
Joined: Jul 2003
Posts: 409
Spencer
Senior Member
Spencer Apr 5, 1:13am - #142928 

Senior Member
2000 Toyota Celica

Joined: Jul 2003
Posts: 409
Dunn, NC
Originally Posted by hucke150
clean the maf air sensor


yes and takes 5 mins

https://www.celicahobby.com/ubbthreads/thread.f_1862388016_0_collapsed_2__1.html

To deny the simple pleasures in life is to desire death in the most horrifing way.
Joined: Sep 2003
Posts: 40
NeCelica
Member
NeCelica Apr 5, 5:05am - #142929 
Member

Joined: Sep 2003
Posts: 40
oohhh man...good response i got...i will try it tis week to see what happen...thanks for all the help plzzzz...
Join the conversation - Register now or Sign in to add your comment


Moderated by  isaac 

Customize Your Toyota CelicaPrivacy Policy · About · Contact
CelicaHobby.com is an independent Toyota Celica enthusiast website. CelicaHobby.com is not sponsored by or affiliated with Toyota Motor Sales, USA, Inc. in any way. The Toyota and Celica names and logos are trademarks owned by Toyota Motor Sales, USA, Inc.
© CelicaHobby.com, 2001-2016