Previous Thread
Next Thread
New Reply
Print Thread
Rate Thread
Need Help! #126801 Mar 16, 9:56am Mar 16, 9:56am
Joined: Feb 2004
Posts: 27
Wisconsin
00 red Toyota Celica GTS
ErikY OP
Member
00 Toyota Celica GTS
ErikY OP
00 red Toyota Celica GTS
Member
00 Toyota Celica GTS

Joined: Feb 2004
Posts: 27
Wisconsin
Need Help!
While trying to put in my AEM CAI i accidentally knocked the air flow sensor to the ground, the piece that the instruction tells you to be careful with because it can be broken easily. The CAI is not in yet, but now my car dies when i'm rolling in neutral and i stop! It also dies when i slowing down to turn in neutral too! If i leave it in neutral id doesn't die it only dies while rolling to a stop in neutral. Any ideas what's wrong with my car? It's a 00 GT's with about 38,000 miles on it. Do ya think the air flow sensor is broken cause i dropped it?

Re: Need Help! [Re: ErikY] #126802 Mar 16, 10:10am Mar 16, 10:10am
Joined: Jan 2004
Posts: 2,373
ATL GA
AZZKIKR
SHO - NUFF
2003 Toyota Celica GT
AZZKIKR
SHO - NUFF
2003 Toyota Celica GT

Joined: Jan 2004
Posts: 2,373
ATL GA
When I first Installed my AEM CAI, I forgot to hook the Air flow sensor back up, and had the same problem you're goin thru...so I popped my Hood, went back over the directions step by step, and discovered that I had forgotten to hook up the Air Flow Sensor when I put the CAI in...check all your connections, and check your air flow sensor for cracks...hope this helps thumbsup

Re: Need Help! [Re: ErikY] #126803 Mar 16, 10:13am Mar 16, 10:13am
Joined: Feb 2004
Posts: 27
Wisconsin
00 red Toyota Celica GTS
ErikY OP
Member
00 Toyota Celica GTS
ErikY OP
00 red Toyota Celica GTS
Member
00 Toyota Celica GTS

Joined: Feb 2004
Posts: 27
Wisconsin
Thanks bro! I'll look for cracks with the air flow sensor. Nice to know somebody had the same experience! This site rocks!

Re: Need Help! [Re: ErikY] #126804 Mar 16, 10:42am Mar 16, 10:42am
Joined: Feb 2004
Posts: 27
Wisconsin
00 red Toyota Celica GTS
ErikY OP
Member
00 Toyota Celica GTS
ErikY OP
00 red Toyota Celica GTS
Member
00 Toyota Celica GTS

Joined: Feb 2004
Posts: 27
Wisconsin
Fixed it! I'm an idiot! i forgot to connect to hoses to hte Intake! DIdn't mean to be a nuissance.

Re: Need Help! [Re: ErikY] #126805 Mar 16, 10:56am Mar 16, 10:56am
Joined: Jan 2004
Posts: 2,373
ATL GA
AZZKIKR
SHO - NUFF
2003 Toyota Celica GT
AZZKIKR
SHO - NUFF
2003 Toyota Celica GT

Joined: Jan 2004
Posts: 2,373
ATL GA
no worries bro...enjoy the CAI...I love my AEM...

Join the conversation - Register Now or Log In to add your comment


Moderated by  isaac 

Member Spotlight
ice33
ice33
2000 Toyota Celica GT
Austin, Tx.

Posts: 138
Joined: October 2003
Show All Member Profiles 
Recent Topics
APR strut bar brace for 2000 GTS
by TweakMaster. 10/15/2017 8:02 PM
Help with vacuum hose
by Chaos. 10/15/2017 6:07 PM
My 2000 GTS
by TweakMaster. 10/14/2017 6:29 PM
Replaced bad MAF. Now getting p0300/p1300 CEL codes. HELP!
by Bblee1989. 10/14/2017 4:34 PM
What kind of rim is this?
by mariahjordan. 10/10/2017 8:05 PM
Changed Headlight but so Dimm
by smsih. 10/10/2017 2:55 PM
Anyone know this remote unlock key? trying to ID it!
by kieronboz. 10/04/2017 2:36 AM
will C-one lip fit on TRD front bumper
by Mik3l. 09/30/2017 3:28 PM
Customize Your Toyota Celica Privacy Policy · About · Contact
Privacy Policy · About · Contact
CelicaHobby.com is an independent Toyota Celica enthusiast website. CelicaHobby.com is not sponsored by or affiliated with Toyota Motor Sales, USA, Inc. in any way. The Toyota and Celica names and logos are trademarks owned by Toyota Motor Sales, USA, Inc.
© CelicaHobby.com, 2001-2017
Powered by UBB.threads™ PHP Forum Software 7.6.1
(Snapshot build 20171017)